Bug 165811 - cproto Fedora Extras inclusion
cproto Fedora Extras inclusion
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: Package Review (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Michael Schwendt
David Lawrence
: FutureFeature
Depends On:
Blocks: FE-ACCEPT
  Show dependency treegraph
 
Reported: 2005-08-12 10:32 EDT by Jindrich Novy
Modified: 2013-07-02 19:09 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-08-17 03:56:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jindrich Novy 2005-08-12 10:32:31 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.10) Gecko/20050720 Fedora/1.0.6-1.1.fc4 Firefox/1.0.6

Description of problem:
Please review the latest cproto spec and propose changes if needed before Extras inclusion. There's no review needed since it's the former Core package, but I think it's not bad to review it anyway.

The cproto SRPM is located at:
http://people.redhat.com/jnovy/files/cproto-4.7c-6.src.rpm

Thanks.

Version-Release number of selected component (if applicable):
cproto-4.7c-6

How reproducible:
Always

Steps to Reproduce:
Reproduction isn't needed.

Additional info:
Comment 1 Michael Schwendt 2005-08-13 07:23:57 EDT
$ rpmlint cproto-4.7c-6.src.rpm 
W: cproto summary-ended-with-dot Generates function prototypes and variable
declarations from C code.
W: cproto no-url-tag
W: cproto redundant-prefix-tag
W: cproto hardcoded-path-in-buildroot-tag /var/tmp/%{name}-root
W: cproto patch-not-applied Patch1: cproto-4.6.1-patch
W: cproto patch-not-applied Patch3: cproto-4.6-bison.patch
W: cproto patch-not-applied Patch2: cproto-4.6-varargs.patch

> ./configure: line 3351: yacc: command not found

> make: yacc: Command not found
> make: *** [y.tab.c] Error 127

BuildRequires: byacc

> %configure --exec-prefix=%{_prefix}

The --exec-prefix=... argument is set by %configure already.

> ./grammar.y:824:21: error: lex.yy.c: No such file or directory
> ./grammar.y: In function 'yaccError':
> ./grammar.y:832: error: 'yytext' undeclared (first use in this function)

BuildRequires: flex

> Prefix: %{_prefix}

This is not only redundant (see rpmlint warning), it marks the package as being
relocatable (man rpm). If you really want that, please add a comment in the spec
file, which says so. At present, the package is relocatable (also because of
cproto's options -I and -E).
Comment 2 Jindrich Novy 2005-08-14 07:54:02 EDT
Thanks for the review. If there are no other objections, I'll import and build
this version of cproto:

http://people.redhat.com/jnovy/files/cproto-4.7c-7.src.rpm
Comment 3 Tom "spot" Callaway 2005-08-15 09:22:12 EDT
"There's no review needed since it's the former Core package"

Just a reminder: This is no longer valid. All FE packages must be reviewed,
whether they were in Core once or not.
Comment 4 Michael Schwendt 2005-08-16 17:57:23 EDT
Looks okay packaging-wise. Changing to FE-ACCEPT. These changes are still
preferred by packaging guidelines and rpmlint:

--- cproto.spec.orig    2005-08-13 15:42:41.000000000 +0200
+++ cproto.spec 2005-08-16 23:52:14.000000000 +0200
@@ -1,4 +1,4 @@
-Summary: Generates function prototypes and variable declarations from C code.
+Summary: Generates function prototypes and variable declarations from C code
 Name: cproto
 Version: 4.7c
 Release: 7
@@ -7,7 +7,7 @@
 Source: ftp://invisible-island.net/cproto/cproto-4_7c.tgz
 URL: http://invisible-island.net/
 BuildRequires: byacc, flex
-BuildRoot: %{_tmppath}/%{name}-root
+BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
 
 %description
 Cproto generates function prototypes and variable declarations from C
Comment 5 Jindrich Novy 2005-08-17 03:56:11 EDT
Ok, applied. The cproto package is now imported and initial build is in progress.

Thanks.
Comment 6 Ville Skyttä 2005-08-17 05:43:18 EDT
I don't think it's properly enqueued. 
http://buildsys.fedoraproject.org/build-status/indiv.psp?email=jnovy%40redhat.com 
 
You should be using "make plague" to enqueue build requests, not "make build". 
http://fedoraproject.org/wiki/Extras/BuildRequests 
Comment 7 Michael Schwendt 2005-08-17 07:34:42 EDT
The "tobuild" file is still imported by Seth from time to time, isn't it?
Else the move from "make build" to "make plague" has been unclear and
confusing to several packagers. In particular, since "make build" will
use plague-client as soon as the testing period is over.
Comment 8 Jindrich Novy 2005-08-17 07:42:26 EDT
Package cproto enqueued.  Job ID: 83.

Michael, yes, make plague doesn't look too intuitive ;-) I would be nice to see
make build working again.
Comment 9 Seth Vidal 2005-08-17 07:47:28 EDT
Michael,
 yes it is but school starts this week so I've been very busy. Could I ask you
to enqueue those builds?

Note You need to log in before you can comment on or make changes to this bug.