Bug 1658135 - [UPGRADES][14]Fail upgrade if deployment task fails
Summary: [UPGRADES][14]Fail upgrade if deployment task fails
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-tripleoclient
Version: 14.0 (Rocky)
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: z1
: 14.0 (Rocky)
Assignee: Jiri Stransky
QA Contact: Ronnie Rasouli
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-12-11 10:37 UTC by Yurii Prokulevych
Modified: 2019-07-02 20:08 UTC (History)
12 users (show)

Fixed In Version: python-tripleoclient-10.6.1-0.20190117233304.e780899.el7ost
Doc Type: Bug Fix
Doc Text:
Previously, an upgrade of director would continue with post-upgrade tasks, even if deployment Ansible tasks had failed. This was due to a missing return code check on deployment tasks, which has been added to correct this behavior.
Clone Of:
Environment:
Last Closed: 2019-07-02 20:08:26 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Launchpad 1805836 None None None 2018-12-11 11:14:55 UTC
OpenStack gerrit 622192 None stable/rocky: MERGED python-tripleoclient: Stop undercloud upgrade procedure if deployment tasks fail (Ia749c01602214df326edf52b855e4a2a43c6b... 2019-03-07 20:16:34 UTC
Red Hat Product Errata RHBA-2019:1672 None None None 2019-07-02 20:08:44 UTC

Description Yurii Prokulevych 2018-12-11 10:37:32 UTC
Description of problem:
-----------------------
We need to fail earlier in upgrade process if deployment tasks fail and not continue with upgrade tasks.

Version-Release number of selected component (if applicable):
-------------------------------------------------------------
python-tripleoclient-10.6.1-0.20181010222410.8c8f259.el7ost.noarch

How reproducible:
-----------------
100%


Steps to Reproduce:
-------------------
1. Configure different registries in undercloud.conf and containers-image-prepare-paramaters file
2. Run undercloud upgrade


Actual results:
---------------
Upgrade fails because images ain't downloaded and upgrade tasks expect them


Expected results:
-----------------
Don't start upgrade tasks if deployment one failed

Comment 2 Jiri Stransky 2018-12-11 11:14:56 UTC
The fix is present in stable/rocky.

Comment 4 Carlos Camacho 2018-12-13 14:54:44 UTC
This is not a blocker, we just need the PM ack to have this available for zstream.

Comment 16 errata-xmlrpc 2019-07-02 20:08:26 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:1672


Note You need to log in before you can comment on or make changes to this bug.