Bug 165818 - kickstart: advanced options contain wrong URL
kickstart: advanced options contain wrong URL
Status: CLOSED DUPLICATE of bug 191241
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Server (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Kevin A. Smith
Beth Nackashi
: 172743 (view as bug list)
Depends On:
Blocks: rhn410-kickstart
  Show dependency treegraph
Reported: 2005-08-12 11:29 EDT by Patrick C. F. Ernzer
Modified: 2007-07-31 11:28 EDT (History)
2 users (show)

See Also:
Fixed In Version: rhn405
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-05-23 14:15:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
Default Download Location for ia64 (139.93 KB, image/png)
2006-05-23 09:34 EDT, Beth Nackashi
no flags Details

  None (edit)
Description Patrick C. F. Ernzer 2005-08-12 11:29:15 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040816

Description of problem:

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. create a kickstart file with distribution set to rhel4 i386 as U1
2. go to options, advanced options.
3. look at the url line

Actual Results:  --url http://ohsumi.ntc.nokia.com/kickstart/dist/ks-rhel-i386-as-3/

Expected Results:  --url http://MYSAT/kickstart/dist/ks-rhel-i386-as-4/
--url http://MYSAT/kickstart/dist/ks-rhel-i386-as-u-u1/
--url http://MYSAT/ty/nLQJpr_k

Additional info:

when viewing the kickstart file, one sees:
url --url http://MYSAT/ty/nLQJpr_k
and it installs just as expected (redhat-release-4AS-2.4)

so this is a cosmetic bug.
Comment 1 Robin Norwood 2005-10-10 09:48:25 EDT
Fixed in SVN.

Test plan:

* Note that this change only affects newly created kickstart profiles - existing
kickstart profiles will continue to show the issue.

1) Follow the instructions in the original comment. (satellite only)
 - Expect the part of the URL after 'dist' to match the dist label.
2) Also test a few different externally hosted distributions.
3) Remember that the code in this area is slightly different for ia64 systems -
test those specifically.
Comment 2 Robin Norwood 2005-11-09 15:57:08 EST
*** Bug 172743 has been marked as a duplicate of this bug. ***
Comment 3 Todd Warner 2005-11-18 15:07:26 EST
Move bugs from Vlad's plate to Fanny's plate (QA contact)
Comment 4 Fanny Augustin 2005-12-07 16:31:34 EST
Looks good on QA
Comment 5 Todd Warner 2006-01-25 00:46:41 EST
Comment 7 David Lehman 2006-03-28 12:01:26 EST
Adding a new Issue Tracker ticket against 370. Also adding to 410-triage since
the fix doesn't appear to have ever been released in 405.
Comment 8 David Lehman 2006-03-28 14:05:10 EST
Created bug 187136 for tracking against rhn370.
Comment 9 Robin Norwood 2006-03-28 22:22:20 EST
Not sure how this could have passed QA, but still be broken.  blocking
rhn410-triage so we take another look at it.
Comment 10 Mike McCune 2006-05-02 10:23:52 EDT
Can you take a look to see if the new java code version has the above issue?
Comment 11 Kevin A. Smith 2006-05-03 14:29:20 EDT
As I understand this bug, the core problem is that the url does not reflect the
actual selection made by the user.

So, assuming that is the case, I have confirmed that the Java port does not
contain this bug. Moving this QA for confirmation.

Testing Suggestions:

1) Create a kickstart profile. Note which tree you select.

2) View the advanced options page for that profile

3) Confirm that the --url option ends in the name of selected tree.
Comment 12 Beth Nackashi 2006-05-23 09:33:47 EDT
Retested on satellite -76 for i386 and ia64.  The actual bug is fixed on both

However, when creating the ia64 kickstart profile, something weird happens.  The
Default Download Location should just say
"http://fjs-0-06.rhndev.redhat.com/rhn/kickstart/ks-rhel-ia65-as-4", but instead
it says

The same problem does not occur when creating an i386 profile.  See attached
Comment 13 Beth Nackashi 2006-05-23 09:34:43 EDT
Created attachment 129859 [details]
Default Download Location for ia64
Comment 14 Kevin A. Smith 2006-05-23 14:15:24 EDT

*** This bug has been marked as a duplicate of 191241 ***
Comment 15 Kevin A. Smith 2006-05-23 14:19:21 EDT
I am not able to reproduce this with the code used in today's QA push. Marking
this as a dupe of 191241 which should hit QA after the push is complete.

Note You need to log in before you can comment on or make changes to this bug.