Bug 1658186 - Host Upgrade do not fail, if the VMs runnin,g on host to be upgraded, are not migratable
Summary: Host Upgrade do not fail, if the VMs runnin,g on host to be upgraded, are not...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: Frontend.WebAdmin
Version: 4.2.8
Hardware: Unspecified
OS: Unspecified
unspecified
medium vote
Target Milestone: ovirt-4.3.0
: ---
Assignee: Andrej Krejcir
QA Contact: Petr Matyáš
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-12-11 13:19 UTC by Ilanit Stein
Modified: 2019-02-13 07:43 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-02-13 07:43:21 UTC
oVirt Team: Virt
rule-engine: ovirt-4.3+


Attachments (Terms of Use)

Description Ilanit Stein 2018-12-11 13:19:42 UTC
Description of problem:
In RHV-4.2.8-1, 4.2 cluster, with 2 hosts:
1. Host up to date
2. Host with older vdsm (of RHV-4.2.7-9), and a running VM.
This VM is assigned to this 2nd host,
and defined a Manual migration only.
In RHV UI, there is no indication on why the Upgrade host fail.
In engine.log, it is indicated that host can't move to maintenance,
since VMs are not migratable.

Version-Release number of selected component (if applicable):
RHV-4.2.8-1

How reproducible:
100%

Expected results:
Update host should fail in such case.

Comment 1 Michal Skrivanek 2018-12-12 07:04:11 UTC
Notification for non migratable vms has been added only in 4.3. Any reason you’re testing it with 4.2.z? In 4.2 this is expected behavior, there is no notification anywhere

Comment 2 Ilanit Stein 2018-12-12 08:23:24 UTC
There is no intention in testing a 4.3 feature in 4.2.

While I was running Upgrade cluster tests from CFME,
I encountered this RHV bug:
Upgrade host in RHV, in case the host has running VMs, 
that are non migratable (manual migration allowed only),
do not fail, as expected.
Clearly the host upgrade is not executed, and the user has no indication in the UI on that. 

By the engine.log, it seem RHV gets info on that the VM cannot be migrated.
On RHV-4.2 the engine cannot / do not pass such failure to the Upgrade host role, and this is a known issue?

Comment 3 Michal Skrivanek 2018-12-12 10:05:35 UTC
yes, it never worked in 4.2, until 4.3 manual migration was only for migrations of individual vms.
It only makes sense to test in 4.3

Comment 4 Ilanit Stein 2018-12-17 09:36:09 UTC
Thanks Michal.

Is there an open bug, targeted to 4.3, for adding migration notification please?
If yes, we can add it here for tracking, and once resolved, this current bug 
(of upgrade cluster do not fail on non migratable VMs) can be verified too (on 4.3).

Comment 5 Michal Skrivanek 2018-12-17 09:49:38 UTC
It’s all resolved. Bug 1628484

Comment 6 Petr Matyáš 2019-01-23 14:00:32 UTC
What was done/is to be verified in this bug?
As after bug 1631215 even manually migrateable VMs are a cause for upgrade to fail (this is expected behaviour now).

Manual move to maintenance of the host before upgrade causes manually migrateable VMs to migrate though, so if this is enough it can be probably verified.

Comment 7 Petr Matyáš 2019-01-30 15:39:43 UTC
(In reply to Petr Matyáš from comment #6)
> What was done/is to be verified in this bug?
> As after bug 1631215 even manually migrateable VMs are a cause for upgrade
> to fail (this is expected behaviour now).
> 
> Manual move to maintenance of the host before upgrade causes manually
> migrateable VMs to migrate though, so if this is enough it can be probably
> verified.

Michal can you answer this?

Comment 8 Michal Skrivanek 2019-01-30 16:52:04 UTC
"Manual move to maintenance of the host before upgrade causes manually migrateable VMs to migrate" - yes. That covers also REST API request to move to maintenance. There's no automatic maint.

Comment 9 Petr Matyáš 2019-01-31 10:30:24 UTC
So lets just verify this bug as the behaviour is as expected.

Comment 10 Sandro Bonazzola 2019-02-13 07:43:21 UTC
This bugzilla is included in oVirt 4.3.0 release, published on February 4th 2019.

Since the problem described in this bug report should be
resolved in oVirt 4.3.0 release, it has been closed with a resolution of CURRENT RELEASE.

If the solution does not work for you, please open a new bug report.


Note You need to log in before you can comment on or make changes to this bug.