Bug 1658206 - missing Requires: for subpackages
Summary: missing Requires: for subpackages
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 8
Classification: Red Hat
Component: util-linux
Version: 8.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: 8.0
Assignee: Karel Zak
QA Contact: Radka Skvarilova
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-12-11 14:01 UTC by Karel Zak
Modified: 2019-06-14 01:07 UTC (History)
2 users (show)

Fixed In Version: util-linux-2.32.1-8.el8
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-06-14 01:07:26 UTC
Type: Bug
Target Upstream Version:


Attachments (Terms of Use)

Description Karel Zak 2018-12-11 14:01:53 UTC
RPMDiff:

Subpackage python3-libmount on i686 consumes library libuuid.so.1 from subpackage libuuid but does not have explicit package version requirement.
Please add Requires: libuuid = %{version}-%{release} to python3-libmount in the specfile to avoid the need to test interoperability between the various combinations of old and new subpackages.

Subpackage python3-libmount on i686 consumes library libblkid.so.1 from subpackage libblkid but does not have explicit package version requirement.
Please add Requires: libblkid = %{version}-%{release} to python3-libmount in the specfile to avoid the need to test interoperability between the various combinations of old and new subpackages.

Subpackage libfdisk on i686 consumes libraries libuuid.so.1 libuuid.so.1(UUID_1.0) from subpackage libuuid but does not have explicit package version requirement.
Please add Requires: libuuid = %{version}-%{release} to libfdisk in the specfile to avoid the need to test interoperability between the various combinations of old and new subpackages.

Subpackage libfdisk on i686 consumes libraries libblkid.so.1 libblkid.so.1(BLKID_2.15) libblkid.so.1(BLKID_2.17) libblkid.so.1(BLKID_2.21) from subpackage libblkid but does not have explicit package version requirement.
Please add Requires: libblkid = %{version}-%{release} to libfdisk in the specfile to avoid the need to test interoperability between the various combinations of old and new subpackages.

Subpackage python3-libmount on aarch64 x86_64 ppc64le s390x consumes library libuuid.so.1()(64bit) from subpackage libuuid but does not have explicit package version requirement.
Please add Requires: libuuid = %{version}-%{release} to python3-libmount in the specfile to avoid the need to test interoperability between the various combinations of old and new subpackages.

Subpackage python3-libmount on aarch64 x86_64 ppc64le s390x consumes library libblkid.so.1()(64bit) from subpackage libblkid but does not have explicit package version requirement.
Please add Requires: libblkid = %{version}-%{release} to python3-libmount in the specfile to avoid the need to test interoperability between the various combinations of old and new subpackages.

Subpackage libfdisk on aarch64 x86_64 ppc64le s390x consumes libraries libuuid.so.1()(64bit) libuuid.so.1(UUID_1.0)(64bit) from subpackage libuuid but does not have explicit package version requirement.
Please add Requires: libuuid = %{version}-%{release} to libfdisk in the specfile to avoid the need to test interoperability between the various combinations of old and new subpackages.

Subpackage libfdisk on aarch64 x86_64 ppc64le s390x consumes libraries libblkid.so.1()(64bit) libblkid.so.1(BLKID_2.15)(64bit) libblkid.so.1(BLKID_2.17)(64bit) libblkid.so.1(BLKID_2.21)(64bit) from subpackage libblkid but does not have explicit package version requirement.
Please add Requires: libblkid = %{version}-%{release} to libfdisk in the specfile to avoid the need to test interoperability between the various combinations of old and new subpackages.


Note You need to log in before you can comment on or make changes to this bug.