Bug 1658214 - Skydive installation fails on OSP14 [NEEDINFO]
Summary: Skydive installation fails on OSP14
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: skydive
Version: 14.0 (Rocky)
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: rc
: 14.0 (Rocky)
Assignee: safchain
QA Contact: safchain
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-12-11 14:23 UTC by Sai Sindhur Malleni
Modified: 2019-01-11 11:55 UTC (History)
2 users (show)

Fixed In Version: skydive-0.20.1-1.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-01-11 11:55:18 UTC
Target Upstream Version:
jamsmith: needinfo? (safchain)


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github skydive-project skydive pull 1529 None None None 2018-12-13 14:30:48 UTC
Red Hat Product Errata RHEA-2019:0045 None None None 2019-01-11 11:55:28 UTC

Description Sai Sindhur Malleni 2018-12-11 14:23:41 UTC
Description of problem:
'm using the latest passed_phase2 puddle at http://download-node-02.eng.bos.redhat.com/rcm-guest/puddles/OpenStack/14.0-RHEL-7/passed_phase2/RH7-RHOS-14.0.repo

I am deploying my overcloud using the following command

openstack overcloud deploy --templates -e /usr/share/openstack-tripleo-heat-templates/environments/network-isolation.yaml -e templates/network-environment.yaml -e templates/deploy.yaml  -e /home/stack/docker_registry.yaml -e templates/neutron-policy.yaml -e /usr/share/openstack-tripleo-heat-templates/environments/disable-telemetry.yaml  -e /usr/share/openstack-tripleo-heat-templates/environments/services/skydive-environment.yaml --ntp-server clock.redhat.com 

I am seeing the installation fail in the ansible configuration phase, when some requirements are trying to be installed on the overcloud nodes.

The error is as follows,
2018-12-10 22:06:48,092 p=28982 u=mistral |  TASK [skydive_analyzer : Create API basic auth users file] *********************
2018-12-10 22:06:48,093 p=28982 u=mistral |  Monday 10 December 2018  22:06:48 -0500 (0:00:00.237)       0:01:25.818 *******
2018-12-10 22:06:48,185 p=28982 u=mistral |  skipping: [overcloud-controller-2]
2018-12-10 22:06:48,254 p=28982 u=mistral |  skipping: [overcloud-controller-1]
2018-12-10 22:06:48,285 p=28982 u=mistral |  skipping: [overcloud-controller-0]
2018-12-10 22:06:48,345 p=28982 u=mistral |  TASK [skydive_analyzer : Define API keystone user authentication parameters] ***
2018-12-10 22:06:48,345 p=28982 u=mistral |  Monday 10 December 2018  22:06:48 -0500 (0:00:00.252)       0:01:26.070 *******
2018-12-10 22:06:48,642 p=28982 u=mistral |  changed: [overcloud-controller-1]
2018-12-10 22:06:48,655 p=28982 u=mistral |  changed: [overcloud-controller-2]
2018-12-10 22:06:48,789 p=28982 u=mistral |  changed: [overcloud-controller-0]
2018-12-10 22:06:48,948 p=28982 u=mistral |  TASK [skydive_analyzer : Install Keystone requirements] ************************
2018-12-10 22:06:48,949 p=28982 u=mistral |  Monday 10 December 2018  22:06:48 -0500 (0:00:00.603)       0:01:26.674 *******
2018-12-10 22:06:50,433 p=28982 u=mistral |  fatal: [overcloud-controller-0]: FAILED! => {"changed": false, "msg": "No package matching 'python2-shade' found available, installed or updated", "rc": 126, "results": ["No package matching 'python2-shade' found available, installed or updated"]}
2018-12-10 22:06:50,857 p=28982 u=mistral |  fatal: [overcloud-controller-2]: FAILED! => {"changed": false, "msg": "No package matching 'python2-shade' found available, installed or updated", "rc": 126, "results": ["No package matching 'python2-shade' found available, installed or updated"]}
2018-12-10 22:06:50,990 p=28982 u=mistral |  fatal: [overcloud-controller-1]: FAILED! => {"changed": false, "msg": "No package matching 'python2-shade' found available, installed or updated", "rc": 126, "results": ["No package matching 'python2-shade' found available, installed or updated"]}


Shouldn't the python2-shade package be baked into the overcloud image instead of trying to install.



Version-Release number of selected component (if applicable):
14

How reproducible:
100%

Steps to Reproduce:
1. Deploy with skydive environment file 
2.
3.

Actual results:
Ansible configuration of overcloud fails

Expected results:
Installation should succeeed

Additional info:

Comment 4 safchain 2018-12-14 16:29:05 UTC
This bug avoid Skydive deployment with Keystone as authentication backend

Comment 5 safchain 2018-12-14 16:30:29 UTC
Version 0.20.1 fixes the issue by using python2-shade within the mistral container.

Comment 8 errata-xmlrpc 2019-01-11 11:55:18 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2019:0045


Note You need to log in before you can comment on or make changes to this bug.