Bug 165822 - Admin Server management window misparses access log
Admin Server management window misparses access log
Status: CLOSED DUPLICATE of bug 166230
Product: 389
Classification: Community
Component: Admin (Show other bugs)
7.1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Rich Megginson
Chandrasekar Kannan
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-08-12 12:05 EDT by Steve Bonneville
Modified: 2015-01-04 18:19 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-19 19:23:23 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot of misparsed access log entry (82.57 KB, image/png)
2005-08-12 12:06 EDT, Steve Bonneville
no flags Details

  None (edit)
Description Steve Bonneville 2005-08-12 12:05:24 EDT
Description of problem:

In Red Hat Console in Red Hat Directory Server 7.1, the Admin Server's
management window misparses access log entries which include host names that
have a hyphen in them.  (Hyphens are permitted by RFC 1034.)  The - is 
treated as a field separator and the remainder of the hostname appears 
in the username field with the username.

Version-Release number of selected component (if applicable):
redhat-ds-7.1-2

Steps to Reproduce:
1.  Have a host with a hyphen in its shortname access Admin Server
2.  In Red Hat Console, open the Admin Server's management window,
    switch to the Configuration tab, and navigate to Administration
    Server -> Logs -> Accesses
  
Actual results:
Screenshot of bug is attached.  The actual log entry highlighted in the
screenshot as stored in /opt/redhat-ds/admin-serv/logs/access read:

sbonnevi-lt.rdu.redhat.com - - [09/Aug/2005:17:33:18 -0400] "GET /dist/download
HTTP/1.1" 200 4786
Comment 1 Steve Bonneville 2005-08-12 12:06:45 EDT
Created attachment 117675 [details]
Screenshot of misparsed access log entry
Comment 3 Rich Megginson 2008-12-19 19:23:23 EST

*** This bug has been marked as a duplicate of bug 166230 ***

Note You need to log in before you can comment on or make changes to this bug.