Bug 1658221 - graphana (prometheus) some info are partially hidden
Summary: graphana (prometheus) some info are partially hidden
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Monitoring
Version: 3.10.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 4.1.0
Assignee: Frederic Branczyk
QA Contact: Junqi Zhao
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-12-11 14:28 UTC by mmariyan
Modified: 2019-06-06 11:58 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-06-04 10:41:14 UTC
Target Upstream Version:


Attachments (Terms of Use)
Project name shows when the cursor in the upper area (260.61 KB, application/gzip)
2019-03-07 07:25 UTC, Junqi Zhao
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:0758 None None None 2019-06-04 10:41:20 UTC

Description mmariyan 2018-12-11 14:28:48 UTC
Description of problem:

there is no way to fully view the table that appears near the cursor highlighting the element where the cursor is in the browser. when we have  many projects in ocp cluster with the sample applications.

Version-Release number of selected component (if applicable):


How reproducible:



Steps to Reproduce:
1. install cluster-monitoring
2.access grafana-dashboard
3.

Actual results:

Its not able view complete table

Expected results:

should able to view with single table or multiple table

Additional info:
screenshot attched

Comment 4 Matthias Loibl 2019-02-06 12:53:42 UTC
Talking with Grafana developers back and forth, it seems that there is currently not way to configure / improve the tooltip itself.
Their solution would be to select the specific time series in the graph, which then also limits the number of elements shown in the tooltip.

It is definitely interesting, that this problem hasn't been solved in Grafana yet.
We are going to work with Grafana to improve this situation.

Comment 5 Frederic Branczyk 2019-02-27 14:35:23 UTC
Opened the PR that uses the "single" tooltip on high cardinality panels: https://github.com/openshift/cluster-monitoring-operator/pull/272

Comment 6 Frederic Branczyk 2019-02-28 07:43:34 UTC
https://github.com/openshift/cluster-monitoring-operator/pull/272 merged so this is now available starting in 4.0.

Comment 8 Junqi Zhao 2019-03-07 04:48:22 UTC
move the mouse over the specific time series in the graph, it will only show the related project name, not all project names. 

payload: 4.0.0-0.nightly-2019-03-04-234414

Comment 9 Junqi Zhao 2019-03-07 07:24:41 UTC
@Frederic

FYI, There is one small problem, see the attached file, the example project is openshift-kube-apiserver, even move the cursor in the middle area, the project name is not shown, it is shown when the cursor in the upper area

Comment 10 Junqi Zhao 2019-03-07 07:25:21 UTC
Created attachment 1541699 [details]
Project name shows when the cursor in the upper area

Comment 13 errata-xmlrpc 2019-06-04 10:41:14 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0758


Note You need to log in before you can comment on or make changes to this bug.