Bug 1658241 - [docs] 12->13 upgrade: notes specific for deployed server environments
Summary: [docs] 12->13 upgrade: notes specific for deployed server environments
Keywords:
Status: NEW
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: documentation
Version: 13.0 (Queens)
Hardware: x86_64
OS: Linux
urgent
urgent
Target Milestone: ---
: ---
Assignee: RHOS Documentation Team
QA Contact: RHOS Documentation Team
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-12-11 15:18 UTC by Ganesh Kadam
Modified: 2020-02-05 05:10 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed:
Target Upstream Version:


Attachments (Terms of Use)

Description Ganesh Kadam 2018-12-11 15:18:43 UTC
Description of problem:


One of our Cu is trying to upgrade an RHOSP12 environment to RHOSP13. 

It's a predeployed nodes environment, where the nodes itself get provisioned by the Customer. 

When running the "openstack overcloud upgrade run --nodes ControllerDeployedServer" command, it fails.

The error is caused by a playbook trying to "Gather facts" from the Overcloud Nodes, in this case, the controllers. It fails with a connection issue, not being able to ssh into the machine.

We checked the logs on the overcloud nodes and found the try to login to the system. It was rejected due to an unknown ssh key was used.

We checked with the local key from the director node (the one in /home/stack/.ssh/id_rsa) and found it not matching the key which was used to access the node.

After some searching we found the key the director tried to use:
/tmp/ansible-mistral-action$tmpid/ssh_private_key

Its a separate key from mistral and not the stack's user key which is normally used by the director.

It seems to be related to validations, which we can't use on a pre-deployed nodes environment.

So we tried to re-run the upgrade with --skip-tags validation, but it failed with the same issue.


Version-Release number of selected component (if applicable):

$ rpm -qa | grep tripleo-heat-temp
openstack-tripleo-heat-templates-8.0.7-4.el7ost.noarch
openstack-tripleo-heat-templates-compat-7.0.12-8.el7ost.noarch



Steps to Reproduce:
- Follow the official guide instructions to upgrade pre-deployed nodes.


Actual results:
- The upgrade is failing because it uses different ssh key 


Expected results:
- The upgrade should be successful


Additional info:

We followed the steps as mentioned in our official document:
~~~
https://access.redhat.com/documentation/en-us/red_hat_openstack_platform/12/html-single/upgrading_red_hat_openstack_platform/#preparing_for_pre-provisioned_nodes_upgrade
~~~

Comment 2 Rabi Mishra 2018-12-12 03:31:55 UTC
Seems like you're missing "Preparing for Pre-Provisioned Nodes Upgrade" part[1] which enables ssh for those nodes for 'triplo-admin' user. I don't see those 13 upgrade docs though. Probably a docs bug.

[1] https://access.redhat.com/documentation/en-us/red_hat_openstack_platform/12/html/upgrading_red_hat_openstack_platform/assembly-preparing_for_overcloud_upgrade#preparing_for_pre-provisioned_nodes_upgrade


Note You need to log in before you can comment on or make changes to this bug.