Bug 165828 - ALPS Dualpoint tap-to-drag no longer works as of 2.6.12-1.1469_FC5
ALPS Dualpoint tap-to-drag no longer works as of 2.6.12-1.1469_FC5
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
4
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-08-12 12:48 EDT by Craig McLean
Modified: 2015-01-04 17:21 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-06 16:00:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmesg from working boot (14.12 KB, text/plain)
2005-08-12 12:48 EDT, Craig McLean
no flags Details
dmesg from non-working boot (15.49 KB, application/octet-stream)
2005-08-12 12:49 EDT, Craig McLean
no flags Details

  None (edit)
Description Craig McLean 2005-08-12 12:48:13 EDT
Description of problem:
Toshiba Tecra M2, kernel as described. Using Gnome.
Note that the kernel is from FC5, everything else on the system is FC4.
tap-to-drag on ALPS touchpad worked in 2.6.12-1.1400_FC5 but no longer does.

Version-Release number of selected component (if applicable):
2.6.12-1.1469_FC5

How reproducible:
Every time

Steps to Reproduce:
1. Get a system with ALPS Dualpoint touchpad
2. Upgrade from 2.6.12-1.1400_FC5 to 2.6.12-1.1469_FC5
  
Actual results:
Tap-to-drag windows does not work.

Expected results:
tap and hold should grab the window and allow it to be dragged. This worked in
earlier kernels but not as of 2.6.12-1.1469

Additional info:
I have the psmouse.proto=exps in my boot options, although this makes no
difference. Double tap for a double click works fine, just tap to drag causing
problems.
There seems to be new code around the mouse in the new kernel, it gets announced
as an ALPS dualpoint, while older kernels simply said "PS/2 mouse". dmesg from
working and not working boots attached.
Comment 1 Craig McLean 2005-08-12 12:48:14 EDT
Created attachment 117677 [details]
dmesg from working boot
Comment 2 Craig McLean 2005-08-12 12:49:34 EDT
Created attachment 117678 [details]
dmesg from non-working boot
Comment 3 Dave Jones 2005-10-06 03:09:14 EDT
any better in current builds ?
Comment 4 Craig McLean 2005-10-06 08:48:52 EDT
Just updated to 2.6.13-1.1526 and all seems OK, haven't tested the FC5 Kernel
though, so if the changes are tracked through that build too then we're fine to
close this.

Note You need to log in before you can comment on or make changes to this bug.