Bug 1658323 - Overcloud install with Octavia fails
Summary: Overcloud install with Octavia fails
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-octavia
Version: 1.0 (Essex)
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: ---
Assignee: Assaf Muller
QA Contact: Alexander Stafeyev
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-12-11 18:24 UTC by Sai Sindhur Malleni
Modified: 2019-09-10 14:11 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-12-11 20:43:45 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Sai Sindhur Malleni 2018-12-11 18:24:16 UTC
Description of problem:
Deploying overcloud with the following command,
openstack overcloud deploy --templates -e /usr/share/openstack-tripleo-heat-templates/environments/network-isolation.yaml -e templates/network-environment.yaml -e templates/deploy.yaml  -e /home/stack/docker_registry.yaml -e templates/neutron-policy.yaml -e /usr/share/openstack-tripleo-heat-templates/environments/disable-telemetry.yaml -e /usr/share/openstack-tripleo-heat-templates/environments/services/octavia.yaml --ntp-server clock.redhat.com 

The deployment is failing at the stage of configuring octavia
TASK [Configure octavia on overcloud] ******************************************                                                                                                                          [34/1963]
Tuesday 11 December 2018  12:44:56 -0500 (0:00:00.208)       0:27:26.750 ****** 
fatal: [undercloud]: FAILED! => {"changed": true, "cmd": "ansible-playbook -i \"/var/lib/mistral/overcloud/octavia-ansible/inventory.yaml\" --extra-vars @\"/var/lib/mistral/overcloud/octavia-ansible/group_vars\"/octavia_vars.yaml \"/usr/share/tripleo-common/playbooks/octavia-files.yaml\" --private-key \"/var/lib/mistral/overcloud/ssh_private_key\"", "delta": "0:01:20.975572", "end": "2018-12-11 12:46:18.210586", "msg": "non-zero return code", "rc": 2, "start": "2018-12-11 12:44:57.235014", "stderr": "[DEPRECATION WARNING]: get_md5 has been deprecated along with the md5 return \nvalue, use get_checksum=True and checksum_algorithm=md5 instead. This feature \nwill be removed in version 2.9. Deprecation warnings can be disabled by setting\n deprecation_warnings=False in ansible.cfg.", "stderr_lines": ["[DEPRECATION WARNING]: get_md5 has been deprecated along with the md5 return ", "value, use get_checksum=True and checksum_algorithm=md5 instead. This feature ", "will be removed in version 2.9. Deprecation warnings can be disabled by setting", " deprecation_warnings=False in ansible.cfg."], "stdout": "\nPLAY [Undercloud[0]] ***********************************************************\n\nTASK [Gathering Facts] *********************************************************\nTuesday 11 December 2018  12:44:59 -0500 (0:00:00.229)       0:00:00.229 ****** \nok: [ducati]\n\nTASK [octavia-undercloud : set file if already set by heat variable (backwards-compatibility)] ***\nTuesday 11 December 2018  12:45:51 -0500 (0:00:52.263)       0:00:52.493 ****** \nskipping: [ducati]\n\nTASK [octavia-undercloud : set location if CentOS] *****************************\nTuesday 11 December 2018  12:45:51 -0500 (0:00:00.151)       0:00:52.645 ****** \nskipping: [ducati]\n\nTASK [octavia-undercloud : set location if Red Hat] ****************************\nTuesday 11 December 2018  12:45:51 -0500 (0:00:00.149)       0:00:52.795 ****** \nok: [ducati]\n\nTASK [octavia-undercloud : check if amphora image file exists] *****************\nTuesday 11 December 2018  12:45:52 -0500 (0:00:00.200)       0:00:52.996 *****
* \nok: [ducati]\n\nTASK [octavia-undercloud : include_tasks] **************************************\nTuesday 11 December 2018  12:45:56 -0500 (0:00:04.604)       0:00:57.601 ****** \nincluded: /usr/share/openst
ack-tripleo-common/playbooks/roles/octavia-undercloud/tasks/image_mgmt.yml for ducati\n\nTASK [octavia-undercloud : check if name is a symlink] *************************\nTuesday 11 December 2018  12:45:56 -0500
 (0:00:00.134)       0:00:57.735 ****** \nok: [ducati]\n\nTASK [octavia-undercloud : bypass image naming logic if image name is provided (backwards-compatibility)] ***\nTuesday 11 December 2018  12:45:57 -0500 (
0:00:00.434)       0:00:58.170 ****** \nskipping: [ducati]\n\nTASK [octavia-undercloud : set the actual glance image name if it is a symlink] ***\nTuesday 11 December 2018  12:45:57 -0500 (0:00:00.163)       0:0
0:58.333 ****** \nok: [ducati]\n\nTASK [octavia-undercloud : set the actual glance image name if it is not a symlink] ***\nTuesday 11 December 2018  12:45:57 -0500 (0:00:00.219)       0:00:58.553 ****** \nskippi
ng: [ducati]\n\nTASK [octavia-undercloud : check there an image in glance already] *************\nTuesday 11 December 2018  12:45:57 -0500 (0:00:00.162)       0:00:58.715 ****** \nfatal: [ducati]: FAILED! => {\"
changed\": true, \"cmd\": \"openstack image show octavia-amphora-14.0-20181207.1.x86_64 -c checksum -f value\", \"delta\": \"0:00:09.086625\", \"end\": \"2018-12-11 12:46:07.743332\", \"msg\": \"non-zero return 
code\", \"rc\": 1, \"start\": \"2018-12-11 12:45:58.656707\", \"stderr\": \"Failed to discover available identity versions when contacting http://172.21.0.100:5000/v3. Attempting to parse version from URL.\\nUna
ble to establish connection to http://172.21.0.100:5000/v3/auth/tokens: HTTPConnectionPool(host='172.21.0.100', port=5000): Max retries exceeded with url: /v3/auth/tokens (Caused by NewConnectionError('<urllib3.
connection.HTTPConnection object at 0x7f1164c32ed0>: Failed to establish a new connection: [Errno 113] No route to host',))\", \"stderr_lines\": [\"Failed to discover available identity versions when contacting 
http://172.21.0.100:5000/v3. Attempting to parse version from URL.\", \"Unable to establish connection to http://172.21.0.100:5000/v3/auth/tokens: HTTPConnectionPool(host='172.21.0.100', port=5000): Max retries 
exceeded with url: /v3/auth/tokens (Caused by NewConnectionError('<urllib3.connection.HTTPConnection object at 0x7f1164c32ed0>: Failed to establish a new connection: [Errno 113] No route to host',))\"], \"stdout
\": \"\", \"stdout_lines\": []}\n...ignoring\n\nTASK [octavia-undercloud : get md5 from glance if image already exists there] ***\nTuesday 11 December 2018  12:46:07 -0500 (0:00:10.001)       0:01:08.716 ****** 
\nskipping: [ducati]\n\nTASK [octavia-undercloud : determine if the image needs to be replaced] ********\nTuesday 11 December 2018  12:46:08 -0500 (0:00:00.158)       0:01:08.875 ****** \nskipping: [ducati]\n\nT
ASK [octavia-undercloud : move existing image if the names match and the md5s are not the same] ***\nTuesday 11 December 2018  12:46:08 -0500 (0:00:00.152)       0:01:09.028 ****** \nskipping: [ducati]\n\nTASK [
octavia-undercloud : decide whether to upload new image] *****************\nTuesday 11 December 2018  12:46:08 -0500 (0:00:00.154)       0:01:09.182 ****** \nok: [ducati]\n\nTASK [octavia-undercloud : upload ima
ge to glance] *****************************\nTuesday 11 December 2018  12:46:08 -0500 (0:00:00.352)       0:01:09.535 ****** \nfatal: [ducati]: FAILED! => {\"changed\": false, \"cmd\": \"openstack image create -
-disk-format qcow2 --container-format bare --tag amphora-image --file /usr/share/openstack-octavia-amphora-images/octavia-amphora.qcow2 octavia-amphora-14.0-20181207.1.x86_64\", \"delta\": \"0:00:09.021527\", \"
end\": \"2018-12-11 12:46:18.116946\", \"msg\": \"non-zero return code\", \"rc\": 1, \"start\": \"2018-12-11 12:46:09.095419\", \"stderr\": \"Failed to discover available identity versions when contacting http:/
/172.21.0.100:5000/v3. Attempting to parse version from URL.\\nUnable to establish connection to http://172.21.0.100:5000/v3/auth/tokens: HTTPConnectionPool(host='172.21.0.100', port=5000): Max retries exceeded 
with url: /v3/auth/tokens (Caused by NewConnectionError('<urllib3.connection.HTTPConnection object at 0x7fb3bc224ed0>: Failed to establish a new connection: [Errno 113] No route to host',))\", \"stderr_lines\": 
[\"Failed to discover available identity versions when contacting http://172.21.0.100:5000/v3. Attempting to parse version from URL.\", \"Unable to establish connection to http://172.21.0.100:5000/v3/auth/tokens
: HTTPConnectionPool(host='172.21.0.100', port=5000): Max retries exceeded with url: /v3/auth/tokens (Caused by NewConnectionError('<urllib3.connection.HTTPConnection object at 0x7fb3bc224ed0>: Failed to establi
sh a new connection: [Errno 113] No route to host',))\"], \"stdout\": \"\", \"stdout_lines\": []}\n\nPLAY RECAP *********************************************************************\nducati                     :
 ok=8    changed=1    unreachable=0    failed=1   \n\nTuesday 11 December 2018  12:46:18 -0500 (0:00:09.439)       0:01:18.975 ****** \n===========================================================================
==== ", "stdout_lines": ["", "PLAY [Undercloud[0]] ***********************************************************", "", "TASK [Gathering Facts] *********************************************************", "Tuesday 1
1 December 2018  12:44:59 -0500 (0:00:00.229)       0:00:00.229 ****** ", "ok: [ducati]", "", "TASK [octavia-undercloud : set file if already set by heat variable (backwards-compatibility)] ***", "Tuesday 11 Dec
ember 2018  12:45:51 -0500 (0:00:52.263)       0:00:52.493 ****** ", "skipping: [ducati]", "", "TASK [octavia-undercloud : set location if CentOS] *****************************", "Tuesday 11 December 2018  12:45
:51 -0500 (0:00:00.151)       0:00:52.645 ****** ", "skipping: [ducati]", "", "TASK [octavia-undercloud : set location if Red Hat] ****************************", "Tuesday 11 December 2018  12:45:51 -0500 (0:00:0
0.149)       0:00:52.795 ****** ", "ok: [ducati]", "", "TASK [octavia-undercloud : check if amphora image file exists] *****************", "Tuesday 11 December 2018  12:45:52 -0500 (0:00:00.200)       0:00:52.99
6 ****** ", "ok: [ducati]", "", "TASK [octavia-undercloud : include_tasks] **************************************", "Tuesday 11 December 2018  12:45:56 -0500 (0:00:04.604)       0:00:57.601 ****** ", "included: 
/usr/share/openstack-tripleo-common/playbooks/roles/octavia-undercloud/tasks/image_mgmt.yml for ducati", "", "TASK [octavia-undercloud : check if name is a symlink] *************************", "Tuesday 11 Decemb
er 2018  12:45:56 -0500 (0:00:00.134)       0:00:57.735 ****** ", "ok: [ducati]", "", "TASK [octavia-undercloud : bypass image naming logic if image name is provided (backwards-compatibility)] ***", "Tuesday 11 
December 2018  12:45:57 -0500 (0:00:00.434)       0:00:58.170 ****** ", "skipping: [ducati]", "", "TASK [octavia-undercloud : set the actual glance image name if it is a symlink] ***", "Tuesday 11 December 2018 
 12:45:57 -0500 (0:00:00.163)       0:00:58.333 ****** ", "ok: [ducati]", "", "TASK [octavia-undercloud : set the actual glance image name if it is not a symlink] ***", "Tuesday 11 December 2018  12:45:57 -0500 
(0:00:00.219)       0:00:58.553 ****** ", "skipping: [ducati]", "", "TASK [octavia-undercloud : check there an image in glance already] *************", "Tuesday 11 December 2018  12:45:57 -0500 (0:00:00.162)    
   0:00:58.715 ****** ", "fatal: [ducati]: FAILED! => {\"changed\": true, \"cmd\": \"openstack image show octavia-amphora-14.0-20181207.1.x86_64 -c checksum -f value\", \"delta\": \"0:00:09.086625\", \"end\": \"
2018-12-11 12:46:07.743332\", \"msg\": \"non-zero return code\", \"rc\": 1, \"start\": \"2018-12-11 12:45:58.656707\", \"stderr\": \"Failed to discover available identity versions when contacting http://172.21.0
.100:5000/v3. Attempting to parse version from URL.\\nUnable to establish connection to http://172.21.0.100:5000/v3/auth/tokens: HTTPConnectionPool(host='172.21.0.100', port=5000): Max retries exceeded with url:
 /v3/auth/tokens (Caused by NewConnectionError('<urllib3.connection.HTTPConnection object at 0x7f1164c32ed0>: Failed to establish a new connection: [Errno 113] No route to host',))\", \"stderr_lines\": [\"Failed
 to discover available identity versions when contacting http://172.21.0.100:5000/v3. Attempting to parse version from URL.\", \"Unable to establish connection to http://172.21.0.100:5000/v3/auth/tokens: HTTPCon
nectionPool(host='172.21.0.100', port=5000): Max retries exceeded with url: /v3/auth/tokens (Caused by NewConnectionError('<urllib3.connection.HTTPConnection object at 0x7f1164c32ed0>: Failed to establish a new 
connection: [Errno 113] No route to host',))\"], \"stdout\": \"\", \"stdout_lines\": []}", "...ignoring", "", "TASK [octavia-undercloud : get md5 from glance if image already exists there] ***", "Tuesday 11 Dece
mber 2018  12:46:07 -0500 (0:00:10.001)       0:01:08.716 ****** ", "skipping: [ducati]", "", "TASK [octavia-undercloud : determine if the image needs to be replaced] ********", "Tuesday 11 December 2018  12:46:
08 -0500 (0:00:00.158)       0:01:08.875 ****** ", "skipping: [ducati]", "", "TASK [octavia-undercloud : move existing image if the names match and the md5s are not the same] ***", "Tuesday 11 December 2018  12:
46:08 -0500 (0:00:00.152)       0:01:09.028 ****** ", "skipping: [ducati]", "", "TASK [octavia-undercloud : decide whether to upload new image] *****************", "Tuesday 11 December 2018  12:46:08 -0500 (0:00
:00.154)       0:01:09.182 ****** ", "ok: [ducati]", "", "TASK [octavia-undercloud : upload image to glance] *****************************", "Tuesday 11 December 2018  12:46:08 -0500 (0:00:00.352)       0:01:09.
535 ****** ", "fatal: [ducati]: FAILED! => {\"changed\": false, \"cmd\": \"openstack image create --disk-format qcow2 --container-format bare --tag amphora-image --file /usr/share/openstack-octavia-amphora-image
s/octavia-amphora.qcow2 octavia-amphora-14.0-20181207.1.x86_64\", \"delta\": \"0:00:09.021527\", \"end\": \"2018-12-11 12:46:18.116946\", \"msg\": \"non-zero return code\", \"rc\": 1, \"start\": \"2018-12-11 12:
46:09.095419\", \"stderr\": \"Failed to discover available identity versions when contacting http://172.21.0.100:5000/v3. Attempting to parse version from URL.\\nUnable to establish connection to http://172.21.0
.100:5000/v3/auth/tokens: HTTPConnectionPool(host='172.21.0.100', port=5000): Max retries exceeded with url: /v3/auth/tokens (Caused by NewConnectionError('<urllib3.connection.HTTPConnection object at 0x7fb3bc22
4ed0>: Failed to establish a new connection: [Errno 113] No route to host',))\", \"stderr_lines\": [\"Failed to discover available identity versions when contacting http://172.21.0.100:5000/v3. Attempting to par
se version from URL.\", \"Unable to establish connection to http://172.21.0.100:5000/v3/auth/tokens: HTTPConnectionPool(host='172.21.0.100', port=5000): Max retries exceeded with url: /v3/auth/tokens (Caused by 
NewConnectionError('<urllib3.connection.HTTPConnection object at 0x7fb3bc224ed0>: Failed to establish a new connection: [Errno 113] No route to host',))\"], \"stdout\": \"\", \"stdout_lines\": []}", "", "PLAY RE
CAP *********************************************************************", "ducati                     : ok=8    changed=1    unreachable=0    failed=1   ", "", "Tuesday 11 December 2018  12:46:18 -0500 (0:00:0
9.439)       0:01:18.975 ****** ", "=============================================================================== "]}



Version-Release number of selected component (if applicable):
14

How reproducible:
100%

Steps to Reproduce:
1. deploy overcloud with octavia
2.
3.

Actual results:
Deployment fails

Expected results:
Deployment should succeed

Additional info:

Comment 1 Sai Sindhur Malleni 2018-12-11 20:43:45 UTC
Sorry, this was due to a configuration error on my end.


Note You need to log in before you can comment on or make changes to this bug.