Bug 1658332 - eBPF tool 'biolatency -D' fails with Traceback
Summary: eBPF tool 'biolatency -D' fails with Traceback
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 8
Classification: Red Hat
Component: bcc
Version: 8.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: rc
: 8.1
Assignee: Jerome Marchand
QA Contact: Ziqian SUN (Zamir)
URL:
Whiteboard:
Depends On: 1680631
Blocks: 1701002 1645899
TreeView+ depends on / blocked
 
Reported: 2018-12-11 19:12 UTC by John Pittman
Modified: 2019-11-05 20:42 UTC (History)
8 users (show)

Fixed In Version: 0.8.0-1
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-11-05 20:42:19 UTC
Type: Bug
Target Upstream Version:


Attachments (Terms of Use)
biolatency -D command output (3.25 KB, text/plain)
2018-12-11 19:12 UTC, John Pittman
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 3749701 None None None 2018-12-11 19:42:00 UTC
Red Hat Product Errata RHBA-2019:3327 None None None 2019-11-05 20:42:32 UTC

Description John Pittman 2018-12-11 19:12:02 UTC
Created attachment 1513488 [details]
biolatency -D command output

Description of problem:

eBPF tool 'biolatency -D' fails with Traceback

Traceback (most recent call last):
  File "./biolatency", line 121, in <module>
    fn_name="trace_req_completion")
  File "/usr/lib/python3.6/site-packages/bcc/__init__.py", line 592, in attach_kprobe
    fn = self.load_func(fn_name, BPF.KPROBE)
  File "/usr/lib/python3.6/site-packages/bcc/__init__.py", line 377, in load_func
    (func_name, errstr))
Exception: Failed to load BPF program b'trace_req_completion': Permission denied

Version-Release number of selected component (if applicable):

kernel-4.18.0-40.el8.x86_64
bcc-tools-0.7.0-3.el8.x86_64
bcc-0.7.0-3.el8.x86_64

Steps to Reproduce:

Install RHEL8 beta on KVM virt
Install bcc/bcc-tools
cd /usr/share/bcc/tools
./biolatency -D

Actual results:

Command fails

Expected results:

Command should succeed

Comment 1 Jerome Marchand 2018-12-12 09:39:58 UTC
Looks like we need commit fc245dfe9dab ("biolatency: Fix --disks bpf_probe_read() (#1980)")

Comment 11 errata-xmlrpc 2019-11-05 20:42:19 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:3327


Note You need to log in before you can comment on or make changes to this bug.