Bug 1658359 - liveuser nor root can login to live media
Summary: liveuser nor root can login to live media
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: livecd-tools
Version: 29
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Neal Gompa
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-12-11 20:38 UTC by Scott Dowdle
Modified: 2018-12-15 03:18 UTC (History)
10 users (show)

Fixed In Version: livecd-tools-26.1-1.fc29
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-12-15 03:18:54 UTC
Type: Bug


Attachments (Terms of Use)

Description Scott Dowdle 2018-12-11 20:38:11 UTC
I have been building personal remixes of Fedora since about Fedora 7.  I primarily use livecd-creator.  Builds for the past two weeks or so build just fine but when booted, the liveuser can't login.

Switching to a console, it isn't prompting for a password... perhaps because the liveuser and the root user on the live media have blank passwords set.  In that case for a fraction of a second this error message is seen:
 -- root: no shell: Permission denied

Here is a sort video showing the issue:
https://www.montanalinux.org/files/videos/fedora29-centos76-livemedia-issue-20181205.mp4

Oddly this has also affected my CentOS 7.6 media even though I'm using a much, much older version of livecd-tools / livecd-creator that hvaen't been updated in some time... so I know it is some underlying package rather than binaries/scripts provided by the livecd-tools package.  I just don't know what.

How to reproduce?  I have my own kickstarts but I've also tested with the stock kickstart files provided by the fedora-kickstarts package and I can duplicate it with the stock kickstarts.

I'm a member of the Fedora Respin SIG (I do mostly testing) and the build environment they are using doesn't produce media with this problem... and I'm at a lose to figure out why that is.  Other members of the SIG have reported hitting the same issue on builds they have done on their own machines.

While I can provide my kickstart files, as previously stated, I'm getting the same issue on the stock kickstarts.

Since I can't log into the media it is hard to troubleshoot the issue.  I can mount the media (three levels worth) and examine the file system... or boot the iso up in a passwordless bash mode (by adding init=/bin/bash to the grub line).. but again, I'm not sure what I'm looking for.  The liveuser is created at boot time and that account doesn't exist in the only troubleshooting methods I have figure out.

Also, I'm not sure exactly when the problem started and what package update might have been the cause.  authselect?

HELP!

Comment 1 Scott Dowdle 2018-12-11 23:18:19 UTC
BTW, Fedora Rawhide (F30) is working for me and doesn't suffer from the inability to login.

Comment 2 Neal Gompa 2018-12-12 02:40:01 UTC
I think I recently resolved this issue with livecd-tools v26.1.

There are updates proposed in Bodhi, sitting in updates-testing right now:

* Fedora 28: https://bodhi.fedoraproject.org/updates/FEDORA-2018-7eb5688a2f
* Fedora 29: https://bodhi.fedoraproject.org/updates/FEDORA-2018-82f85b0db9

Can you try this release? If it works, I can add this bug to the Bodhi update notes.

Comment 3 Scott Dowdle 2018-12-12 03:05:43 UTC
Trying it out now.  Will report back in a while this evening (MST).

Comment 4 Scott Dowdle 2018-12-12 04:15:22 UTC
Yes, your updated packages seem to have fixed the issue on Fedora 29.  I haven't tested it on Fedora 28.

Any idea why my CentOS 7.6 build (built on a CentOS 7.6 host) would ALSO have the same problem?

Comment 5 Scott Dowdle 2018-12-12 19:23:42 UTC
If you would, please explain what change was made that caused the breakage and the subsequent change that fixed it.  Thanks.

Comment 6 Scott Dowdle 2018-12-13 23:16:20 UTC
I tested it on Fedora 28 and was able to build working media.  Fixed there too.

Comment 7 Scott Dowdle 2018-12-14 01:13:40 UTC
Ok, if I boot my EL7 builds adding the following to the kernel boot line "selinux=1 enforcing=0" then my media works just fine... so it appears to be an SELinux issue.

I see this in the changelog for your package update:
"- Run setfiles after chroot (noto.kazufumi)"

I found this code modification:
https://github.com/livecd-tools/livecd-tools/commit/c6dd265af7ccb3c51c37dcd89839f178832518ea

I tried updating my file from my older package on EL7 (Livecd-tools-21.4-5.el7.x86_64 and python-imgcreate-21.4-5.el7.x86_64) but the code bases have diverged so much that changing the line that containers the selinux.selinux_file_context_path call (line 453) just produce an error.

So, I'm not sure where I got those packages for EL7.  They were built by the Scientific Linux folks.  I'm not sure what CentOS might be using / offer.  It would be nice if the package was in EPEL.  I see a mention of "Fix up EL7 support" in your changelog but I don't know what that is about.

Any chance you could provide a codefix fo the older version of python-imgcreate I have?  Does it sound like I'm on the right track?

Comment 8 Neal Gompa 2018-12-14 04:46:04 UTC
As of EL7.6, it is now possible to run the latest version of livecd-tools on EL7. CentOS was planning on switching to livecd-tools v26, but this issue (which is now fixed in v26.1) came a bit late for the 7.6 GA. I made the spec fixes so that they could backport straight from Fedora Dist-Git to CentOS Extras.

I'm hoping that Fabian Arrotin and Pablo Greco will ship v26.1 soon in their Extras (which I believe Scientific Linux and friends get it from...).

Unfortunately, I don't really have the time or motivation to fix issues with old versions of livecd-tools. And since the new versions now work on EL7, it doesn't matter so much anymore.

Comment 9 Fedora Update System 2018-12-14 04:46:52 UTC
livecd-tools-26.1-1.fc29 has been submitted as an update to Fedora 29. https://bodhi.fedoraproject.org/updates/FEDORA-2018-82f85b0db9

Comment 10 Fedora Update System 2018-12-14 04:47:26 UTC
livecd-tools-26.1-1.fc28 has been submitted as an update to Fedora 28. https://bodhi.fedoraproject.org/updates/FEDORA-2018-7eb5688a2f

Comment 11 Fedora Update System 2018-12-15 03:18:54 UTC
livecd-tools-26.1-1.fc29 has been pushed to the Fedora 29 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.