Bug 1658375 - osp13->osp14 major upgrade error message during undercloud upgrade "Syntax error on line 23 of /etc/httpd/conf.d/ssl.conf:\nSSLSessionCache: 'shmcb' session cache not supported "
Summary: osp13->osp14 major upgrade error message during undercloud upgrade "Syntax er...
Keywords:
Status: CLOSED DUPLICATE of bug 1664705
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: rhosp-director
Version: 14.0 (Rocky)
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: ---
Assignee: Sergii Golovatiuk
QA Contact: Gurenko Alex
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-12-11 21:41 UTC by Alexander Chuzhoy
Modified: 2019-01-18 16:49 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-01-18 16:49:31 UTC
Target Upstream Version:


Attachments (Terms of Use)
install-undercloud.log (66.15 KB, application/gzip)
2018-12-11 22:49 UTC, Alexander Chuzhoy
no flags Details

Description Alexander Chuzhoy 2018-12-11 21:41:43 UTC
osp13->osp14 major upgrade error message during undercloud upgrade "Syntax error on line 23 of /etc/httpd/conf.d/ssl.conf:\nSSLSessionCache: 'shmcb' session cache not supported "

Environment:
python-passlib-1.7.0-4.el7ost.noarch
instack-undercloud-9.4.1-0.20180928005746.15cda5a.el7ost.noarch
python-httplib2-0.9.2-1.el7ost.noarch
httpd-2.4.6-88.el7.x86_64
openssl-1.0.2k-16.el7.x86_64
python-backports-ssl_match_hostname-3.5.0.1-1.el7.noarch
openstack-tripleo-heat-templates-9.0.1-0.20181013060901.el7ost.noarch
mod_ssl-2.4.6-88.el7.x86_64
httpd-tools-2.4.6-88.el7.x86_64
openssl-libs-1.0.2k-16.el7.x86_64
erlang-ssl-18.3.4.11-1.el7ost.x86_64
mod_ssl-2.4.6-88.el7.x86_64




Steps to reproduce:
1. Deploy OSP13 OC with:
openstack overcloud deploy \
--templates \
-e /home/stack/network-environment.yaml \
-e /usr/share/openstack-tripleo-heat-templates/environments/network-isolation.yaml \
-e /usr/share/openstack-tripleo-heat-templates/environments/ceph-ansible/ceph-ansible.yaml \
-e /home/stack/ceph.yaml \
-e /home/stack/virt/debug.yaml \
-e /home/stack/virt/nodes_data.yaml \
-e /home/stack/virt/docker-images.yaml \
-e /home/stack/dns_wipedisk_root_password.yaml


2. Update the undercloud.conf with:
[DEFAULT]
container_images_file = /home/stack/containers-prepare-parameter.yaml
docker_insecure_registries = rhos-qe-mirror-qeos.usersys.redhat.com:5000,brew-pulp-docker01.web.prod.ext.phx2.redhat.com:8888,registry.access.redhat.com
local_ip = 192.168.0.1/24
undercloud_public_host = 192.168.0.2
undercloud_admin_host = 192.168.0.3
undercloud_ntp_servers = clock.redhat.com
masquerade_network = 192.168.0.0/24
[auth]
[ctlplane-subnet]
cidr = 192.168.0.0/24
dhcp_start = 192.168.0.5
dhcp_end = 192.168.0.24
inspection_iprange = 192.168.0.100,192.168.0.120
gateway = 192.168.0.1


[stack@undercloud76 ~]$ cat /home/stack/containers-prepare-parameter.yaml
parameter_defaults:
  ContainerImagePrepare:
  - push_destination: true
    set:
      ceph_image: rhceph
      ceph_namespace: brew-pulp-docker01.web.prod.ext.phx2.redhat.com:8888
      ceph_tag: 3-13
      name_prefix: openstack-
      name_suffix: ''
      namespace: rhos-qe-mirror-qeos.usersys.redhat.com:5000/rhosp14
      neutron_driver: null
      openshift_base_image: ose
      openshift_cockpit_image: registry-console
      openshift_cockpit_namespace: registry.access.redhat.com/openshift3
      openshift_cockpit_tag: v3.9
      openshift_etcd_image: etcd
      openshift_etcd_namespace: registry.access.redhat.com/rhel7
      openshift_etcd_tag: latest
      openshift_gluster_block_image: rhgs-gluster-block-prov-rhel7
      openshift_gluster_image: rhgs-server-rhel7
      openshift_gluster_namespace: registry.access.redhat.com/rhgs3
      openshift_gluster_tag: latest
      openshift_heketi_image: rhgs-volmanager-rhel7
      openshift_heketi_namespace: registry.access.redhat.com/rhgs3
      openshift_heketi_tag: latest
      openshift_namespace: registry.access.redhat.com/openshift3
      openshift_tag: v3.9
      tag: 2018-12-05.2




3. Run 'openstack undercloud upgrade -y'


Result:

The upgrade fails. Digging through install-undercloud.log I see:

2018-10-24 01:27:15.409 1375 WARNING tripleoclient.v1.tripleo_deploy.Deploy [  ] fatal: [undercloud76]: FAILED! => {"changed": true, "cmd": "httpd -t -D DUMP_VHOSTS | grep -q heat_api_wsgi", "delta": "0:00:00.147834", "end": "2018-10-24 01:27:15.356925", "msg": "non-zero return code", "rc": 1, "start": "2018-10-24 01:27:15.209091", "stderr": "AH00526: Syntax error on line 23 of /etc/httpd/conf.d/ssl.conf:
SSLSessionCache: 'shmcb' session cache not supported (known names: ). Maybe you need to load the appropriate socache module (mod_socache_shmcb?).", "stderr_lines": ["AH00526: Syntax error on line 23 of /etc/httpd/conf.d/ssl.conf:", "SSLSessionCache: 'shmcb' session cache not supported (known names: ). Maybe you need to load the appropriate socache module (mod_socache_shmcb?)."], "stdout": "", "stdout_lines": []}



The w/a is to comment out this line in /etc/httpd/conf.d/ssl.conf (line 23):

SSLSessionCache         shmcb:/run/httpd/sslcache(512000)

Comment 1 Alexander Chuzhoy 2018-12-11 22:49:49 UTC
Created attachment 1513539 [details]
install-undercloud.log

Comment 3 Carlos Camacho 2018-12-24 10:13:49 UTC
There is a task failing with: 

2018-10-24 04:42:39.839 13760 WARNING tripleoclient.v1.tripleo_deploy.Deploy [  ] TASK [Ensure all online data migrations for Ironic have been applied] ************************************************************************************************************************
2018-10-24 04:42:40.525 13760 WARNING tripleoclient.v1.tripleo_deploy.Deploy [  ] fatal: [undercloud76]: FAILED! => {"changed": true, "cmd": ["docker", "exec", "ironic_api", "ironic-dbsync", "--config-file", "/etc/ironic/ironic.conf", "online_data_migrations"], "delta": "0:00:00.168807", "end": "2018-10-24 04:42:40.475842", "msg": "non-zero return code", "rc": 1, "start": "2018-10-24 04:42:40.307035", "stderr": "Error response from daemon: No such container: ironic_api", "stderr_lines": ["Error response from daemon: No such container: ironic_api"], "stdout": "", "stdout_lines": []}

Comment 5 Carlos Camacho 2019-01-14 14:13:58 UTC
I think this is  a duplicate of https://bugzilla.redhat.com/show_bug.cgi?id=1664705

Comment 6 Sergii Golovatiuk 2019-01-18 16:49:31 UTC

*** This bug has been marked as a duplicate of bug 1664705 ***


Note You need to log in before you can comment on or make changes to this bug.