Bug 165838 - Precision 380 has no usb input availible after install
Precision 380 has no usb input availible after install
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: anaconda (Show other bugs)
3.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-08-12 14:52 EDT by Gary Gatling
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-08-12 15:12:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gary Gatling 2005-08-12 14:52:08 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050511 Firefox/1.0.4

Description of problem:
On installing a new DELL precision 380 workstation with RHEL WS3 update 5 CDs the system is unresponsive to keyboard input on first boot post install. This is noticed when kudzu pops up a screen announcing that it has detected new hardware. So kudzu times out and the system proceeds to run first boot. At the "Welcome" screen in first boot both the usb mouse and usb keyboard are not working. The DELL precision 380 ships with USB keyboards and mice.

If you turn on sshd durring the install you can fix this problem by hand. ssh into your newly installed Precision 380. edit /etc/modules.conf and reverse the order of the usb-uhci and ehci-hcd lines like so:

configured by anaconda?:
alias eth0 tg3
alias scsi_hostadapter ata_piix
alias usb-controller usb-uhci
alias usb-controller1 ehci-hcd

edited:

alias eth0 tg3
alias scsi_hostadapter ata_piix
alias usb-controller1 ehci-hcd
alias usb-controller usb-uhci

Next, reboot your machine. 

/sbin/init 6

and on reboot the keyboard and mouse work fine so you can navigate through and finish first boot.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Install RHEL WS3 U5 on a DELL Precision 380 workstation with usb keyboard and mouse attached to system. On first boot note that the keyboard doesn't work.
2.Shell into the machine with SSH and reverse the order of the usb-uhci and ehci-hcd lines. reboot.
3. Notice that the usb mouse and usb keyboard now work.
  

Actual Results:  The keyboard started working again indicating there is a problem with the order of the lines with usb-uhci and ehci-hcd references in the installers initial configuration of the /etc/modules.conf file.

Additional info:

I recieved a hint that this is what I would need to do to get the system running from a user on the linux-precision mailing list @ DELL: http://lists.us.dell.com/pipermail/linux-precision/

http://lists.us.dell.com/mailman/listinfo/linux-precision

I would never have guessed that this was what I needed to do to get the keyboard/mouse to work.
Comment 1 Gary Gatling 2005-08-12 15:12:52 EDT
John Hull at DELL posted this to the list so it looks like this is a bug in the
BIOS of the PC rather than a red hat bug.

Date: Fri, 12 Aug 2005 14:05:07 -0500
From: John_Hull@Dell.com
To: gsgatlin@eos.ncsu.edu, linux-precision@lists.us.dell.com
Subject: RE: Precision 380 WS3 woes...

>We have been working on this issue here at Dell and have determined it
>to be a BIOS bug in its handling of USB. We should have this fix in the
>next BIOS update (but I don't have a hard date on when that will be). In
>the meantime, resolving the issue as outlined in Gary's bugzilla will
>work; another option is to boot to rescue mode with RHEL 3 U5 CD1, and
>edit the modules.conf file that way. If you only need PS/2 to work and
>not USB, you can also turn off the USB controller in the BIOS setup
>screen, and your PS/2 will work just fine.

I'll pass along more info about the BIOS fix as I receive it. 

So I guess there isn't anything for you guys to do. :)

Note You need to log in before you can comment on or make changes to this bug.