Bug 1658453 - Openshift 3.9.51-1 - Scale up Playbook Error with openshift_master_facts
Summary: Openshift 3.9.51-1 - Scale up Playbook Error with openshift_master_facts
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer
Version: 3.9.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
: 3.9.z
Assignee: Scott Dodson
QA Contact: sheng.lao
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-12-12 07:37 UTC by Suresh
Modified: 2019-01-10 08:55 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
An incorrect role inclusion path was used in the scaleup playbooks. That error has been corrected and now the master scaleup works as it should.
Clone Of:
Environment:
Last Closed: 2019-01-10 08:55:23 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:0028 None None None 2019-01-10 08:55:28 UTC

Description Suresh 2018-12-12 07:37:59 UTC
Description of problem:


Ran into an issue with the scale up playbook in Openshift 3.9.51-1


Moses provided us with a temporary work around by defining the path of the role in the playbook. 
The workaround/fix is below:


/usr/share/ansible/openshift-ansible/playbooks/openshift-node/scaleup.yml
- name: Ensure master facts are set
  hosts: oo_masters_to_config
  roles:
  #- openshift_master_facts
  - ../../roles/openshift_master_facts


Version-Release number of the following components:

openshift-ansible-playbooks-3.9.51-1.git.0.c4968ca.el7.noarch
openshift-ansible-docs-3.9.51-1.git.0.c4968ca.el7.noarch
atomic-openshift-utils-3.9.51-1.git.0.c4968ca.el7.noarch
openshift-ansible-3.9.51-1.git.0.c4968ca.el7.noarch
openshift-ansible-roles-3.9.51-1.git.0.c4968ca.el7.noarch


This is already merged:

https://github.com/openshift/openshift-ansible/pull/10767

We need to include this fix to the openshift-ansible package. 

How reproducible:

Steps to Reproduce:
1.
2.
3.

Actual results:
Please include the entire output from the last TASK line through the end of output if an error is generated

Expected results:

Additional info:
Please attach logs from ansible-playbook with the -vvv flag

Comment 1 Scott Dodson 2018-12-13 15:02:47 UTC
In openshift-ansible-3.9.55-1

Comment 2 Scott Dodson 2018-12-13 22:04:55 UTC
openshift-ansible-3.9.57-1.git.0.9ece605.el7 has shipped as an errata but we need QE to confirm this and close as appropriate

Comment 3 sheng.lao 2018-12-15 12:42:21 UTC
Verified with openshift-ansible-3.9.57-1.git.0.9ece605.el7.noarch.rpm

# oc get node --show-labels |grep new_node
ip-172-18-1-60.ec2.internal ... region=primary,role=new_node

# oc new-app nodejs-mongodb-example --node-selector='role=new_node'

# oc get pod nodejs-mongodb-example-2-xcl7k
NAME                             READY     STATUS    RESTARTS   AGE
nodejs-mongodb-example-2-xcl7k   1/1       Running   0          39m

# oc get pod nodejs-mongodb-example-2-xcl7k
NAME                             READY     STATUS    RESTARTS   AGE
nodejs-mongodb-example-2-xcl7k   1/1       Running   0          39m

Comment 4 sheng.lao 2018-12-15 12:43:19 UTC
# oc get pod nodejs-mongodb-example-2-xcl7k -o yaml |grep -A1 nodeSelector:
  nodeSelector:
    role: new_node

Comment 6 errata-xmlrpc 2019-01-10 08:55:23 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0028


Note You need to log in before you can comment on or make changes to this bug.