Bug 1658488 - Webadmin- Storage volumes window -> Snapshot-> options cluster -> 'update' button should be disabled when there is nothing to update
Summary: Webadmin- Storage volumes window -> Snapshot-> options cluster -> 'update' bu...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: Frontend.WebAdmin
Version: 4.3.0
Hardware: Unspecified
OS: Unspecified
low
low vote
Target Milestone: ovirt-4.4.2
: ---
Assignee: Ritesh Chikatwar
QA Contact: SATHEESARAN
URL:
Whiteboard:
Depends On:
Blocks: 1869598
TreeView+ depends on / blocked
 
Reported: 2018-12-12 09:33 UTC by Avihai
Modified: 2020-09-18 07:13 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1869598 (view as bug list)
Environment:
Last Closed: 2020-09-18 07:13:06 UTC
oVirt Team: Gluster
pm-rhel: ovirt-4.4+


Attachments (Terms of Use)
Video of the issue (386.34 KB, video/mp4)
2018-12-12 09:33 UTC, Avihai
no flags Details


Links
System ID Private Priority Status Summary Last Updated
oVirt gerrit 108622 0 master MERGED webadmin: Update button disabled when there is nothing to update 2020-09-08 04:04:08 UTC

Description Avihai 2018-12-12 09:33:27 UTC
Created attachment 1513633 [details]
Video of the issue

Description of problem:
Webadmin- Storage volumes window -> Snapshot-> options cluster -> 'update' button should be disabled when there is nothing to update - See attached capture movie.

Version-Release number of selected component (if applicable):
Software Version:4.3.0-0.2.master.20181128141347.git38908dd.el7


How reproducible:
100%

Steps to Reproduce:
1.Webadmin- Storage volumes window -> Snapshot-> options cluster -> 'update' 

Actual results:
the button should is not disabled when there is nothing to update so if you press update it will try to update which is not needed as there is nothing to update.

Expected results:
the 'update' button should be disabled when there is nothing to update - See attached capture movie.

Additional info:

Comment 1 SATHEESARAN 2020-09-08 09:50:45 UTC
Tested with RHV 4.4.2 and this issue is no longer seen.

1. On the web admin portal, navigated to Storage -> volumes
2. Click on snapshot and click on 'option-cluster'
3. Update the volume option

Now, it throws the error - "No volume snapshot option is available to update."

Comment 2 Sandro Bonazzola 2020-09-18 07:13:06 UTC
This bugzilla is included in oVirt 4.4.2 release, published on September 17th 2020.

Since the problem described in this bug report should be resolved in oVirt 4.4.2 release, it has been closed with a resolution of CURRENT RELEASE.

If the solution does not work for you, please open a new bug report.


Note You need to log in before you can comment on or make changes to this bug.