Bug 165849 - Disable FAN processing in Emulex lpfc driver
Disable FAN processing in Emulex lpfc driver
Status: CLOSED DUPLICATE of bug 165850
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: kernel (Show other bugs)
3.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tom Coughlan
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-08-12 16:39 EDT by Tom Coughlan
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-08-12 17:10:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tom Coughlan 2005-08-12 16:39:02 EDT
From my rhkernel-list posting on 05 Aug 2005:

Emulex requests the following fix for U6, if possible.

The current driver does not process a particular FC link event properly.
This can cause devices on the FC to become inaccessible.

The details: when an FC initialization event occurs a node can
optionally wait for a Fabric Address Notification (FAN) to arrive from
another node that it was in communication with. If the address
information in the FAN exactly match the values prior to the
initialization, then any existing exchanges can be resumed. If the FAN
does not arrive, or it is ignored, or the address values do not match,
then communication with the the remote node is restarted from scratch
(FLOGI - Fabric Login).

The patch simply ignores the FAN and goes straight to FLOGI. This is
done to keep the fix as simple as possible. The FLOGI path should be
very safe because it is already the default approach used in most other
FC link events.

I built the patched driver and did some regression testing. Emulex has
tested it and has already given it to their big OEMs for qualification.
Taking this patch is the best way for us to keep U6 synchronized with
the rest of the world.
Comment 1 Ernie Petrides 2005-08-12 17:10:28 EDT
Accidental dup of bug 165850.

*** This bug has been marked as a duplicate of 165850 ***

Note You need to log in before you can comment on or make changes to this bug.