Bug 1658514 - [downstream clone - 4.2.8] Clone VM with Direct LUN fails on UI but succeeds on backend.
Summary: [downstream clone - 4.2.8] Clone VM with Direct LUN fails on UI but succeeds ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine
Version: 4.2.6
Hardware: x86_64
OS: Linux
unspecified
low
Target Milestone: ovirt-4.2.8
: ---
Assignee: shani
QA Contact: Shir Fishbain
URL:
Whiteboard:
Depends On: 1635942
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-12-12 10:34 UTC by RHV bug bot
Modified: 2019-01-22 12:44 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
This fix addresses a warning message while cloning a VM with an attached direct logical unit number or a shareable disk. This release ensures the cloning succeeds, informs that the task is in process, and does not display the error message.
Clone Of: 1635942
Environment:
Last Closed: 2019-01-22 12:44:51 UTC
oVirt Team: Storage
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:0121 0 None None None 2019-01-22 12:44:57 UTC
oVirt gerrit 94933 0 master MERGED core: Fix disk's interface null value when cloning a VM 2020-03-17 18:45:37 UTC
oVirt gerrit 94967 0 ovirt-engine-4.2 MERGED core: Fix disk's interface null value when cloning a VM 2020-03-17 18:45:37 UTC

Description RHV bug bot 2018-12-12 10:34:01 UTC
+++ This bug is a downstream clone. The original bug is: +++
+++   bug 1635942 +++
======================================================================

Description of problem:

When cloning a VM that has a Direct LUN attached, the UI immediately shows the clone failed (task is red, failed), but the task is actually running just fine and later it finished, unlocking the VM.

Version-Release number of selected component (if applicable):
ovirt-engine-4.2.6.4-1.el7.noarch

How reproducible:
100%

Steps to Reproduce:
1. Create a VM, attach a Direct LUN Disk
2. Clone the VM

Actual results:
- Clone succeeds
- UI shows task as failed, but its actually running

Expected results:
- Clone succeeds
- UI shows task running, then completes when the disk copy finished.

Additional info:

2018-10-04 12:53:08,891+10 WARN  [org.ovirt.engine.core.bll.storage.disk.AttachDiskToVmCommand] (default task-4) [715bb46a] Validation of action 'AttachDiskToVm' failed for user admin@internal-authz. Reasons: VAR__ACTION__ATTACH_ACTION_TO,VAR__TYPE__DISK,VALIDATION_DISK_INTERFACE_NOT_NULL,$message VALIDATION_DISK_INTERFACE_NOT_NULL,$payload [Ljava.lang.Class;@47f46a48,$groups [Ljava.lang.Class;@232dfdbb,ACTION_TYPE_FAILED_ATTRIBUTE_PATH,$path diskVmElement.diskInterface,$validatedValue null

(Originally by Germano Veit Michel)

Comment 1 RHV bug bot 2018-12-12 10:34:03 UTC
Any symptoms from bug 1623379?

(Originally by michal.skrivanek)

Comment 2 RHV bug bot 2018-12-12 10:34:04 UTC
(In reply to Michal Skrivanek from comment #1)
> Any symptoms from bug 1623379?

I just blew up my test setup to do some more testing for bug 1620314 (unrelated), so cant check ui.log

But no, there were no UI exceptions, everything works fine, except the UI shows the task as failed immediately and the engine throws that warning. If one waits the clone creation actually finished, the VM is unlocked and everyone is happy.

I can test again if required... after I rebuild this =D

(Originally by Germano Veit Michel)

Comment 4 RHV bug bot 2018-12-12 10:34:07 UTC
The clone VM succeeded and the UI shows it.
The message from the task running(in green color): "Creating VM shir_clone_vm as a clone of VM shirVM" 

ovirt-engine-4.3.0-0.0.master.20181101091940.git61310aa.el7.noarch

(Originally by Shir Fishbain)

Comment 5 RHV bug bot 2018-12-12 10:34:09 UTC
The clone VM succeeded and the UI shows it.
The message from the task running(in green color): "Creating VM shirClone as a clone of VM shirVM"

ovirt-engine-4.2.8-0.0.master.20181119152157.gita72a684.el7.noarch
vdsm-4.20.43-4.gitb76af64.el7.x86_64

(Originally by Shir Fishbain)

Comment 6 RHV bug bot 2018-12-12 10:34:10 UTC
WARN: Bug status (VERIFIED) wasn't changed but the folowing should be fixed:

[Found non-acked flags: '{'rhevm-4.2.z': '?'}', ]

For more info please contact: rhv-devops@redhat.comINFO: Bug status (VERIFIED) wasn't changed but the folowing should be fixed:

[Found non-acked flags: '{'rhevm-4.2.z': '?'}', ]

For more info please contact: rhv-devops@redhat.com

(Originally by rhv-bugzilla-bot)

Comment 9 errata-xmlrpc 2019-01-22 12:44:51 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0121


Note You need to log in before you can comment on or make changes to this bug.