Bug 1658524 - Replace error notification with patternfly element
Summary: Replace error notification with patternfly element
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: Frontend.WebAdmin
Version: future
Hardware: All
OS: All
unspecified
low
Target Milestone: ovirt-4.4.0
: ---
Assignee: Lucia Jelinkova
QA Contact: Nikolai Sednev
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-12-12 11:20 UTC by Tomasz Barański
Modified: 2020-05-20 20:03 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
undefined
Clone Of:
Environment:
Last Closed: 2020-05-20 20:03:32 UTC
oVirt Team: Virt
pm-rhel: ovirt-4.4+


Attachments (Terms of Use)
Screenshot of the notifications to replace (58.26 KB, image/png)
2018-12-12 11:20 UTC, Tomasz Barański
no flags Details
Screenshot from 2020-03-03 13-47-07.png (72.96 KB, image/png)
2020-03-03 11:49 UTC, Nikolai Sednev
no flags Details


Links
System ID Private Priority Status Summary Last Updated
oVirt gerrit 100431 0 'None' MERGED webadmin: Changed warnings in host popup to PF 2020-03-24 14:23:34 UTC

Description Tomasz Barański 2018-12-12 11:20:34 UTC
Created attachment 1513653 [details]
Screenshot of the notifications to replace

Greg commented on a PR (re Edit Host panel):

> Not related to the patch, but note that those red notifications should be
> replaced with https://www.patternfly.org/pattern-library/communication/inline-notifications/

See the attachment for the screenshot of the notifications in question.

It needs to be done eventually

Comment 1 Ryan Barry 2019-01-21 14:54:15 UTC
Re-targeting to 4.3.1 since it is missing a patch, an acked blocker flag, or both

Comment 2 Nikolai Sednev 2020-03-03 11:49:04 UTC
Created attachment 1667176 [details]
Screenshot from 2020-03-03 13-47-07.png

I see as follows on latest components:
rhvm-appliance.x86_64 2:4.4-20200123.0.el8ev rhv-4.4.0                                               
sanlock-3.8.0-2.el8.x86_64
qemu-kvm-4.2.0-12.module+el8.2.0+5858+afd073bc.x86_64
vdsm-4.40.5-1.el8ev.x86_64
libvirt-client-6.0.0-7.module+el8.2.0+5869+c23fe68b.x86_64
ovirt-hosted-engine-setup-2.4.2-2.el8ev.noarch
ovirt-hosted-engine-ha-2.4.2-1.el8ev.noarch
Linux 4.18.0-183.el8.x86_64 #1 SMP Sun Feb 23 20:50:47 UTC 2020 x86_64 x86_64 x86_64 GNU/Linux
Red Hat Enterprise Linux release 8.2 Beta (Ootpa)

Engine is:
Software Version:4.4.0-0.17.master.el7
Red Hat Enterprise Linux Server release 7.8 Beta (Maipo)
Linux 3.10.0-1123.el7.x86_64 #1 SMP Tue Jan 14 03:44:38 EST 2020 x86_64 x86_64 x86_64 GNU/Linux

Comment 3 Nikolai Sednev 2020-03-03 11:56:28 UTC
Forth to our conversation with Lucia, moving this bug to verified, as only "red" warnings/errors should be replaced by patternfly warnings/errors and they are.

Comment 4 Sandro Bonazzola 2020-05-20 20:03:32 UTC
This bugzilla is included in oVirt 4.4.0 release, published on May 20th 2020.

Since the problem described in this bug report should be
resolved in oVirt 4.4.0 release, it has been closed with a resolution of CURRENT RELEASE.

If the solution does not work for you, please open a new bug report.


Note You need to log in before you can comment on or make changes to this bug.