Bug 1658586 - Unable to login to Gnome X session on ThinkPak P50 with hybrid graphics (Intel)
Summary: Unable to login to Gnome X session on ThinkPak P50 with hybrid graphics (Intel)
Keywords:
Status: CLOSED DUPLICATE of bug 1677022
Alias: None
Product: Red Hat Enterprise Linux 8
Classification: Red Hat
Component: xorg-x11-server
Version: 8.0
Hardware: x86_64
OS: Unspecified
unspecified
urgent
Target Milestone: rc
: 8.0
Assignee: Lyude
QA Contact: Desktop QE
URL:
Whiteboard:
Depends On:
Blocks: 1635157
TreeView+ depends on / blocked
 
Reported: 2018-12-12 13:17 UTC by Bohdan Milar
Modified: 2019-05-22 04:57 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-02-20 19:00:08 UTC
Type: Bug
Target Upstream Version:


Attachments (Terms of Use)
journalctl -xe in GDM just after boot (i.e. before first login). (170.48 KB, text/plain)
2018-12-12 13:17 UTC, Bohdan Milar
no flags Details
journalctl -xe after the first login (back in GDM). (164.86 KB, text/plain)
2018-12-12 13:20 UTC, Bohdan Milar
no flags Details
/home/test/.local/share/xorg/Xorg.0.log after the first login (back in GDM). (7.36 KB, text/plain)
2018-12-12 13:23 UTC, Bohdan Milar
no flags Details
journalctl -xe after the second login (empty screen). (154.76 KB, text/plain)
2018-12-12 13:25 UTC, Bohdan Milar
no flags Details
/home/test/.local/share/xorg/Xorg.0.log after the second login (empty screen). (7.36 KB, text/plain)
2018-12-12 13:27 UTC, Bohdan Milar
no flags Details
sosreport after unsuccessful login (7.20 MB, application/x-xz)
2019-01-04 16:51 UTC, Bohdan Milar
no flags Details
sosreport after unsuccessful login in lab (5.89 MB, application/x-xz)
2019-01-30 12:36 UTC, Bohdan Milar
no flags Details

Description Bohdan Milar 2018-12-12 13:17:00 UTC
Created attachment 1513667 [details]
journalctl -xe in GDM just after boot (i.e. before first login).

Description of problem:
If I use my P50 laptop undocked (so have only the built-in screen), hybrid graphics is on (in BIOS) and Intel GPU controls the built-in screen, I am unable to login to Gnome on X session from GDM. After boot when I try to log in for the first time, GDM appears again as if wrong password. When I try for the second time, GDM disappears, screen remains empty and no response from mouse or keyboard (not even CapsLock, NumLock or Ctrl+Alt+Fx). But system is still running, I can log in via SSH and restart GDM (which causes screen, mouse and keyboard to "unfreeze" and return to GDM).

Version-Release number of selected component (if applicable):
xorg-x11-server-Xorg-1.20.3-3.el8.x86_64
xorg-x11-drv-intel-2.99.917-38.20180618.el8.x86_64
xorg-x11-drv-ati-18.1.0-1.el8.x86_64
xorg-x11-drv-nouveau-1.0.15-4.el8.1.x86_64
kernel-4.18.0-50.el8.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Have P50 undocked with hybrid graphics and Intel controlling the built-in screen.
2. Boot RHEL 8 to GDM (running on Wayland).
3. Try to login to Gnome on X11 display server.
4. If GDM appears again, repeat step 3.

Actual results:
Empty screen, no response from mouse and keyboard (not even CapsLock, NumLock or Ctrl+Alt+Fx).

Expected results:
Gnome session on X should be started and shown on screen, mouse and keyboard should work.

Additional info:
- 00:02.0 VGA compatible controller: Intel Corporation HD Graphics 530 (rev 06)
- 01:00.0 VGA compatible controller: NVIDIA Corporation GM107GLM [Quadro M1000M] (rev a2)
- Gnome session on Wayland works on built-in screen controlled by Intel GPU.
- Gnome session on X works on built-in screen controlled by NVIDIA GPU.
- Gnome session on X works on external display (controlled by NVIDIA GPU; tested via docking station).

Comment 1 Bohdan Milar 2018-12-12 13:20:14 UTC
Created attachment 1513668 [details]
journalctl -xe after the first login (back in GDM).

Comment 2 Bohdan Milar 2018-12-12 13:23:26 UTC
Created attachment 1513669 [details]
/home/test/.local/share/xorg/Xorg.0.log after the first login (back in GDM).

Comment 3 Bohdan Milar 2018-12-12 13:25:36 UTC
Created attachment 1513670 [details]
journalctl -xe after the second login (empty screen).

Comment 4 Bohdan Milar 2018-12-12 13:27:23 UTC
Created attachment 1513672 [details]
/home/test/.local/share/xorg/Xorg.0.log after the second login (empty screen).

Comment 6 Bohdan Milar 2018-12-18 15:03:17 UTC
If I login with external screen connected via HDMI (no dock), Gnome session on X works. It continues working (when logged in) even after I disconnect the HDMI cable (so then using only the built-in screen).

Comment 9 Bohdan Milar 2019-01-04 16:51:57 UTC
Created attachment 1518443 [details]
sosreport after unsuccessful login

1. I booted the system to GDM
2. I tried to log in as "test" but accidentally used wrong password.
3. I tried to log in as "test" with correct password but in-stead GDM appeared again.
4. I tried to log in as "test" to Gnome on X - Gnome did not appear (black screen)
5. I made this sosreport as root via SSH.

Comment 10 Lyude 2019-01-07 21:01:13 UTC
Something's really weird here. This doesn't seem to be related to the BIOS bug, but your X server is printing out some errors I haven't seen before. Since that sosreport seems to be from an older kernel, could you make sure that updating your system doesn't end up fixing this?

As a note: I'm not having any luck reproducing this on my P50, X seems to come up 100% of the time here.

Comment 12 Bohdan Milar 2019-01-30 12:36:27 UTC
Created attachment 1525027 [details]
sosreport after unsuccessful login in lab

What I did:

1. Installed clear RHEL 8 (via PXE) on another P50 in lab - p50.tpb.lab.eng.brq.redhat.com
2. Added AppStream repo and installed Workstation
3. systemctl set-default graphical.target
4. Undocked the P50
5. reboot
6. Booted RHEL 8 to GDM (on Wayland)
7. Tried to log in as "test" to Gnome on X - Gnome did not appear (black screen)
8. Docked (1 screen connected via DVI)
9. Logged in as root via SSH.
10. Made this sosreport.

When docked with external screen, Gnome session on X starts without problem.

Comment 14 Lyude 2019-01-31 19:24:20 UTC
(In reply to Bohdan Milar from comment #12)
> Created attachment 1525027 [details]
> sosreport after unsuccessful login in lab
> 
> What I did:
> 
> 1. Installed clear RHEL 8 (via PXE) on another P50 in lab -
> p50.tpb.lab.eng.brq.redhat.com
> 2. Added AppStream repo and installed Workstation
> 3. systemctl set-default graphical.target
> 4. Undocked the P50
> 5. reboot
> 6. Booted RHEL 8 to GDM (on Wayland)
> 7. Tried to log in as "test" to Gnome on X - Gnome did not appear (black
> screen)
> 8. Docked (1 screen connected via DVI)
> 9. Logged in as root via SSH.
> 10. Made this sosreport.
> 
> When docked with external screen, Gnome session on X starts without problem.

So it isn't working at all when there's no external screen connected, am I correct?
Also thank you for the sosreport! X is definitely doing something funky here, but I'm not yet quite sure what

Comment 15 Lyude 2019-01-31 19:32:46 UTC
(In reply to Lyude from comment #14)
> (In reply to Bohdan Milar from comment #12)
> > Created attachment 1525027 [details]
> > sosreport after unsuccessful login in lab
> > 
> > What I did:
> > 
> > 1. Installed clear RHEL 8 (via PXE) on another P50 in lab -
> > p50.tpb.lab.eng.brq.redhat.com
> > 2. Added AppStream repo and installed Workstation
> > 3. systemctl set-default graphical.target
> > 4. Undocked the P50
> > 5. reboot
> > 6. Booted RHEL 8 to GDM (on Wayland)
> > 7. Tried to log in as "test" to Gnome on X - Gnome did not appear (black
> > screen)
> > 8. Docked (1 screen connected via DVI)
> > 9. Logged in as root via SSH.
> > 10. Made this sosreport.
> > 
> > When docked with external screen, Gnome session on X starts without problem.
> 
> So it isn't working at all when there's no external screen connected, am I
> correct?
> Also thank you for the sosreport! X is definitely doing something funky
> here, but I'm not yet quite sure what

(as well, I will give another try at reproducing this on my P50 today)

Comment 16 Bohdan Milar 2019-02-04 11:29:39 UTC
(In reply to Lyude from comment #14)
> (In reply to Bohdan Milar from comment #12)
> > ...
> > When docked with external screen, Gnome session on X starts without problem.
> 
> So it isn't working at all when there's no external screen connected, am I
> correct?

Yes. P50 undocked, without external screen connected, hybrid graphics on.

There is no problem when any external screen connected (no matter if via dock or directly). It even works if I log in with a screen connected directly (no dock) via HDMI and (while in Gnome) disconnect the external screen. Then X continues to work even with only built-in screen. So I guess the problem is somewhere in the Xorg initialization.

Comment 17 Lyude 2019-02-04 22:25:30 UTC
was about to ask if you were up to date, but then I finally managed to reproduce this bug :). Looking at it now

As a note: it took me a couple of tries before I managed to get this bug to come up

Comment 18 Lyude 2019-02-04 23:21:49 UTC
(In reply to Lyude from comment #17)
> was about to ask if you were up to date, but then I finally managed to
> reproduce this bug :). Looking at it now
> 
> As a note: it took me a couple of tries before I managed to get this bug to
> come up

ugh, and now I haven't managed to reproduce this bug once since the first time I hit it. It sounds like you're able to reproduce this pretty reliably on your P50? Additionally, do you think you could setup your P50 for ssh access so I could login and look at it?

Comment 19 Bohdan Milar 2019-02-05 09:28:14 UTC
(In reply to Lyude from comment #18)
> (In reply to Lyude from comment #17)
> > was about to ask if you were up to date, but then I finally managed to
> > reproduce this bug :). Looking at it now
> 
> ugh, and now I haven't managed to reproduce this bug once since the first
> time I hit it. It sounds like you're able to reproduce this pretty reliably
> on your P50?

On my P50, it is reproduceable 100 %, i.e. I am unable to login to Gnome on X without external screen.

> Additionally, do you think you could setup your P50 for ssh
> access so I could login and look at it?

I will try to setup my P50 or that one in the lab later today or tomorrow.

Comment 22 Lyude 2019-02-14 00:37:18 UTC
Investigated the machine that Bohdan gave me access to, got some bad news: this is just another duplicate of the infamous P50 BIOS bug. Luckily I managed to finally come up with a kernel workaround for said bug, so I've installed a fixed kernel onto the P50. Unfortunately after rebooting and testing a few times while I didn't manage to reproduce the problem after installing the fixed kernel, the laptop suddenly stopped responding and hasn't come back up. Can you take a look when you get into the office and check to see if this issue seems fixed now?

Comment 24 Bohdan Milar 2019-02-20 08:38:54 UTC
As we discussed via e-mail, the lab P50 was in kernel panic. So I restarted it and then was unable to reproduce the problem. So I guess we can close this bug.

Comment 25 Lyude 2019-02-20 19:00:08 UTC

*** This bug has been marked as a duplicate of bug 1677022 ***


Note You need to log in before you can comment on or make changes to this bug.