Bug 1658610 - [RFE] Resource group fields are not mandatory when ordering Azure stack
Summary: [RFE] Resource group fields are not mandatory when ordering Azure stack
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Provisioning
Version: 5.9.6
Hardware: All
OS: All
medium
medium
Target Milestone: GA
: 5.10.z
Assignee: Harpreet Kataria
QA Contact: Angelina Nikiforova
Red Hat CloudForms Documentation
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-12-12 14:12 UTC by Angelina Nikiforova
Modified: 2019-08-09 14:02 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-08-08 21:28:40 UTC
Category: ---
Cloudforms Team: CFME Core
Target Upstream Version:


Attachments (Terms of Use)

Description Angelina Nikiforova 2018-12-12 14:12:29 UTC
Description of problem:
When ordering service catalog created from orchestration template, it is possible to submit such request without filling "Existing Resource Group" or "(or) New Resource Group" fields. That will lead to the error in provisioning. One of these fields should be filled (be mandatory).

Version-Release number of selected component (if applicable):
5.9.6.5.20181130162459_7977a85
5.10.0.29.20181211195209_fd990a9

How reproducible:
Always

Steps to Reproduce:
1.Add azure template with resource_group selection field
2.Create Service Dialog from such template
3.Order Orchestration Stack
4.Do not fill in neither "Existing Resource Group" nor "(or) New Resource Group" and fill all the other fields
5.Click "Submit"

Actual results:
Request created

Expected results:
Request is not created because either of these fields should be filled.

Additional info:
This was discussed in BZ1549216 but wasn't in the bug description itself, so I'm creating a sepatate BZ for that.

Comment 2 Greg McCullough 2019-01-16 15:22:52 UTC
Currently the Service Dialogs do not allow for field validation to be conditional, for example field A is required if field B is not populated.  This would require and enhancement to the base dialog system to support advanced validation options.


Note You need to log in before you can comment on or make changes to this bug.