Bug 1658651 - overcloud deployment fails when overcloud images are built with ceph 2.0 content [NEEDINFO]
Summary: overcloud deployment fails when overcloud images are built with ceph 2.0 content
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-puppet-modules
Version: 8.0 (Liberty)
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: async
: 8.0 (Liberty)
Assignee: John Fulton
QA Contact: Yogev Rabl
URL:
Whiteboard:
: 1669188 (view as bug list)
Depends On:
Blocks: 1638128
TreeView+ depends on / blocked
 
Reported: 2018-12-12 15:41 UTC by Steve Linabery
Modified: 2019-03-06 16:24 UTC (History)
10 users (show)

Fixed In Version: openstack-puppet-modules-7.1.5-11.2.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-03-06 16:24:51 UTC
Target Upstream Version:
johfulto: needinfo? (slinaber)


Attachments (Terms of Use)

Description Steve Linabery 2018-12-12 15:41:38 UTC
Since libvirt 4.5.0-10.el7_6.3 from RHEL-7.6 is incompatible with ceph 0.94.5 from ceph 1.3 repos, we rebuilt the overcloud images using the content from ceph 2.0. The new overcloud images build is rhosp-director-images-8.0-20180928.1.el7ost.

The phase1 tripleo job is failing to deploy the overcloud using these new images.

osp8 has not been tested with ceph 2.0, so iiuc we need backports to tht and puppet-ceph (at a minimum).

In output from os-collect-config in /var/log/messages on controller-0, I see this error (I've cleaned up the error formatting in this paste):
Error: Could not start Service[ceph-mon-controller-0]: Execution of 'service ceph start mon.controller-0' returned 5: Redirecting to /bin/systemctl start  mon.controller-0 ceph.service
Failed to start mon.controller-0.service: Unit not found.
Failed to start ceph.service: Unit not found.
Wrapped exception:
Execution of 'service ceph start mon.controller-0' returned 5: Redirecting to /bin/systemctl start  mon.controller-0 ceph.service
Failed to start mon.controller-0.service: Unit not found.
Failed to start ceph.service: Unit not found.
Error: /Stage[main]/Ceph::Profile::Mon/Ceph::Mon[controller-0]/Service[ceph-mon-controller-0]/ensure: change from stopped to running failed: Could not start Service[ceph-mon-controller-0]: Execution of 'service ceph start mon.controller-0' returned 5: Redirecting to /bin/systemctl start  mon.controller-0 ceph.service
Failed to start mon.controller-0.service: Unit not found.
Failed to start ceph.service: Unit not found.
Warning: /Stage[main]/Ceph::Keys/Ceph::Key[client.admin]/Exec[ceph-injectkey-client.admin]: Skipping because of failed dependencies
Warning: /Stage[main]/Ceph::Keys/Ceph::Key[client.openstack]/Exec[ceph-injectkey-client.openstack]: Skipping because of failed dependencies
Warning: /Stage[main]/Ceph::Keys/Ceph::Key[client.bootstrap-osd]/Exec[ceph-injectkey-client.bootstrap-osd]: Skipping because of failed dependencies

Comment 12 Giulio Fidente 2019-02-11 14:05:26 UTC
*** Bug 1669188 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.