Bug 1658686 - Time-delayed automatic login doesn't work when disabling user list in GDM
Summary: Time-delayed automatic login doesn't work when disabling user list in GDM
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: gdm
Version: 7.6
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Ray Strode [halfline]
QA Contact: Desktop QE
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-12-12 16:37 UTC by Andrew Mike
Modified: 2019-08-06 12:38 UTC (History)
8 users (show)

Fixed In Version: gnome-shell-3.28.3-8.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-08-06 12:37:49 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 3751501 None None None 2018-12-12 17:00:19 UTC
Red Hat Product Errata RHBA-2019:2044 None None None 2019-08-06 12:38:05 UTC

Description Andrew Mike 2018-12-12 16:37:02 UTC
Description of problem:
When setting /org/gnome/login-screen/disable-user-list = true in dconf for gdm, TimedLogin settings in /etc/gdm/custom.conf are ignored at gdm start.

Version-Release number of selected component (if applicable):
3.28.2-10

How reproducible:
100%

Steps to Reproduce:
1 Run "systemctl isolate multi-user.target" as root to switch to multiuser mode and log in.
2. Add the following lines in the [daemon] section of /etc/gdm/custom.conf:
TimedLoginEnable=true
TimedLogin=<user>
TimedLoginDelay=10

3. Add the following to /etc/dconf/profile/gdm (if not there already):
user-db:user
system-db:gdm
file-db:/usr/share/gdm/greeter-dconf-defaults

4. Create /etc/dconf/db/gdm.d/01-custom-gdm-settings with the following lines:
[org/gnome/login-screen]
disable-user-list=true

5. Run "dconf update" as root to rebuild the dconf database.
6. Run "systemctl isolate graphical.target" as root to restart the graphical subsystem.

Actual results:
System remains at the GDM login prompt after 10 seconds.

Expected results:
System should log in automatically as <user>, with <user>'s graphical session, after 10 seconds.

Comment 9 Michael Boisvert 2019-05-07 12:14:45 UTC
Verified on gnome-shell-3.28.3-9.el7.x86_64. Timed login works as expected with the user list disabled.

Comment 11 errata-xmlrpc 2019-08-06 12:37:49 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:2044


Note You need to log in before you can comment on or make changes to this bug.