Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1658778 - Traceback when exiting mdflush command
Summary: Traceback when exiting mdflush command
Keywords:
Status: CLOSED DUPLICATE of bug 1658692
Alias: None
Product: Red Hat Enterprise Linux 8
Classification: Red Hat
Component: bcc
Version: 8.0
Hardware: All
OS: All
unspecified
medium
Target Milestone: rc
: 8.0
Assignee: Jerome Marchand
QA Contact: Christian Trautman
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-12-12 20:39 UTC by John Pittman
Modified: 2018-12-14 15:50 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-12-13 13:26:01 UTC
Type: Bug
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 3751801 0 None None None 2018-12-12 20:53:24 UTC

Description John Pittman 2018-12-12 20:39:40 UTC
Description of problem:

When exiting the mdflush command, there is a python traceback present:

[root@localhost tools]# ./mdflush
Tracing md flush requests... Hit Ctrl-C to end.
TIME     PID    COMM             DEVICE
15:09:47 8115   dd               md0
15:09:54 8119   dd               md0
15:10:00 8123   dd               md0
15:10:07 8127   dd               md0
15:10:13 8131   dd               md0
15:10:20 8135   dd               md0
15:10:26 8139   dd               md0
^CTraceback (most recent call last):
  File "./mdflush", line 81, in <module>
    b.perf_buffer_poll()
  File "/usr/lib/python3.6/site-packages/bcc/__init__.py", line 1216, in perf_buffer_poll
    lib.perf_reader_poll(len(readers), readers, timeout)
KeyboardInterrupt

Version-Release number of selected component (if applicable):

kernel-4.18.0-48.el8.x86_64
bcc-0.7.0-3.el8.x86_64
bcc-tools-0.7.0-3.el8.x86_64

Steps to Reproduce:

Install bcc and bcc-tools
Execute mdflush
Use ctrl-c to exit

Actual results:

Traceback is reported

Expected results:

Ctrl-c exit should be smooth as in biotop or bitesize

Comment 1 Jerome Marchand 2018-12-13 13:26:01 UTC
Multiple tools do not properly catch the keyboard interrupt and it's not very clean indeed. But let's stick to one bz for this.

*** This bug has been marked as a duplicate of bug 1658369 ***

Comment 2 Jerome Marchand 2018-12-14 15:48:40 UTC

*** This bug has been marked as a duplicate of bug 1658692 ***

Comment 3 Jerome Marchand 2018-12-14 15:50:51 UTC
Sorry, I marked this as a duplicate of the wrong bz.


Note You need to log in before you can comment on or make changes to this bug.