Bug 1658824 - systemd-journal-remote missing upload user
Summary: systemd-journal-remote missing upload user
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 8
Classification: Red Hat
Component: systemd
Version: 8.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: 8.0
Assignee: Jan Synacek
QA Contact: qe-baseos-daemons
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-12-12 23:00 UTC by Scott Poore
Modified: 2019-12-18 09:14 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-12-18 09:14:47 UTC
Type: Bug
Target Upstream Version:


Attachments (Terms of Use)

Description Scott Poore 2018-12-12 23:00:39 UTC
Description of problem:

I ran into an issue when setting up systemd-journal-upload to "send" journal log entries to a remote host.  It appears that 

[root@vm2 CA]# grep User= /lib/systemd/system/systemd-journal-upload.service
User=systemd-journal-upload
DynamicUser=yes

[root@vm2 CA]# id systemd-journal-upload
id: ‘systemd-journal-upload’: no such user


Version-Release number of selected component (if applicable):
systemd-journal-remote-239-8.el8.x86_64

How reproducible:
always

Steps to Reproduce:
1.  dnf install systemd-journal-remote
2.  id systemd-journal-upload

Actual results:
no user created.

Expected results:
since the service sets a user, I would expect the rpm to create it during install.

Additional info:

Comment 2 Jan Synacek 2019-12-18 09:14:47 UTC
DynamicUser= creates the user dynamically at runtime and frees the allocation when the service finishes. The user is not added to /etc/passwd or similar and "id" command won't show it. For more information, see man systemd.exec(5), section CREDENTIALS.


Note You need to log in before you can comment on or make changes to this bug.