Bug 165884 - dhcp6c crashes sometimes
dhcp6c crashes sometimes
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: dhcpv6 (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jason Vas Dias
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-08-13 11:47 EDT by Peter Bieringer
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version: 0.10-14
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-05 02:12:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Peter Bieringer 2005-08-13 11:47:47 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; de-DE; rv:1.7.10) Gecko/20050720 Fedora/1.0.6-1.1.fc4 Firefox/1.0.6

Description of problem:
During playing around with dhcp6c, it sometimes crashes

Version-Release number of selected component (if applicable):
dhcpv6-0.10-13

How reproducible:
Sometimes

Steps to Reproduce:
1. cat /etc/dhcp6c.conf
interface eth0 {
#       information-only;
        send rapid-commit;
        request domain-name-servers;
#       request temp-address;
};


2. dhcp6c  -f eth0

segmentation fault
  

Actual Results:  # LANG=C gdb /sbin/dhcp6c core.7370
GNU gdb Red Hat Linux (6.3.0.0-1.21rh)
Copyright 2004 Free Software Foundation, Inc.
GDB is free software, covered by the GNU General Public License, and you are
welcome to change it and/or distribute copies of it under certain conditions.
Type "show copying" to see the conditions.
There is absolutely no warranty for GDB.  Type "show warranty" for details.
This GDB was configured as "i386-redhat-linux-gnu"...(no debugging symbols found)
Using host libthread_db library "/lib/libthread_db.so.1".

Reading symbols from shared object read from target memory...(no debugging symbols found)...done.
Loaded system supplied DSO at 0xf5f000
Core was generated by `dhcp6c -f eth0'.
Program terminated with signal 11, Segmentation fault.

warning: svr4_current_sos: Can't read pathname for load map: Input/output error

Reading symbols from /lib/libresolv.so.2...Reading symbols from /usr/lib/debug/lib/libresolv-2.3.5.so.debug...done.
done.
Loaded symbols for /lib/libresolv.so.2
Reading symbols from /lib/libcrypto.so.5...done.
Loaded symbols for /lib/libcrypto.so.5
Reading symbols from /lib/libc.so.6...Reading symbols from /usr/lib/debug/lib/libc-2.3.5.so.debug...done.
done.
Loaded symbols for /lib/libc.so.6
Reading symbols from /lib/libdl.so.2...Reading symbols from /usr/lib/debug/lib/libdl-2.3.5.so.debug...done.
done.
Loaded symbols for /lib/libdl.so.2
Reading symbols from /usr/lib/libz.so.1...done.
Loaded symbols for /usr/lib/libz.so.1
Reading symbols from /lib/ld-linux.so.2...Reading symbols from /usr/lib/debug/lib/ld-2.3.5.so.debug...done.
done.
Loaded symbols for /lib/ld-linux.so.2
#0  0x0805c41e in dprintf ()
(gdb) bt
#0  0x0805c41e in dprintf ()
#1  0x0805c9b3 in dprintf ()
#2  0x080540fe in dprintf ()
#3  0x0804b009 in ?? ()
#4  0x0804cb5b in ?? ()
#5  0x00e00de6 in __libc_start_main (main=0x804c24c, argc=3, ubp_av=0xbf8a86b4, init=0x805e40c <getifaddrs+3404>,
    fini=0x805e45c <getifaddrs+3484>, rtld_fini=0x23af2d <_dl_fini>, stack_end=0xbf8a86ac) at ../sysdeps/generic/libc-start.c:228
#6  0x08049ab1 in ?? ()
(gdb)


Expected Results:  Not crashing

Additional info:

I can provide core file, if necessary.
Comment 1 Jason Vas Dias 2005-08-15 21:37:34 EDT
I am not able to reproduce this problem, but it may be fixed with the new
dhcpv6-0.10-14_FC4 release, available from:
  http://people.redhat.com/~jvdias/dhcpv6/FC4 
and shortly to be released in fc4-updates-testing.

The above gdb trace shows that dhcp6c generates a memory access violation
in the getifaddrs() function.

Now, the problem was that dhcpv6-0.10-13- provided its own getifaddrs 
implementation, but our glibc has its own (probably more up-to-date and robust) 
implementation.

With dhcpv6-0.10-14, I removed dhcpv6's getifaddrs implementation (and some
other glibc function implementations it was defining).

If you can still reproduce this problem with dhcpv6-0.10-14, please can you
append the output of these commands from the time when the problem occurs:
# ip link show
# ip addr show
( the violation in getifaddrs is probably specific to a certain IP interface
  configuration
) - thank you!
Comment 2 Jason Vas Dias 2005-08-22 12:59:56 EDT
As I'm still not able to reproduce any crash with the new dhcpv6-0.10-14, and
no further information has been posted to this bug, I'm assuming it is fixed
with the new version - if not, please re-open.

Note You need to log in before you can comment on or make changes to this bug.