Bug 1658847 - [machines] [RFE] ability to stop and delete storage pool from cockpit GUI
Summary: [machines] [RFE] ability to stop and delete storage pool from cockpit GUI
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 8
Classification: Red Hat
Component: cockpit-appstream
Version: 8.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: rc
: 8.1
Assignee: Katerina Koukiou
QA Contact: YunmingYang
Vendula Ferschmannova
URL:
Whiteboard:
Depends On: 1678935
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-12-13 02:15 UTC by Ulhas Surse
Modified: 2019-11-05 20:41 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
.Adding improvements to Virtual Machines configuration With this update, the RHEL 8 web console includes a lot of improvements in the Virtual Machines page. You can now: * Manage various types of storage pools * Configure VM autostart * Import existing qcow images * Install VMs through PXE boot * Change memory allocation * Pause/resume VMs * Configure cache characteristics (directsync, writeback) * Change the boot order
Clone Of:
Environment:
Last Closed: 2019-11-05 20:41:35 UTC
Type: Feature Request
Target Upstream Version:


Attachments (Terms of Use)
cockpit (71.82 KB, image/png)
2018-12-13 02:47 UTC, Ulhas Surse
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:3325 None None None 2019-11-05 20:41:46 UTC

Description Ulhas Surse 2018-12-13 02:15:43 UTC
Description of problem:

1] After removing the mount point from the host, it is not possible to stop/ delete the storage pool from the cockpit GUI. 

2] Even in general, there is no option to delete storage-pool from the cockpit GUI after creating it. 

3] This can be done from the virt-manager. 

  Connection --> Details --> Storage --> Stop pool --> Delete pool (icons)

Version-Release number of selected component (if applicable):
RHEL 8 Beta

cockpit-dashboard-183-1.el8.noarch
cockpit-storaged-183-1.el8.noarch
cockpit-183-1.el8.x86_64


How reproducible:
Always

Steps to Reproduce:
1. From the tab "Virtual Machines" --> "Storage Pools"
2. Create a storage pool
3. There is no option to stop or delete it. 

Actual results:
Unable to delete pool.

Expected results:
Ability to stop and delete the storage pool just like in virt-manager. 

Additional info:

Comment 1 Ulhas Surse 2018-12-13 02:21:45 UTC
Also, can we add options to start/ stop/ autostart ability for the storage pool for the cockpit GUI?

Comment 3 Ulhas Surse 2018-12-13 02:47:18 UTC
Created attachment 1513862 [details]
cockpit

OK, autostart is available when the host boots but we are still missing on stop and remove storage pool options.

Comment 4 Martin Pitt 2018-12-13 06:45:27 UTC
Katerina is currently working on storage pool deletion. I suppose stopping should not take much extra work.

Comment 5 Katerina Koukiou 2019-02-08 10:30:21 UTC
This functionality was implemented within:

commit edcfa9933c82756546c78da9d1d6489fb8f1f5d6
Author: Katerina Koukiou <kkoukiou@redhat.com>

    machines: implement delete operation for storage pools

and

commit 9f1131def138a5f1070687285afdf213b27366f6
Author: Katerina Koukiou <kkoukiou@redhat.com>

    machines: implement deactivate operation for storage pools

Comment 7 YunmingYang 2019-05-29 06:21:05 UTC
Test Versions:
cockpit-machines-193-1.el8.noarch
libvirt-dbus-1.2.0-2.module+el8.1.0+2983+b2ae9c0a.x86_64

Test Steps:
1. Create a storage pool through page
2. Click the 'Deactivate' button of the storage pool, and make sure with command which is 'virsh pool-info ${poolname}'.
3. Click the 'Activate' button of the storage pool, and make sure with command which is 'virsh pool-info ${poolname}'.
4. Click the 'Delete' button of the storage pool, and make sure with command which is 'virsh pool-list --all'.

Test Results:
The storage pool can be deactivated/activated/deleted from the page, and the results of command are correct.


According to the results, the storage pool can be deactivated/activated/deleted.So move the status to VERIFIED.

Comment 12 errata-xmlrpc 2019-11-05 20:41:35 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:3325


Note You need to log in before you can comment on or make changes to this bug.