Bug 1659005 - gi.overrides.BlockDev.DMError: Failed to activate the RAID set 'pdc_bjifjcag'
Summary: gi.overrides.BlockDev.DMError: Failed to activate the RAID set 'pdc_bjifjcag'
Keywords:
Status: CLOSED DUPLICATE of bug 1664634
Alias: None
Product: Fedora
Classification: Fedora
Component: python-blivet
Version: 29
Hardware: i686
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Blivet Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:2d1c36b945af1a14824cb7bef5b...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-12-13 11:00 UTC by dtdraganov
Modified: 2019-01-21 10:05 UTC (History)
12 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-01-21 10:05:30 UTC


Attachments (Terms of Use)
File: anaconda-tb (472.74 KB, text/plain)
2018-12-13 11:00 UTC, dtdraganov
no flags Details
File: anaconda.log (9.92 KB, text/plain)
2018-12-13 11:00 UTC, dtdraganov
no flags Details
File: dbus.log (3.13 KB, text/plain)
2018-12-13 11:00 UTC, dtdraganov
no flags Details
File: dnf.librepo.log (83.59 KB, text/plain)
2018-12-13 11:00 UTC, dtdraganov
no flags Details
File: environ (637 bytes, text/plain)
2018-12-13 11:00 UTC, dtdraganov
no flags Details
File: hawkey.log (2.49 KB, text/plain)
2018-12-13 11:00 UTC, dtdraganov
no flags Details
File: lorax-packages.log (23.48 KB, text/plain)
2018-12-13 11:00 UTC, dtdraganov
no flags Details
File: lsblk_output (2.19 KB, text/plain)
2018-12-13 11:00 UTC, dtdraganov
no flags Details
File: nmcli_dev_list (1.60 KB, text/plain)
2018-12-13 11:00 UTC, dtdraganov
no flags Details
File: os_info (651 bytes, text/plain)
2018-12-13 11:00 UTC, dtdraganov
no flags Details
File: program.log (14.44 KB, text/plain)
2018-12-13 11:00 UTC, dtdraganov
no flags Details
File: storage.log (28.09 KB, text/plain)
2018-12-13 11:00 UTC, dtdraganov
no flags Details
File: syslog (258.92 KB, text/plain)
2018-12-13 11:00 UTC, dtdraganov
no flags Details
File: ifcfg.log (2.15 KB, text/plain)
2018-12-13 11:00 UTC, dtdraganov
no flags Details
File: packaging.log (5.69 KB, text/plain)
2018-12-13 11:00 UTC, dtdraganov
no flags Details

Description dtdraganov 2018-12-13 11:00:22 UTC
Description of problem:
Started the installation, and several seconds after showing me the initial screen for choosing the language to be used during the installation, it gave me this bug. I didn't do anything, had not pressed any button, or even clicked with the mouse on installation program yet.  

Version-Release number of selected component:
anaconda-29.24.7

The following was filed automatically by anaconda:
anaconda 29.24.7 exception report
Traceback (most recent call first):
  File "/usr/lib/python3.7/site-packages/gi/overrides/BlockDev.py", line 993, in wrapped
    raise transform[1](msg)
  File "/usr/lib/python3.7/site-packages/blivet/populator/helpers/dmraid.py", line 69, in run
    blockdev.dm.activate_raid_set(rs_name)
  File "/usr/lib/python3.7/site-packages/blivet/populator/populator.py", line 304, in handle_format
    helper_class(self, info, device).run()
  File "/usr/lib/python3.7/site-packages/blivet/threads.py", line 53, in run_with_lock
    return m(*args, **kwargs)
  File "/usr/lib/python3.7/site-packages/blivet/populator/populator.py", line 276, in handle_device
    self.handle_format(info, device)
  File "/usr/lib/python3.7/site-packages/blivet/threads.py", line 53, in run_with_lock
    return m(*args, **kwargs)
  File "/usr/lib/python3.7/site-packages/blivet/populator/populator.py", line 461, in _populate
    self.handle_device(dev)
  File "/usr/lib/python3.7/site-packages/blivet/threads.py", line 53, in run_with_lock
    return m(*args, **kwargs)
  File "/usr/lib/python3.7/site-packages/blivet/populator/populator.py", line 413, in populate
    self._populate()
  File "/usr/lib/python3.7/site-packages/blivet/threads.py", line 53, in run_with_lock
    return m(*args, **kwargs)
  File "/usr/lib/python3.7/site-packages/blivet/blivet.py", line 161, in reset
    self.devicetree.populate(cleanup_only=cleanup_only)
  File "/usr/lib/python3.7/site-packages/blivet/threads.py", line 53, in run_with_lock
    return m(*args, **kwargs)
  File "/usr/lib/python3.7/site-packages/pyanaconda/storage/osinstall.py", line 1738, in reset
    super().reset(cleanup_only=cleanup_only)
  File "/usr/lib/python3.7/site-packages/blivet/threads.py", line 53, in run_with_lock
    return m(*args, **kwargs)
  File "/usr/lib/python3.7/site-packages/pyanaconda/storage/osinstall.py", line 2298, in storage_initialize
    storage.reset()
  File "/usr/lib/python3.7/threading.py", line 865, in run
    self._target(*self._args, **self._kwargs)
  File "/usr/lib/python3.7/site-packages/pyanaconda/threading.py", line 286, in run
    threading.Thread.run(self)
gi.overrides.BlockDev.DMError: Failed to activate the RAID set 'pdc_bjifjcag'

Additional info:
addons:         com_redhat_docker, com_redhat_kdump
cmdline:        /usr/bin/python3  /sbin/anaconda
cmdline_file:   BOOT_IMAGE=vmlinuz initrd=initrd.img inst.stage2=hd:LABEL=Fedora-WS-dvd-i386-29 quiet
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         4.18.16-300.fc29.i686
product:        Fedora
release:        Cannot get release name.
type:           anaconda
version:        29

Potential duplicate: bug 1631228

Comment 1 dtdraganov 2018-12-13 11:00:25 UTC
Created attachment 1513982 [details]
File: anaconda-tb

Comment 2 dtdraganov 2018-12-13 11:00:27 UTC
Created attachment 1513983 [details]
File: anaconda.log

Comment 3 dtdraganov 2018-12-13 11:00:28 UTC
Created attachment 1513984 [details]
File: dbus.log

Comment 4 dtdraganov 2018-12-13 11:00:31 UTC
Created attachment 1513985 [details]
File: dnf.librepo.log

Comment 5 dtdraganov 2018-12-13 11:00:32 UTC
Created attachment 1513986 [details]
File: environ

Comment 6 dtdraganov 2018-12-13 11:00:34 UTC
Created attachment 1513987 [details]
File: hawkey.log

Comment 7 dtdraganov 2018-12-13 11:00:36 UTC
Created attachment 1513988 [details]
File: lorax-packages.log

Comment 8 dtdraganov 2018-12-13 11:00:37 UTC
Created attachment 1513989 [details]
File: lsblk_output

Comment 9 dtdraganov 2018-12-13 11:00:38 UTC
Created attachment 1513990 [details]
File: nmcli_dev_list

Comment 10 dtdraganov 2018-12-13 11:00:39 UTC
Created attachment 1513991 [details]
File: os_info

Comment 11 dtdraganov 2018-12-13 11:00:41 UTC
Created attachment 1513992 [details]
File: program.log

Comment 12 dtdraganov 2018-12-13 11:00:43 UTC
Created attachment 1513993 [details]
File: storage.log

Comment 13 dtdraganov 2018-12-13 11:00:45 UTC
Created attachment 1513994 [details]
File: syslog

Comment 14 dtdraganov 2018-12-13 11:00:46 UTC
Created attachment 1513995 [details]
File: ifcfg.log

Comment 15 dtdraganov 2018-12-13 11:00:48 UTC
Created attachment 1513996 [details]
File: packaging.log

Comment 16 Jiri Konecny 2018-12-13 11:59:30 UTC
Based on the traceback it looks like an issue in our storage library.

Comment 17 Vojtech Trefny 2019-01-21 10:05:30 UTC

*** This bug has been marked as a duplicate of bug 1664634 ***


Note You need to log in before you can comment on or make changes to this bug.