Bug 1659129 - "compose-cli compose cancel <uuid>" results in a hung compose-api server
Summary: "compose-cli compose cancel <uuid>" results in a hung compose-api server
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: lorax
Version: 7.7
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: rc
: ---
Assignee: Brian Lane
QA Contact: Release Test Team
Eliane Ramos Pereira
URL:
Whiteboard:
: 1659131 (view as bug list)
Depends On: 1656691
Blocks: 1659131
TreeView+ depends on / blocked
 
Reported: 2018-12-13 16:17 UTC by Brian Lane
Modified: 2019-08-06 13:00 UTC (History)
4 users (show)

Fixed In Version: lorax-19.7.20-1
Doc Type: Bug Fix
Doc Text:
.Cancelling a job initiated from `cockpit-composer` no longer fails Image build process did not support cancelling an image build. As a consequence, cancelling a job initiated from `cockpit-composer` GUI using `composer-cli compose cancel` resulted in a hung compose API server, causing newly queued job builds to not start, and remain in waiting state. To fix the problem, a feature to cancel the Image build process was implemented. As a result, cancelling a job initiated from `cockpit-composer` no longer fails.
Clone Of: 1656691
: 1659131 (view as bug list)
Environment:
Last Closed: 2019-08-06 13:00:19 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:2161 None None None 2019-08-06 13:00:31 UTC

Description Brian Lane 2018-12-13 16:17:13 UTC
+++ This bug was initially created as a clone of Bug #1656691 +++

Description of problem:

unlike BZ #1656684, canceling a job initiated from cockpit-composer gui using "composer-cli compose cancel" results in a hung compose api server.  Newly queued job builds do not start. It remains in waiting state.


--- Additional comment from Brian Lane on 2018-12-07 11:21:52 PST ---

Thanks. Recovering from a crash/reboot is a known issue and #1647985 should fix that.

I'll try to make sense of the logs, but what I was trying to figure out is if you issued 2 cancels to the same build. Either from 2 cli sessions or from cli and gui sessions. It looks like something removed the results directory before the build was done, and it's possible that 2 different requests may do this since I don't have a check for a previously waiting cancel (working on adding that now).


Also, with the current code, cancel really only works before the build starts. I'm working on trying to cancel anaconda while it is running, but am not sure if that can be done without causing other problems. So the cancel will hang until the build is finished and then it will delete the results.

--- Additional comment from Brian Lane on 2018-12-13 08:12:42 PST ---

https://github.com/weldr/lorax/pull/547

Comment 2 Brian Lane 2019-02-20 18:03:23 UTC
Backport PR is here https://github.com/weldr/lorax/pull/615
The pylorax changes will go to rhel7-branch and rhel7-extras, the pylorax.api changes to rhel7-extras only.

Comment 5 Eliane Ramos Pereira 2019-05-29 13:37:44 UTC
Hi Vladimir,

Thanks for pointing me this out.

Comment 9 Brian Lane 2019-07-22 22:16:36 UTC
*** Bug 1659131 has been marked as a duplicate of this bug. ***

Comment 11 errata-xmlrpc 2019-08-06 13:00:19 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:2161


Note You need to log in before you can comment on or make changes to this bug.