Bug 165914 - Error (-53: 'Could not claim the USB device')
Error (-53: 'Could not claim the USB device')
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gphoto2 (Show other bugs)
rawhide
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Radek Vokal
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-08-13 22:32 EDT by John Ellson
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-12-16 04:26:36 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Ellson 2005-08-13 22:32:26 EDT
Description of problem:
Permissions are not being set for the console user to access the usbcam.
Root can read files from the camera without problem.

/var/run/console/console.lock  contains the right user.

Last line in /var/log/messages is:
Aug 13 22:02:59 ontap kernel: usb 2-4: new full speed USB device using ohci_hcd
and address 8

I don't think that   /etc/hotplug/usb/usbcam  is being run.  
What program runs it?


Version-Release number of selected component (if applicable):
gphoto2-2.1.6-2
kernel-2.6.12-1.1469_FC5
udev-063-6
hotplug-2004_09_23-9

How reproducible:
100%

Steps to Reproduce:
1.plugin Canon G3 usb camera
2.gphoto2 -T
3.
  
Actual results:
*** Error ***
An error occurred in the io-library ('Could not claim the USB device'): Could
not claim interface 0 (Operation not permitted). Make sure no other program or
kernel module (such as sdc2xx, stv680, spca50x) is using the device and you have
read/write access to the device.
*** Error (-53: 'Could not claim the USB device') ***


Expected results:
I want the camera's folder to just popup automatically in nautilus showing
thumnails, all oriented correctly, and with no erally obscure permissions issues
to hassle with.  This camera used to work on Linux. 

Additional info:
Comment 1 John Ellson 2005-09-07 22:52:19 EDT
Only change is now: kernel-2.6.13-1.1542_FC5

Different message, but seems like same error:
    An error occurred in the io-library ('Could not claim the USB device'):
Could not claim interface 0 (Operation not permitted). Make sure no other
program or kernel module (such as sdc2xx, stv680, spca50x) is using the device
and you have read/write access to the device.

I added the line "echo hi >/tmp/imhere" to /etc/hotplug/usb/usbcam
and, AFAICT, the usbcam script is never run.

running gphoto2 --debug gives:

...
1.215828 gphoto2-setting(2): Setting key 'port' to value 'usb:' (gphoto2)
1.215895 gphoto2-setting(2): Saving 2 setting(s) to file "/home/ellson/.gphoto/s
ettings"
1.216488 gphoto2-camera(2): Listing files in '/'...
1.216552 gphoto2-camera(2): Initializing camera...
1.216630 gphoto2-port(0): The supplied vendor or product id (0x0,0x0) is not val id.
1.216689 gphoto2-port-usb(1): Looking for USB device (class 0x6, subclass, 0xfff
fffff, protocol 0xffffffff)... found.
1.224353 gphoto2-port-usb(1): Detected defaults: config 1, interface 0, altsetti
ng 0, idVendor ID 04a9, idProduct 309d, inep 81, outep 02, intep 83
1.225404 gphoto2-camera(2): Loading '/usr/lib64/gphoto2/2.1.6/libgphoto2_ptp2.so
'...
1.230930 gphoto2-port(2): Opening USB port...
1.231072 gphoto2-port(0): Could not query kernel driver of device.
1.231138 gphoto2-port(0): Could not claim interface 0 (Operation not permitted).
 Make sure no other program or kernel module (such as sdc2xx, stv680, spca50x) i
s using the device and you have read/write access to the device.
1.231232 context(0): An error occurred in the io-library ('Could not claim the U
SB device'): Could not claim interface 0 (Operation not permitted). Make sure no
 other program or kernel module (such as sdc2xx, stv680, spca50x) is using the d
evice and you have read/write access to the device.

*** Error ***
An error occurred in the io-library ('Could not claim the USB device'): Could no
t claim interface 0 (Operation not permitted). Make sure no other program or ker
nel module (such as sdc2xx, stv680, spca50x) is using the device and you have re
ad/write access to the device.
*** Error (-53: 'Could not claim the USB device') ***
...


Comment 2 John Ellson 2005-11-12 09:50:31 EST
Duplicate of #150985.   Fixed by gphoto2-2.1.6-6 + patch in #150985 comment #16

Note You need to log in before you can comment on or make changes to this bug.