Bug 1659211 - virt-p2v: Conversion failed: NBD server error: timed out waiting for NBD server to start
Summary: virt-p2v: Conversion failed: NBD server error: timed out waiting for NBD serv...
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: libguestfs
Version: 7.4
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: rc
: ---
Assignee: Richard W.M. Jones
QA Contact: Virtualization Bugs
URL:
Whiteboard: P2V
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-12-13 19:59 UTC by Anitha Udgiri
Modified: 2020-04-24 07:35 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-05-13 10:13:09 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 3776641 0 None None None 2018-12-27 07:15:08 UTC

Description Anitha Udgiri 2018-12-13 19:59:41 UTC
Description of problem:

Cutomer is trying to convert a RHEL 7.4 physical server to virtual and gets the following error :

Error Message: Conversion failed: NDB server error: timed out waiting for NBD server to start.

Customer is using the following packages :

virt-p2v-1.38.2-5.el7 and  virt-v2v-1.38.2-12.22.lp.el7ev.x86_64

There are no logs created at this point.

Comment 2 Anitha Udgiri 2018-12-13 20:01:31 UTC
Attached are the journalct logs and screen shot of the error

Comment 5 Anitha Udgiri 2018-12-13 20:05:24 UTC
Rich,
   I will ask the customer to obtain the debug output. In the meantime, do let us know if there is anything pertinent in the logs attached.

~Anitha

Comment 6 Richard W.M. Jones 2018-12-13 20:33:45 UTC
Thanks Anitha, I believe there is enough information in the journal that
the customer supplied.  Looking at it now.

Comment 7 Richard W.M. Jones 2018-12-13 20:42:24 UTC
This is a bug in virt-p2v.  The details are below.

The error is:

Dec 13 13:19:58 localhost launch-virt-p2v[1278]: qemu-nbd: Failed to bdrv_open '/dev/sda': Could not open '/dev/sda': No medium found: No medium found

It turns out this guest has 15 SCSI disks:

Dec 13 13:19:33 localhost launch-virt-p2v[1278]: disks  . . . . .   sda sdb sdc sdd sde sdf sdg sdh sdi sdj sdk sdl sdm sdn sdo

From the logs I can see that:
sda, sdb = removable disk of some kind (virtual CD?)
sdc = 600G hard disk
sdd, sdo = ? unclear
sde, sdf, sdg, sgh, sdi, sdj = large EMC SAN LUNs I think
sdk, sdl, sdm = 1.1 T hard disk or LUN

The bug is that virt-p2v should ignore removable disks called "/dev/sdX" (currently
it only ignores ones called /dev/sr*).

As a way to work around this, can the customer try to uncheck all checkboxes
which appear next to /dev/sda, /dev/sdb and any other removable devices, or
any devices which don't contain system data that they need to transfer to the
remote end.

Comment 8 Richard W.M. Jones 2019-05-13 10:13:09 UTC
We're not planning any more work on virt-p2v in RHEL 7 once 7.7 is released.
This does look as if it's still a bug.  If the issue can be reproduced in
RHEL 8 or upstream please file a new bug there.

Comment 9 savvy 2020-04-23 15:28:22 UTC
Hi Richard, 

I'm currently facing this issue and tried the suggested comment but could not solve the issue.
Let me know how we can fix this issue in the code.

I have /dev/sda /dev/sdb and dev/sdc as the device. (sda is virtual floppy)
case 1: when all the 3 are selected fails with current issue. 
case 2: when I deselected it all it says "at least one fixed hard disk must be selected" 
case 3: I tried with sdb and sdc it failed as "Conversion failed: virt-v2v exited with status 1".

case3 log snippet:

libguestfs: trace: v2v: mountpoints
guestfsd: <= mountpoints (0x93) request length 40 bytes^M
command: lvm 'lvs' '-o' 'vg_name,lv_name' '-S' 'lv_role=public && lv_skip_activation!=yes' '--noheadings' '--separator' '/'^M
command: lvm returned 0^M
command: lvm: stdout:^M
  centos/home^M
  centos/root^M
  centos/swap^M
command: lvm: stderr:^M
  WARNING: Device for PV 9djYRc-B7X4-TjQN-hBfi-vbhq-25us-jziqAG not found or rejected by a filter.^M
  Couldn't find device with uuid 9djYRc-B7X4-TjQN-hBfi-vbhq-25us-jziqAG.^M
guestfsd: error: stat: /dev/centos/home: No such file or directory^M
guestfsd: => mountpoints (0x93) took 0.01 secs^M
libguestfs: trace: v2v: mountpoints = NULL (error)
^[[1;31mvirt-v2v: error: libguestfs error: mountpoints: stat: /dev/centos/home: No
such file or directory^[[0m
rm -rf '/var/tmp/null.QTAhVq'
libguestfs: trace: v2v: close
libguestfs: closing guestfs handle 0x56362074f260 (state 2)
libguestfs: trace: v2v: internal_autosync

Regards,
Savitha

Comment 10 Pino Toscano 2020-04-24 07:35:18 UTC
Hi Savitha,

at least from a quick glance, what you report seems unrelated to this bug.
Please open a new bug, specifying the COMPLETE setup of the conversion: the version of virt-v2v, the version of virt-p2v, the hardware of the machine being converted, the OS on the machine being converted, and the complete logs.
You can find more details in the documentation of virt-p2v:
http://libguestfs.org/virt-p2v.1.html
see the "HOW VIRT-P2V WORKS" section about which files to fetch from the conversion server after a failed conversion.

Thanks.


Note You need to log in before you can comment on or make changes to this bug.