Bug 1659253 - Poedit is missing an application icon
Summary: Poedit is missing an application icon
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: poedit
Version: 29
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: c72578
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-12-13 22:12 UTC by Daniel Rusek
Modified: 2019-01-20 03:00 UTC (History)
5 users (show)

Fixed In Version: poedit-2.2-3.fc29 poedit-2.2-2.fc28
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-01-20 01:59:27 UTC


Attachments (Terms of Use)
Icon of the running Poedit window (2.46 KB, image/png)
2018-12-13 22:12 UTC, Daniel Rusek
no flags Details

Description Daniel Rusek 2018-12-13 22:12:26 UTC
Created attachment 1514244 [details]
Icon of the running Poedit window

Description of problem:
It seems that Poedit has incorrect (default) application icon. The desktop launcher has correct icon, however the actual Poedit window does not. See the attached screenshot.

Version-Release number of selected component (if applicable):
poedit-2.2-2.fc29.x86_64

How reproducible:
Every time.

Steps to Reproduce:
1. Install Poedit.
2. Run Poedit.
3. See if the Poedit window has correct icon.

Actual results:
Poedit has blank icon.

Expected results:
Poedit has correct application icon.

Comment 1 c72578 2018-12-14 01:22:49 UTC
Thanks for the bug report.
There is an upstream issue for this bug:
https://github.com/vslavik/poedit/issues/538

Remark: The issue is related to Wayland. As a workaround, the "Gnome on Xorg" option can be chosen in the session chooser on the login screen, if desired.

Comment 2 Fedora Update System 2019-01-11 12:08:17 UTC
poedit-2.2-3.fc29 has been submitted as an update to Fedora 29. https://bodhi.fedoraproject.org/updates/FEDORA-2019-347fa92148

Comment 3 Fedora Update System 2019-01-11 12:13:45 UTC
poedit-2.2-2.fc28 has been submitted as an update to Fedora 28. https://bodhi.fedoraproject.org/updates/FEDORA-2019-ec4b2dc690

Comment 4 Fedora Update System 2019-01-12 02:30:42 UTC
poedit-2.2-3.fc29 has been pushed to the Fedora 29 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-347fa92148

Comment 5 Fedora Update System 2019-01-12 02:35:27 UTC
poedit-2.2-2.fc28 has been pushed to the Fedora 28 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-ec4b2dc690

Comment 6 Fedora Update System 2019-01-20 01:59:27 UTC
poedit-2.2-3.fc29 has been pushed to the Fedora 29 stable repository. If problems still persist, please make note of it in this bug report.

Comment 7 Fedora Update System 2019-01-20 03:00:48 UTC
poedit-2.2-2.fc28 has been pushed to the Fedora 28 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.