Bug 1659260 - Mouse left click stops working under certain condition
Summary: Mouse left click stops working under certain condition
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: gnome-shell-extensions
Version: 7.6
Hardware: x86_64
OS: Linux
high
high
Target Milestone: rc
: ---
Assignee: Florian Müllner
QA Contact: Desktop QE
URL:
Whiteboard:
Depends On:
Blocks: 1697555
TreeView+ depends on / blocked
 
Reported: 2018-12-13 22:30 UTC by Joe Wright
Modified: 2019-11-01 20:50 UTC (History)
10 users (show)

Fixed In Version: gnome-shell-extensions-3.28.1-6.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1697555 (view as bug list)
Environment:
Last Closed: 2019-08-06 12:37:49 UTC
Target Upstream Version:


Attachments (Terms of Use)
proposal number 5 (1.44 KB, patch)
2019-03-06 21:40 UTC, Ray Strode [halfline]
no flags Details | Diff


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:2044 None None None 2019-08-06 12:38:05 UTC

Description Joe Wright 2018-12-13 22:30:27 UTC
Description of problem:
- If you minimize an application, then attempt to right click it in the bar, but do not release the right click and move the mouse pointer off of the app tab and release the right button in the main part of the screen, the left click doesn't work to open the app in the tab bar.  UNTIL you right click anywhere else...then it works

Version-Release number of selected component (if applicable):
- RHEL 7.6, RHEL 7.5 (Gnome 3.22/ Gnome 3.28)

How reproducible:
- 100%

Steps to Reproduce:
1. Minimize an application
2. Right click it in the minimized bar for the application, but do not release the button
3. Drag the mouse to the desktop while continuing to hold the right mouse button
4. Release right mouse button
5. Left click no longer works

Actual results:
- Left click stops working until you right click again somewhere on the desktop

Expected results:
- Mouse button release registers properly?

Additional info:

Comment 4 Ray Strode [halfline] 2019-03-06 21:40:05 UTC
Created attachment 1541611 [details]
proposal number 5

this is the fix that would have minimal impact on other extensions and code.

Comment 19 Michael Boisvert 2019-05-07 19:09:26 UTC
Verified on gnome-shell-extensions-3.28.1-6.el7 and gnome-shell-3.28.3-10.el7.

Comment 21 errata-xmlrpc 2019-08-06 12:37:49 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:2044


Note You need to log in before you can comment on or make changes to this bug.