Bug 1659308 - [RHEL8]xtables-nft-multi maybe not check rule as strict as old iptables.
Summary: [RHEL8]xtables-nft-multi maybe not check rule as strict as old iptables.
Keywords:
Status: CLOSED DUPLICATE of bug 1659307
Alias: None
Product: Red Hat Enterprise Linux 8
Classification: Red Hat
Component: iptables
Version: 8.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: 8.0
Assignee: Phil Sutter
QA Contact: qe-baseos-daemons
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-12-14 03:23 UTC by yiche
Modified: 2018-12-18 15:44 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-12-18 15:44:27 UTC
Type: Bug
Target Upstream Version:


Attachments (Terms of Use)

Description yiche 2018-12-14 03:23:25 UTC
Description of problem:
xtables-nft-multi maybe not check rule as strict as old iptables.

Version-Release number of selected component (if applicable):
iptables v1.8.1 (nf_tables)

How reproducible:
always

Steps to Reproduce:
iptables -t mangle -A OUTPUT -p tcp -j TCPMSS --set-mss 135
RHEL7 will give a promptin dmesg: xt_TCPMSS: Only works on TCP SYN packets
but RHEL8 accept this rule without --syn.

Actual results:
accept is rule.

Expected results:
reject this rule and give out prompt.

Additional info:

Comment 1 Phil Sutter 2018-12-18 15:44:27 UTC

*** This bug has been marked as a duplicate of bug 1659307 ***


Note You need to log in before you can comment on or make changes to this bug.