Bug 1659329 - curl-7.63.0-1.fc30 breaks fedpkg new-sources
Summary: curl-7.63.0-1.fc30 breaks fedpkg new-sources
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: curl
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Kamil Dudka
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-12-14 05:49 UTC by Kevin Fenzi
Modified: 2019-01-21 09:02 UTC (History)
5 users (show)

Fixed In Version: curl-7.63.0-2.fc30
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-01-21 09:02:03 UTC


Attachments (Terms of Use)

Description Kevin Fenzi 2018-12-14 05:49:52 UTC
With curl-7.63.0-1.fc30 I get: 

%  fedpkg -v new-sources ansible-2.7.5.tar.gz                                                    
Creating repo object from /home/kevin/git/pkgs/ansible/master                                                          
Could not execute new_sources: Fail to upload files. Server returns status 400                                         
Traceback (most recent call last):                                                                                     
  File "/usr/bin/fedpkg", line 11, in <module>                                                                         
    load_entry_point('fedpkg==1.35', 'console_scripts', 'fedpkg')()                                                    
  File "/usr/lib/python3.7/site-packages/fedpkg/__main__.py", line 94, in main                                         
    sys.exit(client.args.command())                                                                                    
  File "/usr/lib/python3.7/site-packages/pyrpkg/cli.py", line 2199, in new_sources                                    
    self.cmd.upload(self.args.files, replace=self.args.replace)                                                       
  File "/usr/lib/python3.7/site-packages/pyrpkg/__init__.py", line 2776, in upload                                    
    f, file_hash)                                                                                                     
  File "/usr/lib/python3.7/site-packages/pyrpkg/lookaside.py", line 289, in upload                                    
    if self.remote_file_exists(name, filename, hash):                                                                 
  File "/usr/lib/python3.7/site-packages/pyrpkg/lookaside.py", line 256, in remote_file_exists                        
    self.raise_upload_error(status)                                                                                   
  File "/usr/lib/python3.7/site-packages/pyrpkg/lookaside.py", line 127, in raise_upload_error                        
    raise UploadError(message, http_status=http_status)                                                               
pyrpkg.errors.UploadError: Fail to upload files. Server returns status 400 

downgrading to 7.62.0-1.fc30 I get: 

✗ fedpkg -v new-sources ansible-2.7.5.tar.gz                                                   
Creating repo object from /home/kevin/git/pkgs/ansible/master                                                         
Uploading: ansible-2.7.5.tar.gz                                                                                       
######################################################################## 100.0%                                       
b'File ansible-2.7.5.tar.gz size 11781337 SHA512 b3a8a2c10e42f4dcf0f3867901eaaf555e6b9bcbd808b91765a8825db3ec49d618d889
3f244d52e49e944d0900a876bbb31b3a7b89d636e435e94cd4b281be18 stored OK'                                                 
Source upload succeeded. Don't forget to commit the sources file

So, something seems to have broken in the latest version...

Comment 1 Kamil Dudka 2018-12-14 10:05:19 UTC
Thanks for the report!  I will have a look...

Comment 2 Kamil Dudka 2018-12-14 10:31:41 UTC
`git bisect` says that the following upstream patch broke it:

    https://github.com/curl/curl/commit/curl-7_62_0-52-g07ebaf837

I have reverted the patch to unblock Fedora development:

    https://src.fedoraproject.org/cgit/rpms/curl.git/commit/?id=c30a9c7f

However, the root cause yet needs to be properly analyzed because the revert of the patch will reintroduce the following upstream bug, which is not really desired:

    https://github.com/curl/curl/pull/3275

Comment 3 Kevin Fenzi 2018-12-14 18:35:37 UTC
Thanks for tracking it down and the quick revert!

Comment 4 Kamil Dudka 2018-12-19 11:30:14 UTC
An independent upstream report that blames the same commit:

https://github.com/curl/curl/issues/3384

Comment 5 Kamil Dudka 2019-01-21 09:02:03 UTC
Upstream reverted the commit that had introduced this bug and we picked the revert:

https://src.fedoraproject.org/rpms/curl/c/da8449de


Note You need to log in before you can comment on or make changes to this bug.