Bug 1659364 - Need update jenkins-2-rhel7 registry for v4.0
Summary: Need update jenkins-2-rhel7 registry for v4.0
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Image Registry
Version: 4.1.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.1.0
Assignee: Gabe Montero
QA Contact: Wenjing Zheng
URL:
Whiteboard:
: 1659358 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-12-14 08:11 UTC by XiuJuan Wang
Modified: 2019-06-04 10:41 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-06-04 10:41:16 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:0758 None None None 2019-06-04 10:41:21 UTC

Description XiuJuan Wang 2018-12-14 08:11:40 UTC
Description of problem:
The default installed jenkins:2 imagestreamtag points to openshift3/jenkins-2-rhel7:v4.0 which does not exist.
Should be openshift/jenkins-2-rhel7:v4.0

Version-Release number of selected component (if applicable):

Server https://***-40-master-etcd-1:8443
openshift v4.0.0-0.97.0
kubernetes v1.11.0+0ce2fe6658

How reproducible:
always

Steps to Reproduce:
1.Check jenkins imagestreams
2.
3.

Actual results:
jenkins:2 imagestreamtag points to **/openshift3/jenkins-2-rhel7:v4.0 which does not exist.

Expected results:
jenkins:2 should point to **/openshift/jenkins-2-rhel7:v4.0

Additional info:

Comment 1 Gabe Montero 2018-12-14 20:46:15 UTC
First step of 3:  PR https://github.com/openshift/jenkins/pull/763

step 2: bump openshift/library

step 3: bump openshift/cluster-samples-operator

side bar step: update openshift/origin

Comment 2 Gabe Montero 2018-12-15 22:27:25 UTC
step 3:  PR https://github.com/openshift/cluster-samples-operator/pull/68

Comment 3 Gabe Montero 2018-12-16 04:50:29 UTC
OK https://github.com/openshift/cluster-samples-operator/pull/68 merged ... moving to QA

Comment 4 wewang 2018-12-17 06:01:00 UTC
I saw in 3.11 aws env, default jenkins2 is from openshift3 registry, and in origin https://github.com/openshift/origin/blob/master/examples/image-streams/image-streams-rhel7.json#L233 is also openshift3, 
maybe should double confirm the bug, Gabe what do you think?
# oc describe is jenkins -n openshift
Name:			jenkins
Namespace:		openshift
Created:		5 hours ago
Labels:			<none>
Annotations:		openshift.io/display-name=Jenkins
			openshift.io/image.dockerRepositoryCheck=2018-12-17T00:40:05Z
Docker Pull Spec:	docker-registry.default.svc:5000/openshift/jenkins
Image Lookup:		local=false
Unique Images:		2
Tags:			3

1
  tagged from registry.redhat.io/openshift3/jenkins-1-rhel7:latest
    prefer registry pullthrough when referencing this tag

  Provides a Jenkins 1.X server on RHEL 7. For more information about using this container image, including OpenShift considerations, see https://github.com/openshift/jenkins/blob/master/README.md.
  Tags: hidden, jenkins

  * registry.redhat.io/openshift3/jenkins-1-rhel7@sha256:3ae2a9ea40f6xxxxxxb
      5 hours ago

2 (latest)
  tagged from registry.redhat.io/openshift3/jenkins-2-rhel7:v3.11
    prefer registry pullthrough when referencing this tag

  Provides a Jenkins 2.X server on RHEL 7. For more information about using this container image, including OpenShift considerations, see https://github.com/openshift/jenkins/blob/master/README.md.
  Tags: jenkins

  * registry.redhat.io/openshift3/jenkins-2-rhel7@sha256:adcdd0319e87503d6e730923c9xxxx
      5 hours ago

Comment 5 wewang 2018-12-17 10:08:54 UTC
Gabe, you can ignore comment 4, but I using sample operator to create rhel jenkins image, still saw it's from openshift3 project
bin/openhift-install v0.7.0-master-4-ga4e426ee762c20019bbb90fe35d33c9b26d23393

here's my steps:
1.Removed centos imagestream by set managementState: Removed in samplesresource

2.Create a secret with credentials for registry.redhat.io under openshift-cluster-samples-operator project
#oc create secret generic samples-registry-credentials \
--from-file=.dockerconfigjson=<path/to/.docker/config.json> \
 --type=kubernetes.io/dockerconfigjson

3.Switch installtype to rhel 
#oc patch samplesresources openshift-samples -p '{"spec":{"installType":"rhel","managementState":"Managed"}}'  --type='merge'

4.Check imagestream later
$ oc describe is jenkins -n openshift
Name:			jenkins
Namespace:		openshift
Created:		3 seconds ago
Labels:			samplesoperator.config.openshift.io/managed=true
Annotations:		openshift.io/display-name=Jenkins
			samplesoperator.config.openshift.io/version=b61113433f047d1c661604ebe64345f21d4a063c
Image Repository:	image-registry.openshift-image-registry.svc:5000/openshift/jenkins
Image Lookup:		local=false
Unique Images:		0
Tags:			3

1
  tagged from registry.redhat.io/openshift3/jenkins-1-rhel7:latest
    prefer registry pullthrough when referencing this tag

  Provides a Jenkins 1.X server on RHEL 7. For more information about using this container image, including OpenShift considerations, see https://github.com/openshift/jenkins/blob/master/README.md.
  Tags: hidden, jenkins

  ~ importing latest image ...

2 (latest)
  tagged from registry.redhat.io/openshift3/jenkins-2-rhel7:v4.0
    prefer registry pullthrough when referencing this tag

  Provides a Jenkins 2.X server on RHEL 7. For more information about using this container image, including OpenShift considerations, see https://github.com/openshift/jenkins/blob/master/README.md.
  Tags: jenkins

  ~ importing latest image ...

Comment 6 Gabe Montero 2018-12-17 16:08:00 UTC
Hey @wewang

the jenkins-1-rhel7 image is still going to be registry.redhat.io/openshift3/jenkins-1-rhel7:latest 

we quit making that a few releases ago ... there will be no v4.0 version of that ... hence it will stay openshift3

For the jenkins-2-rhel image, there must be some lag with the test images available to QE

When I tried with the very lates (where I manually update the samples-operator image), I get the correct value for the "2" tag:

2 (latest)
  tagged from registry.redhat.io/openshift/jenkins-2-rhel7:v4.0
    prefer registry pullthrough when referencing this tag

Comment 7 Ben Parees 2018-12-17 16:55:28 UTC
*** Bug 1659358 has been marked as a duplicate of this bug. ***

Comment 8 wewang 2018-12-18 09:14:37 UTC
Tested latest samples operator, verified it
version:
brewregistry.xxxxt.io/openshift/ose-cluster-samples-operator e7a200ffdac7
[root@qe-wewang-5master-etcd-1 ~]# oc describe is jenkins -n openshift
2 (latest)
  tagged from registry.redhat.io/openshift/jenkins-2-rhel7:v4.0
    prefer registry pullthrough when referencing this tag

  Provides a Jenkins 2.X server on RHEL 7. For more information about using this container image, including OpenShift considerations, see https://github.com/openshift/jenkins/blob/master/README.md.
  Tags: jenkins

  ! error: Import failed (InternalError): Internal error occurred: unknown: Not Found

Comment 9 Gabe Montero 2019-01-08 16:03:42 UTC
This is a 4.0 specific bug found during the 4.0 dev cycle ... no doc update needed

Comment 12 errata-xmlrpc 2019-06-04 10:41:16 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0758


Note You need to log in before you can comment on or make changes to this bug.