This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 165940 - Winbind used by squid to auth, crashed internal error signal 11
Winbind used by squid to auth, crashed internal error signal 11
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: samba (Show other bugs)
4.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Simo Sorce
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-08-14 23:53 EDT by Andre
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-03-28 16:10:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
/var/log/samba.winbind.log (1.13 KB, text/plain)
2005-08-15 00:16 EDT, Andre
no flags Details

  None (edit)
Description Andre 2005-08-14 23:53:40 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.10) Gecko/20050720 Fedora/1.0.6-1.1.fc3 Firefox/1.0.6

Description of problem:
Squid is authenticating through this winbind, and then the winbind connect to a samba acting as a PDC server.
In the last 3 weeks, winbind keeps crashing every sunday at 4 am, i've checked cron.weekly and there is only anacron and makewhatis scripts
The error said that I should checked samba-howto-collection bug appendix section, but there's no such appendix, but in "how to report a bug" they said that a coredump will be dumped and i could post the gdb result here, i've checked in /var/log/samba but there isn't any coredumps

"service winbind restart" shows no error and make winbind run again.



Version-Release number of selected component (if applicable):
samba-common-3.0.13-1.4E.2
squid-2.5.STABLE6-3.4E.9
kernel-2.6.9-5.EL
glibc-2.3.4-2.9

How reproducible:
Didn't try

Steps to Reproduce:
1. install samba-common-3.0.13-1.4E.2 squid-2.5.STABLE6-3.4E.9
2. auth it against samba-3.0.13-1.4E.2 pdc 
3.
  

Additional info:
Comment 1 Andre 2005-08-15 00:16:35 EDT
Created attachment 117727 [details]
/var/log/samba.winbind.log

This happens since a few weeks ago
[root@proxy samba]# head -n1 winbindd.log*
==> winbindd.log <==
[2005/08/14 04:02:26, 0] lib/fault.c:fault_report(36)

==> winbindd.log.1 <==
[2005/08/07 04:02:06, 0] lib/fault.c:fault_report(36)

==> winbindd.log.2 <==
[2005/07/31 04:02:07, 0] lib/fault.c:fault_report(36)

==> winbindd.log.3 <==
[2005/07/25 04:02:22, 0] lib/fault.c:fault_report(36)
Comment 2 Andre 2005-08-21 05:19:04 EDT
It is dead again

[root@proxy samba]# date
Sun Aug 21 15:15:52 WIT 2005

[root@proxy ~]# service winbind status
winbindd dead but pid file exists

[root@proxy samba]# cat /var/log/samba/winbindd.log
[2005/08/21 04:02:05, 0] lib/fault.c:fault_report(36)
  ===============================================================
[2005/08/21 04:02:05, 0] lib/fault.c:fault_report(37)
  INTERNAL ERROR: Signal 11 in pid 1932 (3.0.13-1.4E.2)
  Please read the appendix Bugs of the Samba HOWTO collection
[2005/08/21 04:02:05, 0] lib/fault.c:fault_report(39)
  ===============================================================
[2005/08/21 04:02:05, 0] lib/util.c:smb_panic2(1517)
  PANIC: internal error
[2005/08/21 04:02:05, 0] lib/util.c:smb_panic2(1525)
  BACKTRACE: 9 stack frames:
   #0 winbindd(smb_panic2+0x8a) [0x663b1d]
   #1 winbindd(smb_panic+0x19) [0x663d49]
   #2 winbindd [0x6501cf]
   #3 /lib/tls/libc.so.6 [0x2a68c8]
   #4 winbindd(wcache_invalidate_cache+0x94) [0x608c69]
   #5 winbindd [0x5fb2c9]
   #6 winbindd(main+0xac6) [0x5fc3ad]
   #7 /lib/tls/libc.so.6(__libc_start_main+0xd3) [0x293e23]
   #8 winbindd [0x5fadb1]

[root@proxy samba]# service winbind restart

Shutting down Winbind services:                            [FAILED]
Starting Winbind services:                                 [  OK  ]
[root@proxy samba]#
Comment 3 Andre 2005-08-21 05:24:42 EDT
I forget to attach my smb.conf, here it is:

[global]
        workgroup = DOMAIN
        netbios name = PROXY
        server string = Proxy Server
        interfaces = <ip address>
        security = DOMAIN
        password server = SAMBAPDC
        log level = 10
        log file = /var/log/samba/%m.log
        max log size = 50
        socket options = TCP_NODELAY SO_RCVBUF=8192 SO_SNDBUF=8192
        load printers = No
        printcap name = /etc/printcap
        dns proxy = No
        idmap uid = 16777216-33554431
        idmap gid = 16777216-33554431
        winbind use default domain = Yes
        hosts allow = 192.168., 127.
        cups options = raw
        encrypt passwords = yes
Comment 4 RHEL Product and Program Management 2006-08-18 13:26:01 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 5 Nalin Dahyabhai 2006-08-31 17:49:42 EDT
Can you reproduce this bug with the packages from RHEL 4 (3.0.10-1.4E.9)?  Where
did this packages come from?
Comment 7 Kevin Krafthefer 2007-03-28 16:10:05 EDT
The requested information never came in for a resolution to be arrived at. We
are unable to reproduce here at Red Hat. Please reopen this bug if you can
provide the requested information.


Note You need to log in before you can comment on or make changes to this bug.