Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1659603 - Broken preview of attachments like patches and plain text
Summary: Broken preview of attachments like patches and plain text
Keywords:
Status: CLOSED DUPLICATE of bug 1658655
Alias: None
Product: Bugzilla
Classification: Community
Component: Attachments/Requests
Version: 5.0
Hardware: All
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: PnT DevOps Devs
QA Contact: tools-bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-12-14 18:57 UTC by Alexey Klimov
Modified: 2019-03-14 03:47 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-03-14 03:47:27 UTC


Attachments (Terms of Use)

Description Alexey Klimov 2018-12-14 18:57:05 UTC
Description of problem:

Problem appeared after the upgrade to 5.0 as far as I understand.
On previous release when someone clicks on the attachment, then the following could happen:
1) If it is a patch, then it opens in browser and content of the patch is shown (without fancy colours and with correct indentation). Content of the patch was shown in plain text mode.
2) If the file is a plain text file, then it opens in browser and can be observed.

With a new version the behaviour is different:
1) If it is a patch file, then browser suggests to download it (and doesn't open it). When someone clicks on "Diff", then the behaviour is like this:
by default it shows the diff in fancy colours and shows by default side-by-side. While the expected that by default it should be line-by-line (like in the previous version).

The most important bug here is that indentation is broken. In previous version plain text was shown with correct indentation while in the new version of Bugzilla it looks like formats the output and breaks the correct indentation.

2) When it is a plain text attachments it suggests to download it.

Examples: 1653437, 1576008

Version-Release number of selected component (if applicable):

New release 5.0 (as far as I understood).

How reproducible:

Always.

Steps to Reproduce:
1. Perform described actions.

Actual results:

Described above.

Expected results:

It is expected that old behavior remains -- like viewing attachments in the browser in good old plain text mode with correct indentation.
Instead new behaviour breaks indentation and doesn't allow to view attachments in plain text mode.
Also i wasn't able to find option in preferences to make line-by-line view default and any other options to make bugzilla behave in an old way.

Comment 1 Jeff Fearn 🐞 2019-03-14 03:47:27 UTC

*** This bug has been marked as a duplicate of bug 1658655 ***


Note You need to log in before you can comment on or make changes to this bug.