Bug 165972 - sysklogd fails to build on a rawhide system
sysklogd fails to build on a rawhide system
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: sysklogd (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jason Vas Dias
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-08-15 09:19 EDT by Karsten Hopp
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version: 1.4.1-32
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-04 20:11:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
log of faild build (4.84 KB, text/plain)
2005-08-15 09:20 EDT, Karsten Hopp
no flags Details

  None (edit)
Description Karsten Hopp 2005-08-15 09:19:40 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8b3) Gecko/20050729 Fedora/1.1-0.2.5.deerpark.alpha2 Firefox/1.0+

Description of problem:
package fails to rebuild on a rawhide system, log attached

Version-Release number of selected component (if applicable):
sysklogd-1.4.1-30

How reproducible:
Always

Steps to Reproduce:
1.try to rebuild on a rawhide system
2.
3.
  

Additional info:
Comment 1 Karsten Hopp 2005-08-15 09:20:34 EDT
Created attachment 117744 [details]
log of faild build
Comment 2 Jason Vas Dias 2005-08-15 13:43:50 EDT
This is now fixed with sysklogd-1.4.1-32 .
klogd was including the syslog.o object, and used the vsyslog function
it defines. 
The syslog and vsyslog functions defined by syslog.c do not match the new
prototypes defined by glibc, with their associated '_chk' functions, hence
the compile error.
Defining the glibc syslog functions in sysklogd's own syslog.o was in 
itself a bad idea, since sysklogd's syslog functions do not do any locking.
I've now removed syslog.o from the build and klogd now uses glibc's vsyslog -
I've checked that kernel logging now works fine and all tests pass.

Note You need to log in before you can comment on or make changes to this bug.