Bug 1659727 - Not available LUN with FC-target when running on kernel 4.19 and 4.20
Summary: Not available LUN with FC-target when running on kernel 4.19 and 4.20
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 29
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-12-15 19:13 UTC by Fomalhaut
Modified: 2019-10-13 13:52 UTC (History)
18 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-04-10 18:57:34 UTC
Type: Bug


Attachments (Terms of Use)

Description Fomalhaut 2018-12-15 19:13:51 UTC
Description of problem:
Not available LUN with FC-target when running on kernel 4.19.x. Boot with kernel 4.18.x restores access to the LUN.

Version-Release number of selected component (if applicable):
OS: Fedora 20 x86_64
FC card: QLogic QLE2460

How reproducible:
Connect to the PC storage by FC and boot Fedora 29 x86_64 with any kernel 4.19.x.

Steps to Reproduce:
1. Connect to the PC storage by FC and boot.
2. echo "1" > /sys/class/fc_host/host10/issue_lip
   (host10 - my FC-card)
3. lsscsi

Actual results:
[1:0:0:0]    disk    ATA      KINGSTON SUV400S D6SD  /dev/sda 
[3:0:0:0]    disk    ATA      HGST HUS726060AL W907  /dev/sdb 
[4:0:0:0]    disk    ATA      WDC WD1001FALS-0 0K05  /dev/sdc 
[5:0:0:0]    disk    ATA      WDC WD10EZEX-60Z 0A80  /dev/sdd 
[9:0:0:0]    disk    SanDisk  Cruzer Force     1.00  /dev/sde 
[N:0:1:1]    disk    ADATA SX8000NP__1                          /dev/nvme0n1

Expected results:
[1:0:0:0]    disk    ATA      KINGSTON SUV400S D6SD  /dev/sda
[3:0:0:0]    disk    ATA      HGST HUS726060AL W907  /dev/sdb
[4:0:0:0]    disk    ATA      WDC WD1001FALS-0 0K05  /dev/sdc
[5:0:0:0]    disk    ATA      WDC WD10EZEX-60Z 0A80  /dev/sdd
[9:0:0:0]    disk    SanDisk  Cruzer Force     1.00  /dev/sde
[10:0:0:0]   disk    FreeNAS  TargetLUN        1.00  /dev/sdf
[N:0:1:1]    disk    ADATA SX8000NP__1                          /dev/nvme0n1

Additional info:

# dmesg | grep qla
[    4.688746] qla2xxx [0000:00:00.0]-0005: : QLogic Fibre Channel HBA Driver: 10.00.00.08-k.
[    4.688851] qla2xxx [0000:04:00.0]-001d: : Found an ISP2432 irq 25 iobase 0x0000000015d06336.
[    5.039146] scsi host10: qla2xxx
[    5.040387] qla2xxx [0000:04:00.0]-00fb:10: QLogic QLE2460 - QLogic 4GB FC Single-Port PCI-E HBA for IBM System x.
[    5.040393] qla2xxx [0000:04:00.0]-00fc:10: ISP2432: PCIe (2.5GT/s x4) @ 0000:04:00.0 hdma+ host#=10 fw=8.07.00 (9496).
[   26.263231] qla2xxx [0000:04:00.0]-8038:10: Cable is unplugged...
[ 9670.897702] qla2xxx [0000:04:00.0]-500a:10: LOOP UP detected (4 Gbps).
[ 9672.380012] qla2xxx [0000:04:00.0]-503f:10: ELS IOCB Done -Driver ELS logo error hdl=42 comp_status=0x0 error subcode 1=0x0 error subcode 2=0x0 total_byte=0x74
[ 9673.405205] qla2xxx [0000:04:00.0]-503f:10: ELS IOCB Done -Driver ELS logo error hdl=45 comp_status=0x0 error subcode 1=0x0 error subcode 2=0x0 total_byte=0x74
[ 9674.428961] qla2xxx [0000:04:00.0]-503f:10: ELS IOCB Done -Driver ELS logo error hdl=48 comp_status=0x0 error subcode 1=0x0 error subcode 2=0x0 total_byte=0x74
[ 9675.452971] qla2xxx [0000:04:00.0]-503f:10: ELS IOCB Done -Driver ELS logo error hdl=4b comp_status=0x0 error subcode 1=0x0 error subcode 2=0x0 total_byte=0x74
[ 9676.477154] qla2xxx [0000:04:00.0]-503f:10: ELS IOCB Done -Driver ELS logo error hdl=4e comp_status=0x0 error subcode 1=0x0 error subcode 2=0x0 total_byte=0x74
[ 9677.500979] qla2xxx [0000:04:00.0]-503f:10: ELS IOCB Done -Driver ELS logo error hdl=51 comp_status=0x0 error subcode 1=0x0 error subcode 2=0x0 total_byte=0x74
[ 9678.524943] qla2xxx [0000:04:00.0]-503f:10: ELS IOCB Done -Driver ELS logo error hdl=54 comp_status=0x0 error subcode 1=0x0 error subcode 2=0x0 total_byte=0x74
[ 9679.549110] qla2xxx [0000:04:00.0]-503f:10: ELS IOCB Done -Driver ELS logo error hdl=57 comp_status=0x0 error subcode 1=0x0 error subcode 2=0x0 total_byte=0x74
[ 9680.572939] qla2xxx [0000:04:00.0]-503f:10: ELS IOCB Done -Driver ELS logo error hdl=5a comp_status=0x0 error subcode 1=0x0 error subcode 2=0x0 total_byte=0x74
[ 9681.597239] qla2xxx [0000:04:00.0]-503f:10: ELS IOCB Done -Driver ELS logo error hdl=5d comp_status=0x0 error subcode 1=0x0 error subcode 2=0x0 total_byte=0x74
[ 9682.621194] qla2xxx [0000:04:00.0]-503f:10: ELS IOCB Done -Driver ELS logo error hdl=60 comp_status=0x0 error subcode 1=0x0 error subcode 2=0x0 total_byte=0x74
[ 9683.645257] qla2xxx [0000:04:00.0]-503f:10: ELS IOCB Done -Driver ELS logo error hdl=63 comp_status=0x0 error subcode 1=0x0 error subcode 2=0x0 total_byte=0x74
[ 9684.669116] qla2xxx [0000:04:00.0]-503f:10: ELS IOCB Done -Driver ELS logo error hdl=66 comp_status=0x0 error subcode 1=0x0 error subcode 2=0x0 total_byte=0x74
[ 9685.693115] qla2xxx [0000:04:00.0]-503f:10: ELS IOCB Done -Driver ELS logo error hdl=69 comp_status=0x0 error subcode 1=0x0 error subcode 2=0x0 total_byte=0x74
[ 9686.717172] qla2xxx [0000:04:00.0]-503f:10: ELS IOCB Done -Driver ELS logo error hdl=6c comp_status=0x0 error subcode 1=0x0 error subcode 2=0x0 total_byte=0x74
[ 9687.741974] qla2xxx [0000:04:00.0]-503f:10: ELS IOCB Done -Driver ELS logo error hdl=6f comp_status=0x0 error subcode 1=0x0 error subcode 2=0x0 total_byte=0x74
[ 9688.766084] qla2xxx [0000:04:00.0]-503f:10: ELS IOCB Done -Driver ELS logo error hdl=72 comp_status=0x0 error subcode 1=0x0 error subcode 2=0x0 total_byte=0x74
[ 9689.789064] qla2xxx [0000:04:00.0]-503f:10: ELS IOCB Done -Driver ELS logo error hdl=75 comp_status=0x0 error subcode 1=0x0 error subcode 2=0x0 total_byte=0x74
[ 9690.813248] qla2xxx [0000:04:00.0]-503f:10: ELS IOCB Done -Driver ELS logo error hdl=78 comp_status=0x0 error subcode 1=0x0 error subcode 2=0x0 total_byte=0x74
[ 9691.837043] qla2xxx [0000:04:00.0]-503f:10: ELS IOCB Done -Driver ELS logo error hdl=7b comp_status=0x0 error subcode 1=0x0 error subcode 2=0x0 total_byte=0x74
[ 9692.861063] qla2xxx [0000:04:00.0]-503f:10: ELS IOCB Done -Driver ELS logo error hdl=7e comp_status=0x0 error subcode 1=0x0 error subcode 2=0x0 total_byte=0x74
[ 9693.885246] qla2xxx [0000:04:00.0]-503f:10: ELS IOCB Done -Driver ELS logo error hdl=81 comp_status=0x0 error subcode 1=0x0 error subcode 2=0x0 total_byte=0x74
[ 9694.909282] qla2xxx [0000:04:00.0]-503f:10: ELS IOCB Done -Driver ELS logo error hdl=84 comp_status=0x0 error subcode 1=0x0 error subcode 2=0x0 total_byte=0x74
[ 9695.933266] qla2xxx [0000:04:00.0]-503f:10: ELS IOCB Done -Driver ELS logo error hdl=87 comp_status=0x0 error subcode 1=0x0 error subcode 2=0x0 total_byte=0x74
[ 9696.957156] qla2xxx [0000:04:00.0]-503f:10: ELS IOCB Done -Driver ELS logo error hdl=8a comp_status=0x0 error subcode 1=0x0 error subcode 2=0x0 total_byte=0x74
[ 9697.981160] qla2xxx [0000:04:00.0]-503f:10: ELS IOCB Done -Driver ELS logo error hdl=8d comp_status=0x0 error subcode 1=0x0 error subcode 2=0x0 total_byte=0x74
[ 9699.005224] qla2xxx [0000:04:00.0]-503f:10: ELS IOCB Done -Driver ELS logo error hdl=90 comp_status=0x0 error subcode 1=0x0 error subcode 2=0x0 total_byte=0x74
[ 9700.029139] qla2xxx [0000:04:00.0]-503f:10: ELS IOCB Done -Driver ELS logo error hdl=93 comp_status=0x0 error subcode 1=0x0 error subcode 2=0x0 total_byte=0x74
[ 9701.053249] qla2xxx [0000:04:00.0]-503f:10: ELS IOCB Done -Driver ELS logo error hdl=96 comp_status=0x0 error subcode 1=0x0 error subcode 2=0x0 total_byte=0x74
[ 9702.078165] qla2xxx [0000:04:00.0]-503f:10: ELS IOCB Done -Driver ELS logo error hdl=99 comp_status=0x0 error subcode 1=0x0 error subcode 2=0x0 total_byte=0x74
[ 9703.100992] qla2xxx [0000:04:00.0]-705d:10: Unable to reach remote port 21:00:00:1b:32:18:1e:26
[11747.354237] qla2xxx [0000:04:00.0]-500b:10: LOOP DOWN detected (2 5 0 0).
[11747.875356] qla2xxx [0000:04:00.0]-500a:10: LOOP UP detected (4 Gbps).

Comment 1 Fomalhaut 2018-12-15 19:15:36 UTC
Sorry:
OS: Fedora 29 x86_64

Comment 2 Fomalhaut 2018-12-15 19:22:13 UTC
With kernel 4.18
# dmesg | grep qla
[    4.381653] qla2xxx [0000:00:00.0]-0005: : QLogic Fibre Channel HBA Driver: 10.00.00.07-k.
[    4.381759] qla2xxx [0000:04:00.0]-001d: : Found an ISP2432 irq 25 iobase 0x00000000c6548af0.
[    4.737357] scsi host11: qla2xxx
[    4.738557] qla2xxx [0000:04:00.0]-00fb:11: QLogic QLE2460 - QLogic 4GB FC Single-Port PCI-E HBA for IBM System x.
[    4.738564] qla2xxx [0000:04:00.0]-00fc:11: ISP2432: PCIe (2.5GT/s x4) @ 0000:04:00.0 hdma+ host#=11 fw=8.07.00 (9496).
[    5.007906] qla2xxx [0000:04:00.0]-500a:11: LOOP UP detected (4 Gbps).

Comment 3 predmijat 2018-12-21 13:33:46 UTC
Hi,

Not sure what's the policy here about "+1", but I have the same issue on CentOS 7.6.1810, 4.19.11-1.el7.elrepo (kernel-ml).

Comment 4 Fomalhaut 2018-12-22 12:13:26 UTC
It means not a random bug.
It remains to wait for this report to be taken to work.

Comment 5 predmijat 2018-12-25 08:19:25 UTC
Looks like it's working on 4.20 (4.20.0-1.el7.elrepo.x86_64)

Comment 6 Fomalhaut 2019-01-23 17:07:03 UTC
Installed kernel 4.20, but this did not solve the problem.

# uname -a
Linux fmhstar.homed.local 4.20.3-200.fc29.x86_64 #1 SMP Thu Jan 17 15:19:35 UTC 2019 x86_64 x86_64 x86_64 GNU/Linux

[   27.269872] qla2xxx [0000:04:00.0]-801c:10: Abort command issued nexus=10:0:0 --  0 2003.
[   27.283118] qla2xxx [0000:04:00.0]-8009:10: DEVICE RESET ISSUED nexus=10:0:0 cmd=00000000c3d73d55.
[   31.270772] qla2xxx [0000:04:00.0]-5039:10: Async-tmf error - hdl=7 completion status(6).
[   31.270786] qla2xxx [0000:04:00.0]-8030:10: TM IOCB failed (102).
[   31.270793] qla2xxx [0000:04:00.0]-800c:10: do_reset failed for cmd=00000000c3d73d55.
[   31.270796] qla2xxx [0000:04:00.0]-800f:10: DEVICE RESET FAILED: Task management failed nexus=10:0:0 cmd=00000000c3d73d55.
[   31.270802] qla2xxx [0000:04:00.0]-8009:10: TARGET RESET ISSUED nexus=10:0:0 cmd=00000000c3d73d55.
[   35.270807] qla2xxx [0000:04:00.0]-800e:10: TARGET RESET SUCCEEDED nexus:10:0:0 cmd=00000000c3d73d55.
[   35.271784] qla2xxx [0000:04:00.0]-801c:10: Abort command issued nexus=10:0:0 --  0 2003.
[   35.271789] qla2xxx [0000:04:00.0]-8009:10: DEVICE RESET ISSUED nexus=10:0:0 cmd=00000000c3d73d55.
[   39.234414] qla2xxx [0000:04:00.0]-5039:10: Async-tmf error - hdl=a completion status(6).
[   39.234431] qla2xxx [0000:04:00.0]-8030:10: TM IOCB failed (102).
[   39.234437] qla2xxx [0000:04:00.0]-800c:10: do_reset failed for cmd=00000000c3d73d55.
[   39.234440] qla2xxx [0000:04:00.0]-800f:10: DEVICE RESET FAILED: Task management failed nexus=10:0:0 cmd=00000000c3d73d55.
[   39.234446] qla2xxx [0000:04:00.0]-8009:10: TARGET RESET ISSUED nexus=10:0:0 cmd=00000000c3d73d55.
[   43.266681] qla2xxx [0000:04:00.0]-5039:10: Async-tmf error - hdl=b completion status(6).
[   43.266705] qla2xxx [0000:04:00.0]-8030:10: TM IOCB failed (102).
[   43.266712] qla2xxx [0000:04:00.0]-800c:10: do_reset failed for cmd=00000000c3d73d55.
[   43.266715] qla2xxx [0000:04:00.0]-800f:10: TARGET RESET FAILED: Task management failed nexus=10:0:0 cmd=00000000c3d73d55.
[   43.266721] qla2xxx [0000:04:00.0]-8012:10: BUS RESET ISSUED nexus=10:0:0.
[   47.298915] qla2xxx [0000:04:00.0]-5039:10: Async-tmf error - hdl=c completion status(6).
[   47.298934] qla2xxx [0000:04:00.0]-8030:10: TM IOCB failed (102).
[   47.299708] qla2xxx [0000:04:00.0]-802b:10: BUS RESET SUCCEEDED nexus=10:0:0.
[   48.710842] qla2xxx [0000:04:00.0]-503f:10: ELS IOCB Done -Driver ELS logo error hdl=e comp_status=0x0 error subcode 1=0x0 error subcode 2=0x0 total_byte=0x74
[   50.762047] qla2xxx [0000:04:00.0]-503f:10: ELS IOCB Done -Driver ELS logo error hdl=12 comp_status=0x0 error subcode 1=0x0 error subcode 2=0x0 total_byte=0x74
[   80.006177]  rport-10:0-0: blocked FC remote port time out: removing target and saving binding
[   80.006292] qla2xxx [0000:04:00.0]-8012:10: BUS RESET ISSUED nexus=10:0:0.
[   80.006332] qla2xxx [0000:04:00.0]-5039:10: Async-tmf error - hdl=14 completion status(28).
[   80.006340] qla2xxx [0000:04:00.0]-8030:10: TM IOCB failed (102).
[   80.007090] qla2xxx [0000:04:00.0]-802b:10: BUS RESET SUCCEEDED nexus=10:0:0.
[   81.480263] qla2xxx [0000:04:00.0]-503f:10: ELS IOCB Done -Driver ELS logo error hdl=15 comp_status=0x0 error subcode 1=0x0 error subcode 2=0x0 total_byte=0x74
[   90.246265] qla2xxx [0000:04:00.0]-8018:10: ADAPTER RESET ISSUED nexus=10:0:0.
[   90.246273] qla2xxx [0000:04:00.0]-00af:10: Performing ISP error recovery - ha=00000000c070eb1a.
[   90.821561] qla2xxx [0000:04:00.0]-500a:10: LOOP UP detected (4 Gbps).
[   91.120262] qla2xxx [0000:04:00.0]-8017:10: ADAPTER RESET SUCCEEDED nexus=10:0:0.
[  101.510303] scsi 10:0:0:0: Device offlined - not ready after error recovery
[  131.718347]  rport-10:0-0: blocked FC remote port time out: removing target and saving binding

Comment 7 Fomalhaut 2019-01-23 17:53:58 UTC
The dmesg command output has sdf entries. But sdf is not available (lsscsi)

# dmesg | grep sdf
[   21.342063] sd 11:0:0:1: [sdf] 625142448 512-byte logical blocks: (320 GB/298 GiB)
[   21.342768] sd 11:0:0:1: [sdf] Write Protect is off
[   21.342769] sd 11:0:0:1: [sdf] Mode Sense: 10 00 00 00
[   21.343469] sd 11:0:0:1: [sdf] Write cache: enabled, read cache: enabled, doesn't support DPO or FUA
[   21.369404]  sdf: sdf1 sdf2
[   21.374879] sd 11:0:0:1: [sdf] Attached SCSI disk
[  103.894365] EXT4-fs (sdf2): mounted filesystem with ordered data mode. Opts: (null)
[  181.089649] sd 11:0:0:1: [sdf] Synchronizing SCSI cache

# lsscsi 
[1:0:0:0]    disk    ATA      KINGSTON SUV400S D6SD  /dev/sda 
[3:0:0:0]    disk    ATA      HGST HUS726060AL W907  /dev/sdb 
[4:0:0:0]    disk    ATA      WDC WD1001FALS-0 0K05  /dev/sdc 
[5:0:0:0]    disk    ATA      WDC WD10EZEX-60Z 0A80  /dev/sdd 
[9:0:0:0]    disk    SanDisk  Cruzer Force     1.00  /dev/sde 
[N:0:1:1]    disk    ADATA SX8000NP__1                          /dev/nvme0n1

Comment 8 Fomalhaut 2019-01-23 17:58:35 UTC
Erroneously! "Fomalhaut 2019-01-23 17:53:58 UTC"

Comment 9 Fomalhaut 2019-02-24 19:26:13 UTC
With the latest actual kernel 4.18.16-300, the problem is not solved.

Comment 10 Fomalhaut 2019-03-12 20:29:28 UTC
Checked on 5.0.1 - the problem did not dare.

[root@localhost-live liveuser]# uname -a
Linux localhost-live 5.0.1-300.fc30.x86_64 #1 SMP Mon Mar 11 04:27:50 UTC 2019 x86_64 x86_64 x86_64 GNU/Linux

[root@localhost-live liveuser]# dmesg | grep -iE "qlogic|qla2"
[    4.105541] QLogic iSCSI HBA Driver
[    4.150236] cnic: QLogic cnicDriver v2.5.22 (July 20, 2015)
[    4.153628] QLogic NetXtreme II iSCSI Driver bnx2i v2.7.10.1 (Jul 16, 2014)
[    4.463328] qla2xxx [0000:00:00.0]-0005: : QLogic Fibre Channel HBA Driver: 10.00.00.12-k.
[    4.463447] qla2xxx [0000:04:00.0]-001d: : Found an ISP2432 irq 25 iobase 0x000000001ec98489.
[    4.809360] scsi host11: qla2xxx
[    4.809375] Modules linked in: radeon(+) 8021q garp qla2xxx(+) drm_kms_helper mrp stp llc ttm mxm_wmi crct10dif_pclmul crc32_pclmul igb drm crc32c_intel nvme_fc nvme_fabrics ghash_clmulni_intel nvme uas dca ccp scsi_transport_fc i2c_algo_bit usb_storage nvme_core wmi pinctrl_amd sunrpc be2iscsi bnx2i cnic uio cxgb4i cxgb4 cxgb3i cxgb3 mdio libcxgbi libcxgb qla4xxx iscsi_boot_sysfs iscsi_tcp libiscsi_tcp libiscsi scsi_transport_iscsi loop
[    4.809422]  qla2x00_probe_one+0x1554/0x2dc0 [qla2xxx]
[    4.809452]  qla2x00_module_init+0x1fc/0x24a [qla2xxx]
[    4.810697] qla2xxx [0000:04:00.0]-00fb:11: QLogic QLE2460 - QLogic 4GB FC Single-Port PCI-E HBA for IBM System x.
[    4.810704] qla2xxx [0000:04:00.0]-00fc:11: ISP2432: PCIe (2.5GT/s x4) @ 0000:04:00.0 hdma+ host#=11 fw=8.07.00 (9496).
[    5.168159] qla2xxx [0000:04:00.0]-500a:11: LOOP UP detected (4 Gbps).
[    6.871275] qla2xxx [0000:04:00.0]-503f:11: ELS IOCB Done -Driver ELS logo error hdl=2 comp_status=0x0 error subcode 1=0x0 error subcode 2=0x0 total_byte=0x74
[   27.617353] qla2xxx [0000:04:00.0]-801c:11: Abort command issued nexus=11:0:0 --  0 2003.
[   27.623056] qla2xxx [0000:04:00.0]-8009:11: DEVICE RESET ISSUED nexus=11:0:0 cmd=00000000bd36ad46.
[   31.563996] qla2xxx [0000:04:00.0]-5039:11: Async-tmf error - hdl=7 completion status(6).
[   31.564045] qla2xxx [0000:04:00.0]-8030:11: TM IOCB failed (102).
[   31.564054] qla2xxx [0000:04:00.0]-800c:11: do_reset failed for cmd=00000000bd36ad46.
[   31.564057] qla2xxx [0000:04:00.0]-800f:11: DEVICE RESET FAILED: Task management failed nexus=11:0:0 cmd=00000000bd36ad46.
[   31.564064] qla2xxx [0000:04:00.0]-8009:11: TARGET RESET ISSUED nexus=11:0:0 cmd=00000000bd36ad46.
[   35.596254] qla2xxx [0000:04:00.0]-5039:11: Async-tmf error - hdl=8 completion status(6).
[   35.596302] qla2xxx [0000:04:00.0]-8030:11: TM IOCB failed (102).
[   35.596311] qla2xxx [0000:04:00.0]-800c:11: do_reset failed for cmd=00000000bd36ad46.
[   35.596314] qla2xxx [0000:04:00.0]-800f:11: TARGET RESET FAILED: Task management failed nexus=11:0:0 cmd=00000000bd36ad46.
[   35.596321] qla2xxx [0000:04:00.0]-8012:11: BUS RESET ISSUED nexus=11:0:0.
[   39.628196] qla2xxx [0000:04:00.0]-5039:11: Async-tmf error - hdl=9 completion status(6).
[   39.628299] qla2xxx [0000:04:00.0]-8030:11: TM IOCB failed (102).
[   39.629085] qla2xxx [0000:04:00.0]-802b:11: BUS RESET SUCCEEDED nexus=11:0:0.
[   41.687263] qla2xxx [0000:04:00.0]-503f:11: ELS IOCB Done -Driver ELS logo error hdl=b comp_status=0x0 error subcode 1=0x0 error subcode 2=0x0 total_byte=0x74
[   43.737414] qla2xxx [0000:04:00.0]-503f:11: ELS IOCB Done -Driver ELS logo error hdl=f comp_status=0x0 error subcode 1=0x0 error subcode 2=0x0 total_byte=0x74
[   50.134409] qla2xxx [0000:04:00.0]-8018:11: ADAPTER RESET ISSUED nexus=11:0:0.
[   50.134418] qla2xxx [0000:04:00.0]-00af:11: Performing ISP error recovery - ha=000000002d337e60.
[   50.958054] qla2xxx [0000:04:00.0]-500a:11: LOOP UP detected (4 Gbps).
[   51.006060] qla2xxx [0000:04:00.0]-8017:11: ADAPTER RESET SUCCEEDED nexus=11:0:0.
[   52.952162] qla2xxx [0000:04:00.0]-503f:11: ELS IOCB Done -Driver ELS logo error hdl=2 comp_status=0x0 error subcode 1=0x0 error subcode 2=0x0 total_byte=0x74
[   55.001240] qla2xxx [0000:04:00.0]-503f:11: ELS IOCB Done -Driver ELS logo error hdl=6 comp_status=0x0 error subcode 1=0x0 error subcode 2=0x0 total_byte=0x74

Comment 11 Fomalhaut 2019-03-15 19:44:04 UTC
After executing the command

# echo 1 > /sys/class/fc_host/host10/issue_lip

dmesg reports

[15202.196898] qla2xxx [0000:04:00.0]-1015:10: cmd=0x72, waited 30198 msecs
[15202.196921] qla2xxx [0000:04:00.0]-d04c:10: MBX Command timeout for cmd 72, iocontrol=0 jiffies=100e36400 mb[0-3]=[0x4001 0x4953 0x5020 0x2432] mb7 0x1 host_status 0x40018002 hccr 0x0
[15202.213895] qla2xxx [0000:04:00.0]-d001:10: Firmware dump saved to temp buffer (10/00000000a2e5a748), dump status flags (0x3f).
[15277.973601] qla2xxx [0000:04:00.0]-1015:10: cmd=0x72, waited 30463 msecs
[15277.973622] qla2xxx [0000:04:00.0]-d04c:10: MBX Command timeout for cmd 72, iocontrol=0 jiffies=100e48c00 mb[0-3]=[0x4001 0x4953 0x5020 0x2432] mb7 0x1 host_status 0x40018002 hccr 0x0
[15277.973629] qla2xxx [0000:04:00.0]-d007:10: Firmware has been previously dumped (00000000a2e5a748) -- ignoring request

Comment 12 Fomalhaut 2019-04-10 18:57:10 UTC
Upgrading to the latest available firmware version of the FC adapter helped solve the problem.

Comment 13 Gabi Neculai 2019-10-06 18:09:59 UTC
Hello,

@Fomalhaut What firmware version you upgraded?
I have QLE2462 FW:v8.03.02 and is not working, with exactly the same error.
If you have a newer version what is it and where did you find it from?

On the Qlogic site the latest firmware seems to be 8.00d:

http://driverdownloads.qlogic.com/QLogicDriverDownloads_UI/SearchProductPreviousRelease.aspx?ProductCategory=39&Product=937&Os=167&ResourceCategory=Boot%20Code&grid=1

Comment 14 Fomalhaut 2019-10-08 03:42:25 UTC
Gabi Neculai:
This is not firmware. The latest firmware version I found is 3.29.
I can send my boot image of FreeDOS with this version integrated and the flasher. Send the address where to send.

Comment 15 Gabi Neculai 2019-10-08 04:43:39 UTC
@Fomalhaut: My mail address is gn_ro at yahoo .com
Thank you!

Comment 16 Fomalhaut 2019-10-12 15:56:57 UTC
Gabi Neculai:
Did you get a link to your mailing address?

Comment 17 Gabi Neculai 2019-10-13 13:52:48 UTC
Yes I did, thank you, but I did not had time to use it. I'll post back.


Note You need to log in before you can comment on or make changes to this bug.