Bug 165977 - Panel crashes when any right-stuck applet resizes itself
Panel crashes when any right-stuck applet resizes itself
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gnome-menus (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-08-15 10:04 EDT by Bill Crawford
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version: gnome-menus-2.11.91-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-08-17 11:44:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
core file from crashed gnome-panel. (1.65 MB, application/octet-stream)
2005-08-15 20:03 EDT, Bill Crawford
no flags Details
some debug output from gdb + panel (2.89 KB, text/plain)
2005-08-16 08:48 EDT, Bill Crawford
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 313232 None None None Never

  None (edit)
Description Bill Crawford 2005-08-15 10:04:58 EDT
Description of problem:
When certain applets, placed at the right of the panel (like the clock, or the
systray^Wnotification area) resize themselves (e.g. I open an app with a tray
icon) gnome-panel often crashes (I get a popup saying it has unexpectedly
stopped working, anyway).
Other particular culprits include GAIM, aMule etc etc.
Not sure if it's related, but leaving xmms running for a while seemed to trigger
it too, when I had the window-list menu on the panel too.
I've completely blown away ~/.gconf (gconftool-2 --recursive-unset /apps, ditto
/system, etc; then rm -rf .gconf after logging out of X). Still happens.

Version-Release number of selected component (if applicable):
gnome-panel-2.11.91-2
metacity-2.11.2-1
gnome-applets-2.11.91-2
Comment 1 Bill Crawford 2005-08-15 10:06:13 EDT
Just crashed again as I hit the submit button in firefox to open the bug.
It looks like sometimes just a change in a window title can trigger a crash too.
Comment 2 Bill Crawford 2005-08-15 10:15:56 EDT
Never mind, seems to have been caused by two copies of libwnck on the system.
Comment 3 Bill Crawford 2005-08-15 10:48:38 EDT
Yuck. No, it just didn't happen for a while. Just after gaim changed the tray
icon (becuase I was marked away) the panel crashed again. And it's just done it
again now (five minutes later) while I'm trying to type this.
OK, what can I do to help track down the cause of this? Beyond "when I have
anything changing state in the systray" I mean ...
Comment 4 Mark McLoughlin 2005-08-15 11:29:12 EDT
Thanks for the bug report. Without a stack trace from the crash it is 
very hard to determine what caused the crash. Please see
http://fedoraproject.org/wiki/StackTraces for more information about
getting a useful stack trace.
Comment 5 Bill Crawford 2005-08-15 12:23:09 EDT
I'll have a go, yes - just installing the -debuginfo packages now.
I did click the "inform developers" button but the traces didn't look too useful :-S
Comment 6 Bill Crawford 2005-08-15 15:31:41 EDT
Well, .. I installed all the debugingo packages, and I've attached gdb ... and
it hasn't done it since :)
It *did* crash while I was installing the debug packagess and running prelink,
so I'm gonna write this off as bad luck for now :)
Comment 7 Bill Crawford 2005-08-15 19:54:25 EDT
*sigh* done it again, I have a core dump this time. I'll try to attach it if
'zilla will accept the file.
Comment 8 Bill Crawford 2005-08-15 20:03:19 EDT
Created attachment 117779 [details]
core file from crashed gnome-panel.

I don't know if this will help *that* much ... but I can't make enough sense of
the data to make any deductions beyond "it looks like the menu change monitor"
:)
gnome-panel-2.11.91-2, from rawhide; I've prelinked everything, if that matters
I can pass on a copy of the binary or undo prelinking and try again.
Comment 9 Mark McLoughlin 2005-08-16 02:23:19 EDT
Please don't attach core files, attach a stack trace. See:

  http://fedoraproject.org/wiki/StackTraces

Also, that core file was from gaim, not the panel.
Comment 10 Ryan James 2005-08-16 08:42:04 EDT
i *think* i've been seeing the same thing, but it's only on newer (ie anything
after 1469) kernels.  i looked at, but didn't save, the stack trace from
bugbuddy: #0 was in something that ended in 'vsyscall()' is all i remember. 
i'll get a full trace after yum is done.
Comment 11 Bill Crawford 2005-08-16 08:47:07 EDT
ok .. how do I remove an attachment? and some output from gdb follows
Comment 12 Bill Crawford 2005-08-16 08:48:52 EDT
Created attachment 117788 [details]
some debug output from gdb + panel
Comment 13 Bill Crawford 2005-08-16 09:02:04 EDT
Sorry, it seemed to me the trace alone didn't say much of any use -- the state
of the variables at the time would perhaps explain the segfault, hence the core
file :-S  GAIM dies every time the panel does (presumably related to the tray
icon, 'cause it survives the crash if I disable the icon).  I just assumed the
core file was from the panel 'cause I quit gdb with "signal 6" ... maybe I need
to disable bug-buddy or whatever.

Anyway, if there's any additional info I can prise out of the program state
if/when it crashes again, please tell me, I'm running it with gdb attached.

If it's helpful: last time it crashed, was when I updated a couple of packages;
the next time I clicked on a launcher (the GAIM one, as it happened) *boom*
Comment 14 Mark McLoughlin 2005-08-16 09:46:07 EDT
Looks like a gnome-menus bug which was fixed upstream recently:

* Tue Aug 16 2005 Mark McLoughlin <markmc@redhat.com> 2.11.91-1
- Update to 2.11.91
- Backport patch from HEAD to hopefully fix crasher (rh #165977)


Please re-open if you still see the problem with gnome-menus-2.11.91-1

Comment 15 Mark McLoughlin 2005-08-16 17:04:42 EDT
Upstream bug report:

 http://bugzilla.gnome.org/show_bug.cgi?id=313232
Comment 16 Bill Crawford 2005-08-17 11:25:01 EDT
Reopening due to regression.

Whenever a menu is changed e.g. by installing / upgrading a package, two copies
of all KDE menu items now appear.
Comment 17 Mark McLoughlin 2005-08-17 11:44:38 EDT
Please don't re-open bugs with details of some other bug report. Open a new bug
report.

Thanks for testing, though. I assume this means the crash has been fixed?

The new bug you're referring to is filed upstream at:

  http://bugzilla.gnome.org/show_bug.cgi?id=313624
Comment 18 Bill Crawford 2005-08-17 12:10:30 EDT
Um, ok, ... the crash is gone, but the menus are still messed up; I thought it
best to report that in case it's related ...

I take it there's no need to open a new bug on brc if it's in gnome 'zilla and
will be fixed in the next upstream bump?
Comment 19 Mark McLoughlin 2005-08-18 04:22:22 EDT
Bill: please test gnome-menus-2.11.91-2 now - the "duplicate entries on
updating" issue should be fixed. If you still see that issue or any other new
issues, please do open another bug. Thanks.
Comment 20 Mark McLoughlin 2005-08-18 09:01:09 EDT
gnome-menus-2.11.91-2 had an infinite loop, fixed in gnome-menus-2.11.91-3

Note You need to log in before you can comment on or make changes to this bug.