Bug 1659780 - Uploading/downloading different snapshot disks of the same disk look like the same events
Summary: Uploading/downloading different snapshot disks of the same disk look like the...
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: BLL.Storage
Version: 4.3.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium vote
Target Milestone: ovirt-4.3.5
: ---
Assignee: Tal Nisan
QA Contact: Elad
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-12-16 12:10 UTC by Avihai
Modified: 2019-05-29 13:59 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-05-29 13:59:24 UTC
oVirt Team: Storage
rule-engine: ovirt-4.3+


Attachments (Terms of Use)

Description Avihai 2018-12-16 12:10:43 UTC
Description of problem:
Uploading different snapshot disks of the same disk look like the same event as the snapshot disk name is the same.

So it looks like the same operation was performed multiple times.
Maybe add also the disk id in the event will make it more clear.

In my case I got for 2 different disk snapshots of the same disk(disk_TestCase24989_1612010196) the following events(:
EVENT_ID: TRANSFER_IMAGE_SUCCEEDED(1,032), Image Upload with disk disk_TestCase24989_1612010196 succeeded.
2018-12-16 12:13:02,501+02 INFO  
EVENT_ID: TRANSFER_IMAGE_SUCCEEDED(1,032), Image Download with disk disk_TestCase24989_1612010196 succeeded.


Version-Release number of selected component (if applicable):
ovirt engine - 4.3.0-0.2.master.20181128141347.git38908dd.el7

How reproducible:
100%

Steps to Reproduce:
1.upload/download multiple snapshot disks belonging to the same disk named 'disk1'

Actual results:
Uploading different snapshot disks of the same disk look like the same event as the snapshot disk name is the same.

So it looks like the same operation was performed multiple times.
Maybe add also the disk id in the event will make it more clear.

In my case I got for 2 different disk snapshots of the same disk(disk_TestCase24989_1612010196) the following events(:
EVENT_ID: TRANSFER_IMAGE_SUCCEEDED(1,032), Image Upload with disk disk_TestCase24989_1612010196 succeeded.
2018-12-16 12:13:02,501+02 INFO  
EVENT_ID: TRANSFER_IMAGE_SUCCEEDED(1,032), Image Download with disk disk_TestCase24989_1612010196 succeeded.

Expected results:
I think we should add a clear event message for snapshot disk upload/download like:
"Uploading/Downloading snapshot disk id X"

In this way, it's clear what you are downloading/uploading in a unique way by using snapshot disk id and not the confusing disk name which is the same in this case. 

Additional info:

Comment 1 Sandro Bonazzola 2019-01-28 09:34:40 UTC
This bug has not been marked as blocker for oVirt 4.3.0.
Since we are releasing it tomorrow, January 29th, this bug has been re-targeted to 4.3.1.

Comment 2 Tal Nisan 2019-05-29 13:59:24 UTC
The content of the message itself says whether it's upload or download, I think that's sufficient, changing the audit log types now is not something I think is right to do as they already exist in their current form in customers databases


Note You need to log in before you can comment on or make changes to this bug.