Bug 165979 - libreadline not linked against -lcurses
libreadline not linked against -lcurses
Status: CLOSED DUPLICATE of bug 162023
Product: Fedora
Classification: Fedora
Component: readline (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-08-15 10:12 EDT by Joe Orton
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-08-15 11:09:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joe Orton 2005-08-15 10:12:31 EDT
[root@trash ~]# ldd -r /usr/lib/libreadline.so.5
undefined symbol: BC    (/usr/lib/libreadline.so.5)
undefined symbol: PC    (/usr/lib/libreadline.so.5)
undefined symbol: UP    (/usr/lib/libreadline.so.5)
undefined symbol: tgetnum       (/usr/lib/libreadline.so.5)
...

[root@trash ~]# rpm -qf /usr/lib/libreadline.so.5
readline-5.0-3

curses must win some "worst choice of global symbol name" prize for BC, PC and UP.
Comment 1 Tim Waugh 2005-08-15 11:09:32 EDT

*** This bug has been marked as a duplicate of 162023 ***

Note You need to log in before you can comment on or make changes to this bug.