Bug 1659801 - Template settings are not saved while creating new High Performance VM from template.
Summary: Template settings are not saved while creating new High Performance VM from t...
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: BLL.Virt
Version: 4.3.0
Hardware: x86_64
OS: Linux
unspecified
medium vote
Target Milestone: ovirt-4.3.0
: ---
Assignee: Sharon Gratch
QA Contact: Polina
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-12-16 15:39 UTC by Polina
Modified: 2018-12-28 12:44 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-12-28 12:44:27 UTC
oVirt Team: Virt
rule-engine: ovirt-4.3+


Attachments (Terms of Use)
screenshots (433.75 KB, application/gzip)
2018-12-16 15:39 UTC, Polina
no flags Details

Description Polina 2018-12-16 15:39:55 UTC
Created attachment 1514870 [details]
screenshots

Description of problem:Template settings are not saved while creating new High Performance VM.

Version-Release number of selected component (if applicable):
ovirt-engine-4.3.0-0.2.master.20181203100035.git0ee44c1.el7.noarch

How reproducible:100%

Steps to Reproduce:
1. Open create new VM dialog.
2. Choose Template (imported from glance before)
3. Choose Optimized for High Performance, Name , ok for create .

Actual results: open edit dialog for the created vm  - no template (please see attachment).

Expected results: template settings must be saved (the same as for Desktop)


Additional info:

Comment 1 Ryan Barry 2018-12-17 01:15:02 UTC
Sharon, is this also part of the expected workflow for adding cluster specific data?

Comment 2 Sharon Gratch 2018-12-17 12:33:26 UTC
The Settings inherited from template are saved as required (except cluster specific parameters) but the template field is switched to Blank instead of keeping the origin template that this VM is based on.

Comment 3 Sharon Gratch 2018-12-17 12:39:43 UTC
(In reply to Ryan Barry from comment #1)
> Sharon, is this also part of the expected workflow for adding cluster
> specific data?

It's not part of the workflow for adding cluster specific data. It should be fixed regardless to that.
Even before debugging it looks like somewhere during the process of creating the VM of HP type, the template name is lost somewhere along the events chain in the UI.

Comment 4 Sharon Gratch 2018-12-28 12:44:27 UTC
After checking this I then realized that it's not a bug but a required UI behaviour and that was also the behaviour on previous versions.

Explanation:
The issue described in this bug occurs and is relevant for both "Server" and "High Performance" VMs types.
When creating a "Server"/"High Performance" VM based on a template, the default storage allocation for those types is set to "clone" (optimized for the speed of read/write operations). A Cloned VM from a template inherits the settings of the template but doesn't depend on that template on which it was based after it has been created. This means that the template can be deleted if no other dependencies exist for it. That is why in such a case we display a "Blank" template name for that VM in "edit VM" dialog.

The default storage allocation for creating a "Desktop" type VM is "thin" (Disk space is allocated only as it is required). a VM created from a template with "thin" storage allocation depends on that template and the template can be deleted. That is why for "Desktop" VM types the template name is still displayed in edit vm dialog.

Note that those defaults can be changed via "new VM" -> "resource allocation" tab -> "Storage Allocation" -> Thin/Clone radio buttons.


Therefore I'm closing this bug.


Note You need to log in before you can comment on or make changes to this bug.