Bug 1659809 - Firefox downloads some updates on its own and requires restart instead of opening new URLs
Summary: Firefox downloads some updates on its own and requires restart instead of ope...
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: firefox
Version: 29
Hardware: x86_64
OS: Linux
unspecified
low
Target Milestone: ---
Assignee: Gecko Maintainer
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-12-16 17:08 UTC by Ivan Mironov
Modified: 2018-12-16 17:15 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-12-16 17:15:26 UTC


Attachments (Terms of Use)

Description Ivan Mironov 2018-12-16 17:08:47 UTC
Description of problem:
Sometimes, when I am trying to open a new URL, Firefox shows me some internal page with following messages:

    We have just installed an update in the background. Click Restart Firefox to finish applying it.
    We will restore all your pages, windows and tabs afterwards, so you can be on your way quickly.


Version-Release number of selected component (if applicable):
firefox-64.0-4.fc29.x86_64


How reproducible:
This happens from time to time.


Steps to Reproduce:
There is no specific reproduction steps. It seems that Firefox periodically downloads some updates bypassing the normal package upgrade methods in Linux distributions.

So, just try to open a new tab with some URL when Firefox on its own already downloaded update which requires restart.


Actual results:
Page with following messages:

    We have just installed an update in the background. Click Restart Firefox to finish applying it.
    We will restore all your pages, windows and tabs afterwards, so you can be on your way quickly.


Expected results:
1. Firefox should open URL as usual.
2. Firefox should not silently download any updates.


Additional info:
N/A

Comment 1 Ivan Mironov 2018-12-16 17:15:26 UTC
It looks like I missed an update by dnf:

/var/log/dnf.rpm.log-20181216:2018-12-15T11:58:00Z SUBDEBUG Upgrade: firefox-64.0-4.fc29.x86_64
/var/log/dnf.rpm.log-20181216:2018-12-15T11:58:08Z SUBDEBUG Upgrade: firefox-64.0-4.fc29.x86_64

And Firefox just detected it with some lag.


Note You need to log in before you can comment on or make changes to this bug.