Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1659811 - container-tools:1.0 FTBFS
Summary: container-tools:1.0 FTBFS
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 8
Classification: Red Hat
Component: container-tools-1.0-module
Version: 8.0
Hardware: Unspecified
OS: Unspecified
unspecified
urgent
Target Milestone: rc
: 8.0
Assignee: Lokesh Mandvekar
QA Contact: atomic-bugs@redhat.com
URL:
Whiteboard:
Depends On:
Blocks: 1658633
TreeView+ depends on / blocked
 
Reported: 2018-12-16 17:23 UTC by Petr Šabata
Modified: 2019-06-14 01:29 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-06-14 01:29:34 UTC
Type: Bug
Target Upstream Version:


Attachments (Terms of Use)

Description Petr Šabata 2018-12-16 17:23:48 UTC
container-tools:1.0 fails to build from source.

A number of builds are failing:
https://mbs.engineering.redhat.com/module-build-service/1/module-builds/2439

Checking a few random root.logs, it appears the issue is the packages buildrequire "go-toolset" which the go-toolset-1.10:1.10 module doesn't provide.

My guess would be you need to depend on go-toolset-1.10, some virtual provide, or build against go-toolset:rhel8 instead.  I'd suggest consulting this with the go-toolset maintainers.


Once resolved, please rebuild the module with --optional rebuild_strategy=all.

Comment 2 Petr Šabata 2019-01-07 12:40:16 UTC
Ack.  There was a full rebuild performed since the bug was filed, so I'll assume it's okay.

Comment 3 Joy Pu 2019-02-22 06:17:24 UTC
Update this to verified based on comment #2.


Note You need to log in before you can comment on or make changes to this bug.