Bug 1659850 - [Next_gen_installer] OVS 2.11 should be used for OCP 4.0
Summary: [Next_gen_installer] OVS 2.11 should be used for OCP 4.0
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Networking
Version: 4.1.0
Hardware: All
OS: All
urgent
urgent
Target Milestone: ---
: 4.1.0
Assignee: Casey Callendrello
QA Contact: Meng Bo
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-12-17 02:36 UTC by zhaozhanqi
Modified: 2019-06-04 10:41 UTC (History)
13 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-06-04 10:41:16 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:0758 None None None 2019-06-04 10:41:21 UTC

Description zhaozhanqi 2018-12-17 02:36:50 UTC
Description of problem:
Setup the openshift 4.0 with next_gen_installer. Found the ovs version is 2.7. I checked the 3.11 is using 2.9. So in 4.0. the ovs version should be more than 2.9.

Version-Release number of selected component (if applicable):
oc v4.0.0-alpha.0+3d38233-777
kubernetes v1.11.0+3d38233
features: Basic-Auth GSSAPI Kerberos SPNEGO

How reproducible:
always

Steps to Reproduce:
1. setup the openshift 4.0 with next_gen_installer
2. Check the ovs version
3.

Actual results:

the ovs version is 2.7

Expected results:

should be more than 2.9.

Additional info:

Comment 1 Wei Sun 2018-12-17 06:27:30 UTC
This bug is blocking the testing against the latest OVS

Comment 2 Weibin Liang 2018-12-19 19:23:37 UTC
[root@ip-10-0-14-10 tmp]# oc version
oc v4.0.0-alpha.0+1a648b7-792
kubernetes v1.11.0+1a648b7
features: Basic-Auth GSSAPI Kerberos SPNEGO

Server https://qe-weliang-api.devcluster.openshift.com:6443
kubernetes v1.11.0+1a648b7
[root@ip-10-0-14-10 tmp]# oc get pods -n openshift-sdn
NAME                   READY     STATUS    RESTARTS   AGE
ovs-5hjmf              1/1       Running   0          2h
ovs-898cq              1/1       Running   0          2h
ovs-8pqmz              1/1       Running   0          2h
ovs-kfdql              1/1       Running   0          2h
ovs-mwg9d              1/1       Running   0          2h
ovs-mxrsp              1/1       Running   0          2h
sdn-4p9b6              1/1       Running   0          2h
sdn-9wx7r              1/1       Running   0          2h
sdn-controller-jlxw6   1/1       Running   0          2h
sdn-controller-lvb69   1/1       Running   0          2h
sdn-controller-rj98t   1/1       Running   1          2h
sdn-kvb2q              1/1       Running   0          2h
sdn-n6c9v              1/1       Running   0          2h
sdn-nt8nc              1/1       Running   0          2h
sdn-xlqlh              1/1       Running   0          2h
[root@ip-10-0-14-10 tmp]# oc rsh ovs-5hjmf
sh-4.2# ovs-vsctl --version
ovs-vsctl (Open vSwitch) 2.7.0
DB Schema 7.14.0
sh-4.2#

Comment 3 Casey Callendrello 2018-12-19 19:34:28 UTC
You will need to use the images built with the rhel + fast data path base image, not with centos, to get the latest ovs.

Comment 5 Meng Bo 2019-01-02 08:20:32 UTC
Checked on the downstream ose-node:v4.0 image, the ovs version is 2.9 which is still incorrect.

We need to use ovs-2.11

# docker run -it --entrypoint bash 5d9bfe4f0953
[root@2062c64825d4 origin]# rpm -qa | grep openvs
openvswitch-selinux-extra-policy-1.0-7.el7fdp.noarch
openvswitch-2.9.0-70.el7fdp.1.x86_64
[root@2062c64825d4 origin]# cat /etc/redhat-release 
Red Hat Enterprise Linux Server release 7.6 (Maipo)
[root@2062c64825d4 origin]#

Comment 8 Rashid Khan 2019-02-20 20:52:11 UTC
Raised the priority a bit because of the short fuse for 4.0

Comment 10 Ben Bennett 2019-03-22 16:48:08 UTC
I just spun up a 4.1 cluster and it has:
  openvswitch2.11-2.11.0-0.20190129gitd3a10db.el7fdp.x86_64

Comment 11 zhaozhanqi 2019-03-25 09:06:58 UTC
Verified this bug on 4.0.0-0.nightly-2019-03-23-183709

the ovs version now is 2.11 

oc rsh -n openshift-sdn sdn-svxjf ovs-ofctl --version
ovs-ofctl (Open vSwitch) 2.11.0
OpenFlow versions 0x1:0x5

Comment 13 errata-xmlrpc 2019-06-04 10:41:16 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0758


Note You need to log in before you can comment on or make changes to this bug.