Bug 1659869 - improvements to io-cache
Summary: improvements to io-cache
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: io-cache
Version: mainline
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
Assignee: Raghavendra G
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-12-17 05:28 UTC by Raghavendra G
Modified: 2019-03-25 16:32 UTC (History)
5 users (show)

Fixed In Version: glusterfs-6.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-03-25 16:32:47 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)
paper describing performance of glusterfs on ssds (1.08 MB, application/pdf)
2018-12-17 05:28 UTC, Raghavendra G
no flags Details


Links
System ID Priority Status Summary Last Updated
Gluster.org Gerrit 21398 None Open performance/io-cache: update pages with write data 2018-12-18 09:19:58 UTC

Internal Links: 1785520

Description Raghavendra G 2018-12-17 05:28:35 UTC
Created attachment 1514967 [details]
paper describing performance of glusterfs on ssds

Description of problem:
While working on bz 1629589,

* xavi pointed out io-cache could be the right place for current writes to update the already-read data (another one is read-ahead).
* me and xavi both found out default page-size of io-cache (128K) is too agressive and causes performance regression for random read workloads. This was also reported in the paper attached. The paper was pointed out by Shawn Houston from Red Hat. I assume the cache being referred in the paper refers to io-cache.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Raghavendra G 2018-12-17 05:30:48 UTC
I am proposing to have 8k as the default page-size for io-cache.

Comment 2 Worker Ant 2018-12-17 05:33:05 UTC
REVIEW: https://review.gluster.org/21398 (performance/io-cache: update pages with write data) posted (#4) for review on master by Raghavendra G

Comment 3 Worker Ant 2018-12-18 09:19:57 UTC
REVIEW: https://review.gluster.org/21398 (performance/io-cache: update pages with write data) posted (#5) for review on master by Raghavendra G

Comment 4 Shyamsundar 2019-03-25 16:32:47 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-6.0, please open a new bug report.

glusterfs-6.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://lists.gluster.org/pipermail/announce/2019-March/000120.html
[2] https://www.gluster.org/pipermail/gluster-users/


Note You need to log in before you can comment on or make changes to this bug.