Bug 1659897 - No error judgement when set incorrect patameters in image-registry
Summary: No error judgement when set incorrect patameters in image-registry
Keywords:
Status: CLOSED DUPLICATE of bug 1705752
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Image Registry
Version: 4.1.0
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: ---
: 4.1.0
Assignee: Oleg Bulatov
QA Contact: Wenjing Zheng
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-12-17 07:09 UTC by Wenjing Zheng
Modified: 2019-06-07 12:27 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-06-07 12:27:22 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Wenjing Zheng 2018-12-17 07:09:32 UTC
Description of problem:
Change some parameters in imageregistries image-registry to be invalid ones, no error appears, like change  imagePullPolicy: Invalid or logging: level: invalid.

Version-Release number of selected component (if applicable):
openshift-install v0.7.0-master-6-g8f02020b59147c933a08c5e248a8e2c69dad24ae

How reproducible:
always

Steps to Reproduce:
1.Update some parameters in imageregistries image-registry to be invalid ones
imagePullPolicy: Invalid 
or
logging: 
  level: invalid.
2.
3.

Actual results:
No error appears when try to save.

Expected results:
Should have warning on what is expected.

Additional info:

Comment 1 Oleg Bulatov 2019-01-02 11:48:23 UTC
It's a nice-to-have feature, but this is not our goal for 4.0. Informers can't return invalid objects (with a non-integer log level, for example), therefore our current approach can't handle such objects. We need to implement a validation hook, which requires considerable efforts.

Comment 2 Adam Kaplan 2019-03-05 14:35:31 UTC
We've recently added support for OpenAPI validators on CRDs, so these can be added over time (not for 4.0.0)

Comment 3 Oleg Bulatov 2019-06-07 12:27:22 UTC
Fixed by adding OpenAPI schema

*** This bug has been marked as a duplicate of bug 1705752 ***


Note You need to log in before you can comment on or make changes to this bug.